summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-12-09 13:56:25 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-12-09 13:56:25 +0000
commitf32c4c8bdae4e61c44cb02393de6ed2965902d36 (patch)
treebe58c1389f49640ba5a50dd398083fb122fbf034
parentVersion bump (diff)
downloadgentoo-2-f32c4c8bdae4e61c44cb02393de6ed2965902d36.tar.gz
gentoo-2-f32c4c8bdae4e61c44cb02393de6ed2965902d36.tar.bz2
gentoo-2-f32c4c8bdae4e61c44cb02393de6ed2965902d36.zip
Add run-as-root useflag, by Marco Meier <mmeier@badeio.de>, bug #249451
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.8 x86_64)
-rw-r--r--media-video/vlc/ChangeLog6
-rw-r--r--media-video/vlc/metadata.xml1
-rw-r--r--media-video/vlc/vlc-0.9.8a.ebuild5
3 files changed, 9 insertions, 3 deletions
diff --git a/media-video/vlc/ChangeLog b/media-video/vlc/ChangeLog
index 283e7a201fc5..3e5328c07fc2 100644
--- a/media-video/vlc/ChangeLog
+++ b/media-video/vlc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/vlc
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.412 2008/12/05 08:51:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.413 2008/12/09 13:56:25 aballier Exp $
+
+ 09 Dec 2008; Alexis Ballier <aballier@gentoo.org> metadata.xml,
+ vlc-0.9.8a.ebuild:
+ Add run-as-root useflag, by Marco Meier <mmeier@badeio.de>, bug #249451
*vlc-0.9.8a (05 Dec 2008)
diff --git a/media-video/vlc/metadata.xml b/media-video/vlc/metadata.xml
index 96229adc03e4..878cdf5598ee 100644
--- a/media-video/vlc/metadata.xml
+++ b/media-video/vlc/metadata.xml
@@ -31,6 +31,7 @@
<flag name="qt4" restrict="&gt;=media-video/vlc-0.9">Builds a <pkg>x11-libs/qt</pkg> based frontend. It is now the most up-to-date graphical interface available.</flag>
<flag name="remoteosd">Enables RemoteOSD plugin (VNC client as video filter).</flag>
<flag name="rtsp">Enables real audio and RTSP modules.</flag>
+ <flag name="run-as-root">Allows vlc to start for root. Don't enable this unless you have a very specific (e.g. embedded) need for it!</flag>
<flag name="schroedinger">Enable Dirac video support (an advanced royalty-free video compression format) via libschroedinger (high-speed implementation in C of the Dirac codec).</flag>
<flag name="sdl-image">Enables sdl image video decoder (depends on sdl)</flag>
<flag name="shout">Enables libshout output.</flag>
diff --git a/media-video/vlc/vlc-0.9.8a.ebuild b/media-video/vlc/vlc-0.9.8a.ebuild
index 9fccf0250555..1923c7113060 100644
--- a/media-video/vlc/vlc-0.9.8a.ebuild
+++ b/media-video/vlc/vlc-0.9.8a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.9.8a.ebuild,v 1.1 2008/12/05 08:51:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.9.8a.ebuild,v 1.2 2008/12/09 13:56:25 aballier Exp $
EAPI="1"
@@ -42,7 +42,7 @@ IUSE="a52 aac aalib alsa altivec arts atmo avahi bidi cdda cddb cdio dbus dc1394
debug dirac directfb dts dvb dvd esd fbcon fluidsynth +ffmpeg flac fontconfig ggi gnome gnutls hal httpd
id3tag jack kate libass libcaca +libgcrypt libnotify libsysfs libv4l2 lirc live lua matroska mmx modplug mp3 mpeg
musepack ncurses nsplugin ogg opengl optimisememory oss png pulseaudio pvr +qt4
- remoteosd rtsp samba schroedinger sdl sdl-image seamonkey shout skins speex sse stream svg svga taglib
+ remoteosd rtsp run-as-root samba schroedinger sdl sdl-image seamonkey shout skins speex sse stream svg svga taglib
theora truetype twolame upnp v4l v4l2 vcd vcdinfo vcdx vlm vorbis win32codecs
X x264 xinerama xml xosd xv zvbi"
@@ -302,6 +302,7 @@ src_compile () {
$(use_enable pvr) \
$(use_enable qt4) \
$(use_enable rtsp realrtsp) \
+ $(use_enable run-as-root) \
$(use_enable samba smb) \
$(use_enable schroedinger) \
$(use_enable sdl) \