summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-05 01:28:34 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-05 01:28:34 +0000
commite0f788bff983d3187e7b0fe61eaa86db4d808b0f (patch)
treea68e4ef3d740ae92595500bb05773d0156f02e4e
parentIncrease functionalization to the point that the primary functions are actual... (diff)
downloadgentoo-2-e0f788bff983d3187e7b0fe61eaa86db4d808b0f.tar.gz
gentoo-2-e0f788bff983d3187e7b0fe61eaa86db4d808b0f.tar.bz2
gentoo-2-e0f788bff983d3187e7b0fe61eaa86db4d808b0f.zip
$CC -> $(tc-getCC)
-rw-r--r--sys-apps/mii-diag/mii-diag-2.07.ebuild25
-rw-r--r--sys-apps/mii-diag/mii-diag-2.09.ebuild25
-rw-r--r--sys-apps/mpi350-driver/mpi350-driver-2.0.ebuild30
-rw-r--r--sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild10
-rw-r--r--sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild19
5 files changed, 53 insertions, 56 deletions
diff --git a/sys-apps/mii-diag/mii-diag-2.07.ebuild b/sys-apps/mii-diag/mii-diag-2.07.ebuild
index cf8805754306..174581080f14 100644
--- a/sys-apps/mii-diag/mii-diag-2.07.ebuild
+++ b/sys-apps/mii-diag/mii-diag-2.07.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/mii-diag/mii-diag-2.07.ebuild,v 1.7 2004/06/24 22:16:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mii-diag/mii-diag-2.07.ebuild,v 1.8 2004/11/05 01:25:25 vapier Exp $
-inherit eutils
+inherit eutils toolchain-funcs
MIIVER=${PV}
LIBVER=2.04
@@ -13,27 +13,30 @@ HOMEPAGE="http://www.scyld.com/diag/"
# with version suffixes.
SRC_URI="" # ftp://ftp.scyld.com/pub/diag/mii-diag.c
# ftp://ftp.scyld.com/pub/diag/libmii.c
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 amd64 alpha"
+KEYWORDS="alpha amd64 x86"
IUSE=""
+
DEPEND=""
+S=${WORKDIR}
+
src_unpack() {
- mkdir -p ${S} || die
- cd ${S} || die
- cp ${FILESDIR}/mii-diag.c-${MIIVER} mii-diag.c || die
- cp ${FILESDIR}/libmii.c-${LIBVER} libmii.c || die
- epatch ${FILESDIR}/mii-diag.c-2.07-gcc33.patch # epatch contains die
+ cp ${FILESDIR}/mii-diag.c-${MIIVER} mii-diag.c || die "mii-diag.c"
+ cp ${FILESDIR}/libmii.c-${LIBVER} libmii.c || die "libmii.c"
+ epatch ${FILESDIR}/mii-diag.c-${PV}-gcc33.patch
}
src_compile() {
# Don't change -O below, it is a requirement for building these
# programs. See http://www.scyld.com/diag/#compiling
- ${CC-gcc} -O -c libmii.c || die
- ${CC-gcc} -O -DLIBMII mii-diag.c libmii.o -o mii-diag || die
+ $(tc-getCC) -O -c libmii.c || die
+ $(tc-getCC) -O -DLIBMII mii-diag.c libmii.o -o mii-diag || die
}
src_install() {
- into /; dosbin mii-diag || die
+ into /
+ dosbin mii-diag || die
}
diff --git a/sys-apps/mii-diag/mii-diag-2.09.ebuild b/sys-apps/mii-diag/mii-diag-2.09.ebuild
index d1bec5884489..14631696bd9c 100644
--- a/sys-apps/mii-diag/mii-diag-2.09.ebuild
+++ b/sys-apps/mii-diag/mii-diag-2.09.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/mii-diag/mii-diag-2.09.ebuild,v 1.3 2004/06/24 22:16:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mii-diag/mii-diag-2.09.ebuild,v 1.4 2004/11/05 01:25:25 vapier Exp $
-inherit eutils
+inherit eutils toolchain-funcs
MIIVER=${PV}
LIBVER=2.10
@@ -13,27 +13,30 @@ HOMEPAGE="http://www.scyld.com/diag/"
# with version suffixes.
SRC_URI="" # ftp://ftp.scyld.com/pub/diag/mii-diag.c
# ftp://ftp.scyld.com/pub/diag/libmii.c
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64 ~alpha"
+KEYWORDS="~alpha ~amd64 ~x86"
IUSE=""
+
DEPEND=""
+S=${WORKDIR}
+
src_unpack() {
- mkdir -p ${S} || die
- cd ${S} || die
- cp ${FILESDIR}/mii-diag.c-${MIIVER} mii-diag.c || die
- cp ${FILESDIR}/libmii.c-${LIBVER} libmii.c || die
- epatch ${FILESDIR}/mii-diag.c-2.09-gcc33.patch # epatch contains die
+ cp ${FILESDIR}/mii-diag.c-${MIIVER} mii-diag.c || die "mii-diag.c"
+ cp ${FILESDIR}/libmii.c-${LIBVER} libmii.c || die "libmii.c"
+ epatch ${FILESDIR}/mii-diag.c-${PV}-gcc33.patch
}
src_compile() {
# Don't change -O below, it is a requirement for building these
# programs. See http://www.scyld.com/diag/#compiling
- ${CC-gcc} -O -c libmii.c || die
- ${CC-gcc} -O -DLIBMII mii-diag.c libmii.o -o mii-diag || die
+ $(tc-getCC) -O -c libmii.c || die
+ $(tc-getCC) -O -DLIBMII mii-diag.c libmii.o -o mii-diag || die
}
src_install() {
- into /; dosbin mii-diag || die
+ into /
+ dosbin mii-diag || die
}
diff --git a/sys-apps/mpi350-driver/mpi350-driver-2.0.ebuild b/sys-apps/mpi350-driver/mpi350-driver-2.0.ebuild
index 26930303004f..8291d211b798 100644
--- a/sys-apps/mpi350-driver/mpi350-driver-2.0.ebuild
+++ b/sys-apps/mpi350-driver/mpi350-driver-2.0.ebuild
@@ -1,26 +1,21 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/mpi350-driver/mpi350-driver-2.0.ebuild,v 1.7 2004/07/15 02:00:54 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mpi350-driver/mpi350-driver-2.0.ebuild,v 1.8 2004/11/05 01:27:21 vapier Exp $
DESCRIPTION="Cisco's wireless drivers and utilities"
-
HOMEPAGE="http://www.cisco.com/"
-
-SRC_DOWNLOAD="http://www.cisco.com/public/sw-center/sw-wireless.shtml"
SRC_URI="Linux-ACU-Driver-v2.0.tar.gz"
-RESTRICT="fetch"
LICENSE="MPL-1.1"
-
SLOT="0"
-KEYWORDS="x86 amd64 -ppc -sparc"
-
+KEYWORDS="amd64 x86"
IUSE=""
+RESTRICT="fetch"
DEPEND=""
-MOD_DIR="/lib/modules/`uname -r`"
-KERNEL_SRC="/usr/src/linux"
+MOD_DIR="/lib/modules/${KV}"
+KERNEL_SRC="${ROOT}/usr/src/linux"
# ------------------------------------------------- #
# The script that Cisco provides is basically
@@ -31,14 +26,9 @@ KERNEL_SRC="/usr/src/linux"
# ------------------------------------------------- #
pkg_nofetch() {
- eerror "Please download ${SRC_URI} from ${SRC_DOWNLOAD}"
- eerror "and put it in ${DISTDIR}."
-}
-
-src_unpack() {
- mkdir ${S}
- cd ${S}
- unpack ${A}
+ einfo "Please download ${SRC_URI} from"
+ einfo "http://www.cisco.com/public/sw-center/sw-wireless.shtml"
+ einfo "and put it in ${DISTDIR}"
}
src_compile() {
@@ -47,8 +37,7 @@ src_compile() {
# Thus we compile them by hand here.
cd ${S}/driver
- einfo "Compiling mpi350.o"
- ${CC} -MD -Wall -I${KERNEL_SRC}/include -D__KERNEL__ -DMODULE -c ${S}/driver/mpi350.c
+ $(tc-getCC) -MD -Wall -I${KERNEL_SRC}/include -D__KERNEL__ -DMODULE -c ${S}/driver/mpi350.c || die
}
src_install() {
@@ -80,6 +69,7 @@ src_install() {
cd ${S}
dodoc ethX.cfg readme.txt
}
+
pkg_postinst() {
einfo "The cisco utilities are placed in /opt/cisco/bin"
einfo "To use them either add them to your PATH, or"
diff --git a/sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild b/sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild
index 7fd3faf0139c..12b8ea45694f 100644
--- a/sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild
+++ b/sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild,v 1.15 2004/07/15 02:36:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild,v 1.16 2004/11/05 01:28:34 vapier Exp $
-DESCRIPTION="Starting and stopping daemontools managed services."
+DESCRIPTION="Starting and stopping daemontools managed services"
HOMEPAGE="http://untroubled.org/supervise-scripts/"
SRC_URI="http://untroubled.org/supervise-scripts/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 amd64 ppc sparc"
+KEYWORDS="amd64 ppc sparc x86"
IUSE=""
RDEPEND=">=sys-apps/daemontools-0.70"
@@ -23,7 +23,7 @@ src_install() {
svc-add svc-isdown svc-isup svc-remove \
svc-start svc-status svc-stop \
svc-waitdown svc-waitup svscan-add-to-inittab \
- svscan-start svscan-stopall
- dodoc ANNOUNCEMENT COPYING ChangeLog NEWS README TODO VERSION
+ svscan-start svscan-stopall || die
+ dodoc ANNOUNCEMENT ChangeLog NEWS README TODO VERSION
doman *.[0-9]
}
diff --git a/sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild b/sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild
index 9c1a97c712a2..018e49c24539 100644
--- a/sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild
+++ b/sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild
@@ -1,21 +1,22 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild,v 1.12 2004/09/03 21:03:24 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild,v 1.13 2004/11/05 01:28:34 vapier Exp $
inherit fixheadtails
-DESCRIPTION="Starting and stopping daemontools managed services."
+
+DESCRIPTION="Starting and stopping daemontools managed services"
HOMEPAGE="http://untroubled.org/supervise-scripts/"
SRC_URI="http://untroubled.org/supervise-scripts/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 amd64 ppc sparc alpha"
+KEYWORDS="alpha amd64 ppc sparc x86"
IUSE=""
RDEPEND=">=sys-apps/daemontools-0.70"
DEPEND=">=sys-apps/daemontools-0.70
- dev-libs/bglibs
- sys-devel/gcc-config"
+ dev-libs/bglibs
+ sys-devel/gcc-config"
src_unpack() {
unpack ${A}
@@ -23,8 +24,8 @@ src_unpack() {
echo '/usr/bin' > conf-bin
echo '/usr/lib/bglibs/lib' > conf-bglibs
echo '/usr/lib/bglibs/include' > conf-bgincs
- echo "${CC} ${CFLAGS}" >conf-cc
- echo "${CC} ${LDFLAGS}" >conf-ld
+ echo "$(tc-getCC) ${CFLAGS}" >conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" >conf-ld
ht_fix_file svscan-add-to-inittab.in Makefile
}
@@ -37,7 +38,7 @@ src_install() {
dobin svc-add svc-isdown svc-isup svc-remove \
svc-start svc-status svc-stop svc-restart \
svc-waitdown svc-waitup svscan-add-to-inittab \
- svscan-add-to-inittab svscan-start svscan-stopall
- dodoc ANNOUNCEMENT COPYING ChangeLog NEWS README TODO VERSION
+ svscan-add-to-inittab svscan-start svscan-stopall || die
+ dodoc ANNOUNCEMENT ChangeLog NEWS README TODO VERSION
doman *.[0-9]
}