summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-02-01 09:06:35 +0000
committerJustin Lecher <jlec@gentoo.org>2011-02-01 09:06:35 +0000
commitda27f7e5b3756fa706f862364d8c9e0e9a70586d (patch)
tree7c3b2388a1ebc93219c01244db9460d28af73424
parentAdd 0.84 again for the new squeezeboxserver-7.5.3 (#353376). Version conversion (diff)
downloadgentoo-2-da27f7e5b3756fa706f862364d8c9e0e9a70586d.tar.gz
gentoo-2-da27f7e5b3756fa706f862364d8c9e0e9a70586d.tar.bz2
gentoo-2-da27f7e5b3756fa706f862364d8c9e0e9a70586d.zip
New addition, written by me
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
-rw-r--r--sci-biology/cd-hit/ChangeLog10
-rw-r--r--sci-biology/cd-hit/cd-hit-4.5.1.ebuild44
-rw-r--r--sci-biology/cd-hit/files/4.5.1-gentoo.patch85
-rw-r--r--sci-biology/cd-hit/metadata.xml24
4 files changed, 163 insertions, 0 deletions
diff --git a/sci-biology/cd-hit/ChangeLog b/sci-biology/cd-hit/ChangeLog
new file mode 100644
index 000000000000..4d17282cd697
--- /dev/null
+++ b/sci-biology/cd-hit/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-biology/cd-hit
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/cd-hit/ChangeLog,v 1.1 2011/02/01 09:06:35 jlec Exp $
+
+*cd-hit-4.5.1 (01 Feb 2011)
+
+ 01 Feb 2011; Justin Lecher <jlec@gentoo.org> +files/4.5.1-gentoo.patch,
+ +cd-hit-4.5.1.ebuild, +metadata.xml:
+ New addition, written by me
+
diff --git a/sci-biology/cd-hit/cd-hit-4.5.1.ebuild b/sci-biology/cd-hit/cd-hit-4.5.1.ebuild
new file mode 100644
index 000000000000..16119f159316
--- /dev/null
+++ b/sci-biology/cd-hit/cd-hit-4.5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/cd-hit/cd-hit-4.5.1.ebuild,v 1.1 2011/02/01 09:06:35 jlec Exp $
+
+EAPI="3"
+
+inherit flag-o-matic toolchain-funcs
+
+RELDATE="2011-01-31"
+RELEASE="${PN}-v${PV}-${RELDATE}"
+
+DESCRIPTION="Clustering Database at High Identity with Tolerance"
+HOMEPAGE="http://weizhong-lab.ucsd.edu/cd-hit"
+SRC_URI="http://cdhit.googlecode.com/files/${RELEASE}.tgz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE="openmp"
+
+S="${WORKDIR}"/${RELEASE}
+
+pkg_setup() {
+ use openmp && ! tc-has-openmp && die "Please switch to an openmp compatible compiler"
+}
+
+src_prepare() {
+ tc-export CXX
+ use openmp || append-flags -DNO_OPENMP
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+}
+
+src_compile() {
+ if use openmp; then
+ emake openmp=yes || die
+ else
+ emake || die
+ fi
+}
+
+src_install() {
+ dobin cd-hit cd-hit-est cd-hit-2d cd-hit-est-2d cd-hit-div *.pl || die
+ dodoc ChangeLog cdhit-user-guide.pdf || die
+}
diff --git a/sci-biology/cd-hit/files/4.5.1-gentoo.patch b/sci-biology/cd-hit/files/4.5.1-gentoo.patch
new file mode 100644
index 000000000000..c3eaf79cc8f2
--- /dev/null
+++ b/sci-biology/cd-hit/files/4.5.1-gentoo.patch
@@ -0,0 +1,85 @@
+diff --git a/Makefile b/Makefile
+index f1eaa26..92d3130 100644
+--- a/Makefile
++++ b/Makefile
+@@ -10,7 +10,7 @@ CCFLAGS = -O2 -DNO_OPENMP
+ # in command line:
+ # make openmp=yes
+ ifeq ($(openmp),yes)
+-CCFLAGS = -O2 -fopenmp
++CXXFLAGS += -fopenmp
+ endif
+
+ # support debugging
+@@ -18,16 +18,16 @@ endif
+ # make debug=yes
+ # make openmp=yes debug=yes
+ ifeq ($(debug),yes)
+-CCFLAGS += -ggdb
++CXXFLAGS += -ggdb
+ endif
+
+ #LDFLAGS = -static -o
+-LDFLAGS = -o
++LDFLAGS += -o
+
+ PROGS = cd-hit cd-hit-est cd-hit-2d cd-hit-est-2d cd-hit-div
+
+ .c++.o:
+- $(CC) $(CCFLAGS) -c $<
++ $(CXX) $(CXXFLAGS) -c $<
+
+ all: $(PROGS)
+
+@@ -37,39 +37,39 @@ clean:
+ # programs
+
+ cd-hit: cdhit-common.o cdhit-utility.o cdhit.o
+- $(CC) $(CCFLAGS) cdhit.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit
++ $(CXX) $(CXXFLAGS) cdhit.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit
+
+ cd-hit-2d: cdhit-common.o cdhit-utility.o cdhit-2d.o
+- $(CC) $(CCFLAGS) cdhit-2d.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-2d
++ $(CXX) $(CXXFLAGS) cdhit-2d.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-2d
+
+ cd-hit-est: cdhit-common.o cdhit-utility.o cdhit-est.o
+- $(CC) $(CCFLAGS) cdhit-est.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-est
++ $(CXX) $(CXXFLAGS) cdhit-est.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-est
+
+ cd-hit-est-2d: cdhit-common.o cdhit-utility.o cdhit-est-2d.o
+- $(CC) $(CCFLAGS) cdhit-est-2d.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-est-2d
++ $(CXX) $(CXXFLAGS) cdhit-est-2d.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-est-2d
+
+ cd-hit-div: cdhit-common.o cdhit-utility.o cdhit-div.o
+- $(CC) $(CCFLAGS) cdhit-div.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-div
++ $(CXX) $(CXXFLAGS) cdhit-div.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-div
+
+ # objects
+ cdhit-common.o: cdhit-common.c++ cdhit-common.h
+- $(CC) $(CCFLAGS) cdhit-common.c++ -c
++ $(CXX) $(CXXFLAGS) cdhit-common.c++ -c
+
+ cdhit-utility.o: cdhit-utility.c++ cdhit-utility.h
+- $(CC) $(CCFLAGS) cdhit-utility.c++ -c
++ $(CXX) $(CXXFLAGS) cdhit-utility.c++ -c
+
+ cdhit.o: cdhit.c++ cdhit-utility.h
+- $(CC) $(CCFLAGS) cdhit.c++ -c
++ $(CXX) $(CXXFLAGS) cdhit.c++ -c
+
+ cdhit-2d.o: cdhit-2d.c++ cdhit-utility.h
+- $(CC) $(CCFLAGS) cdhit-2d.c++ -c
++ $(CXX) $(CXXFLAGS) cdhit-2d.c++ -c
+
+ cdhit-est.o: cdhit-est.c++ cdhit-utility.h
+- $(CC) $(CCFLAGS) cdhit-est.c++ -c
++ $(CXX) $(CXXFLAGS) cdhit-est.c++ -c
+
+ cdhit-est-2d.o: cdhit-est-2d.c++ cdhit-utility.h
+- $(CC) $(CCFLAGS) cdhit-est-2d.c++ -c
++ $(CXX) $(CXXFLAGS) cdhit-est-2d.c++ -c
+
+ cdhit-div.o: cdhit-div.c++ cdhit-common.h
+- $(CC) $(CCFLAGS) cdhit-div.c++ -c
++ $(CXX) $(CXXFLAGS) cdhit-div.c++ -c
+
diff --git a/sci-biology/cd-hit/metadata.xml b/sci-biology/cd-hit/metadata.xml
new file mode 100644
index 000000000000..0066dc245f77
--- /dev/null
+++ b/sci-biology/cd-hit/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-biology</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+<longdescription>
+CD-HIT is a very widely used program for clustering and comparing large sets
+of protein or nucleotide sequences. CD-HIT is very fast and can handle
+extremely large databases. CD-HIT helps to significantly reduce the
+computational and manual efforts in many sequence analysis tasks and aids in
+understanding the data structure and correct the bias within a dataset.
+
+The CD-HIT package has CD-HIT, CD-HIT-2D, CD-HIT-EST, CD-HIT-EST-2D,
+CD-HIT-454, CD-HIT-PARA, PSI-CD-HIT and over a dozen scripts. CD-HIT
+(CD-HIT-EST) clusters similar proteins (DNAs) into clusters that meet a
+user-defined similarity threshold. CD-HIT-2D (CD-HIT-EST-2D) compares 2
+datasets and identifies the sequences in db2 that are similar to db1 above
+a threshold. CD-HIT-454 is a program to identify natural and artificial
+duplicates from pyrosequencing reads. The usage of other programs and
+scripts can be found in CD-HIT user's guide.
+</longdescription>
+</pkgmetadata>