summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-04-12 22:16:49 +0000
committerAlex Brandt <alunduil@gentoo.org>2015-04-12 22:16:49 +0000
commitd701435463b3390474ee9c51398584f88d8be2d6 (patch)
treebd7e3f6aa400cfdedf3b637d7358769c9734df45
parentVersion bump. (diff)
downloadgentoo-2-d701435463b3390474ee9c51398584f88d8be2d6.tar.gz
gentoo-2-d701435463b3390474ee9c51398584f88d8be2d6.tar.bz2
gentoo-2-d701435463b3390474ee9c51398584f88d8be2d6.zip
add version 1.8.3
* includes patch (upstream—https://github.com/hamcrest/PyHamcrest/pull/53) (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 11A8217C!)
-rw-r--r--dev-python/pyhamcrest/ChangeLog9
-rw-r--r--dev-python/pyhamcrest/files/sphinx-rtd.patch20
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-1.8.3.ebuild62
3 files changed, 90 insertions, 1 deletions
diff --git a/dev-python/pyhamcrest/ChangeLog b/dev-python/pyhamcrest/ChangeLog
index dab9162bbcbe..eadc44cd9b33 100644
--- a/dev-python/pyhamcrest/ChangeLog
+++ b/dev-python/pyhamcrest/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pyhamcrest
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyhamcrest/ChangeLog,v 1.4 2015/02/23 15:58:57 alunduil Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyhamcrest/ChangeLog,v 1.5 2015/04/12 22:16:49 alunduil Exp $
+
+*pyhamcrest-1.8.3 (12 Apr 2015)
+
+ 12 Apr 2015; Alex Brandt <alunduil@gentoo.org> +files/sphinx-rtd.patch,
+ +pyhamcrest-1.8.3.ebuild:
+ add version 1.8.3 * includes patch
+ (upstream—https://github.com/hamcrest/PyHamcrest/pull/53)
*pyhamcrest-1.8.2 (23 Feb 2015)
diff --git a/dev-python/pyhamcrest/files/sphinx-rtd.patch b/dev-python/pyhamcrest/files/sphinx-rtd.patch
new file mode 100644
index 000000000000..2974c98a56a3
--- /dev/null
+++ b/dev-python/pyhamcrest/files/sphinx-rtd.patch
@@ -0,0 +1,20 @@
+diff --git a/doc/conf.py b/doc/conf.py
+index fb5d79e..7d3571b 100644
+--- a/doc/conf.py
++++ b/doc/conf.py
+@@ -13,6 +13,7 @@
+
+ import sys, os
+ import six
++import sphinx_rtd_theme
+
+ # If extensions (or modules to document with autodoc) are in another directory,
+ # add these directories to sys.path here. If the directory is relative to the
+@@ -106,6 +107,7 @@ html_theme = 'sphinx_rtd_theme'
+
+ # Add any paths that contain custom themes here, relative to this directory.
+ #html_theme_path = []
++html_theme_path = [ sphinx_rtd_theme.get_html_theme_path() ]
+
+ # The name for this set of Sphinx documents. If None, it defaults to
+ # "<project> v<release> documentation".
diff --git a/dev-python/pyhamcrest/pyhamcrest-1.8.3.ebuild b/dev-python/pyhamcrest/pyhamcrest-1.8.3.ebuild
new file mode 100644
index 000000000000..cacd3d979e84
--- /dev/null
+++ b/dev-python/pyhamcrest/pyhamcrest-1.8.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyhamcrest/pyhamcrest-1.8.3.ebuild,v 1.1 2015/04/12 22:16:49 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+MY_PN="PyHamcrest"
+
+DESCRIPTION="Hamcrest framework for matcher objects"
+HOMEPAGE="https://github.com/hamcrest/PyHamcrest"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples numpy test"
+
+CDEPEND="
+ >=dev-python/six-1.4[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )' 'python*')
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/sphinx-1.2.2[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ >=dev-python/pytest-2.6[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/sphinx-rtd.patch
+ )
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+ #use doc && emake -C doc html
+}
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}