summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-08-23 19:26:06 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-08-23 19:26:06 +0000
commitd506aa141cfa2b9ad5eabc8c1c9d0e916b4bcb94 (patch)
tree2547ee45648f72acc922177eba3f9c77a3336888
parentupdated digest (diff)
downloadgentoo-2-d506aa141cfa2b9ad5eabc8c1c9d0e916b4bcb94.tar.gz
gentoo-2-d506aa141cfa2b9ad5eabc8c1c9d0e916b4bcb94.tar.bz2
gentoo-2-d506aa141cfa2b9ad5eabc8c1c9d0e916b4bcb94.zip
fixes fixes fixes
-rw-r--r--sys-apps/portage/files/1.5/cnf/make.globals5
-rw-r--r--sys-kernel/linux-extras/linux-extras-2.4.8.8.ebuild41
-rw-r--r--sys-kernel/linux-headers/files/digest-linux-headers-2.4.8.82
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.4.8.8.ebuild41
-rw-r--r--sys-kernel/linux-sources/files/digest-linux-sources-2.4.8.82
-rw-r--r--sys-kernel/linux-sources/linux-sources-2.4.8.8.ebuild41
-rw-r--r--sys-kernel/linux/files/digest-linux-2.4.8.82
-rw-r--r--sys-kernel/linux/linux-2.4.8.8.ebuild41
-rw-r--r--sys-libs/gpm/gpm-1.19.3-r3.ebuild95
9 files changed, 150 insertions, 120 deletions
diff --git a/sys-apps/portage/files/1.5/cnf/make.globals b/sys-apps/portage/files/1.5/cnf/make.globals
index 0486d9191603..5a281aa204b8 100644
--- a/sys-apps/portage/files/1.5/cnf/make.globals
+++ b/sys-apps/portage/files/1.5/cnf/make.globals
@@ -10,7 +10,10 @@ GENTOO_MIRRORS="http://www.ibiblio.org/gentoo"
# Host-type
CHOST=i686-pc-linux-gnu
-PORTAGE_TMPDIR=${ROOT}/var/tmp
+#PORTAGE_TMPDIR=${ROOT}/var/tmp
+PORTAGE_TMPDIR=/var/tmp
+#/var/tmp without ${ROOT} seems more appropriate
+
# Directory used for the build process
BUILD_PREFIX=${PORTAGE_TMPDIR}/portage
PKG_TMPDIR=${PORTAGE_TMPDIR}/portage-pkg
diff --git a/sys-kernel/linux-extras/linux-extras-2.4.8.8.ebuild b/sys-kernel/linux-extras/linux-extras-2.4.8.8.ebuild
index f87ab0a74c14..664b2b48309a 100644
--- a/sys-kernel/linux-extras/linux-extras-2.4.8.8.ebuild
+++ b/sys-kernel/linux-extras/linux-extras-2.4.8.8.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-extras/linux-extras-2.4.8.8.ebuild,v 1.1 2001/08/22 21:36:53 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-extras/linux-extras-2.4.8.8.ebuild,v 1.2 2001/08/23 19:26:06 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version
@@ -50,7 +50,9 @@ if [ ! "${PN}" = "linux-extras" ] ; then
SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
http://www.kernel.org/pub/linux/kernel/people/alan/linux-2.4/${OKV}/patch-${KV}.bz2
ftp://ftp.sistina.com/pub/LVM/1.0/lvm_${LVMV}.tar.gz
- http://www.knopper.net/download/knoppix/cloop_${CLOOPAV}.tar.gz"
+ http://www.knopper.net/download/knoppix/cloop_${CLOOPAV}.tar.gz
+ http://www.ibiblio.org/gentoo/distfiles/lvm-1.0.1-rc1-2.4.8-ac8.patch.bz2
+ http://www.ibiblio.org/gentoo/distfiles/lvm_perl_to_bash.patch.bz2"
fi
# http://www.zip.com.au/~akpm/ext3-${EXT3V}.gz
# http://oss.software.ibm.com/developerworks/opensource/jfs/project/pub/jfs-1.0.0-patch.tar.gz
@@ -136,17 +138,22 @@ src_unpack() {
cd ${S2}
echo "Unpacking and applying LVM patch..."
unpack lvm_${LVMV}.tar.gz
- cd LVM/${LVMV}
-
+ #cd LVM/${LVMV}
+ #We need to convert those 1.0.1-rc1 perl scripts to bash; This'll be fixed in 1.0.1 final. Thanks AJ :)
+ #cat ${DISTDIR}/lvm_perl_to_bash.patch.bz2 | bzip2 -d | patch -p1 || die
+
# I had to hack this in so that LVM will look in the current linux
# source directory instead of /usr/src/linux for stuff - pete
- CFLAGS="${CFLAGS} -I${S}/include" ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${S}" || die
- cd PATCHES
- make KERNEL_VERSION=${KV} KERNEL_DIR=${S} || die
- cd ${S}
+ #CFLAGS="${CFLAGS} -I${KS}/include" ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${KS}" || die
+ #cd PATCHES
+ #make KERNEL_VERSION=${KV} KERNEL_DIR=${S} || die
+ #cd ${S}
# the -l option allows this patch to apply cleanly (ignore whitespace changes)
# the -N option is an "auto no" to previously applied stuff. Needed for 2.4.8-ac8
- patch -N -l -p1 < ${S2}/LVM/${LVMV}/PATCHES/lvm-${LVMV}-${KV}.patch
+
+ #patch -N -l -p1 < ${S2}/LVM/${LVMV}/PATCHES/lvm-${LVMV}-${KV}.patch
+ cd ${S}
+ cat ${DISTDIR}/lvm-1.0.1-rc1-2.4.8-ac8.patch.bz2 | bzip2 -d | patch -N -l -p1
#|| die
#we removed || die because any stuff that hits -N causes an error code of 1
fi
@@ -251,12 +258,12 @@ src_compile() {
if [ "${PN}" = "linux-sources" ] || [ "${PN}" = "linux-headers" ]
then
cd ${KS}
- try make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep || die
else
if [ $PN = "linux" ]
then
cd ${KS}
- try make symlinks
+ make symlinks || die
fi
if [ "`use lvm`" ]
then
@@ -266,12 +273,12 @@ src_compile() {
# This is needed for linux-extras
if [ -f "Makefile" ]
then
- try make clean
+ make clean || die
fi
# I had to hack this in so that LVM will look in the current linux
# source directory instead of /usr/src/linux for stuff - pete
- CFLAGS="${CFLAGS} -I${KS}/include" try ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${KS}"
- try make
+ CFLAGS="${CFLAGS} -I${KS}/include" ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${KS}" || die
+ make || die
fi
# if [ "`use lm_sensors`" ]
@@ -294,9 +301,9 @@ src_compile() {
if [ "$PN" == "linux" ]
then
cd ${KS}
- try make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep
- try make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" bzImage
- try make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" modules
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep || die
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" bzImage || die
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" modules || die
fi
# if [ "`use pcmcia-cs`" ]
diff --git a/sys-kernel/linux-headers/files/digest-linux-headers-2.4.8.8 b/sys-kernel/linux-headers/files/digest-linux-headers-2.4.8.8
index af481f26d002..633a9bd05f82 100644
--- a/sys-kernel/linux-headers/files/digest-linux-headers-2.4.8.8
+++ b/sys-kernel/linux-headers/files/digest-linux-headers-2.4.8.8
@@ -1,4 +1,6 @@
MD5 568a3673324804e0ac846969a3e311cb cloop_0.61-1.tar.gz
MD5 b37d19b91ae334273b1fc2eb9897bedf linux-2.4.8.tar.bz2
+MD5 b02cb1bb5be17dc7b023b632c3356338 lvm-1.0.1-rc1-2.4.8-ac8.patch.bz2
MD5 4227d98ab42e1f08b4c0804b749b393e lvm_1.0.1-rc1.tar.gz
+MD5 14b33da66be00c77d04f79bc5d2b005c lvm_perl_to_bash.patch.bz2
MD5 0ba4ec924215aa8d96218fbc03f86830 patch-2.4.8-ac8.bz2
diff --git a/sys-kernel/linux-headers/linux-headers-2.4.8.8.ebuild b/sys-kernel/linux-headers/linux-headers-2.4.8.8.ebuild
index c84512b15fcb..b08a5e2e786e 100644
--- a/sys-kernel/linux-headers/linux-headers-2.4.8.8.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.4.8.8.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.8.8.ebuild,v 1.1 2001/08/22 21:36:53 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.8.8.ebuild,v 1.2 2001/08/23 19:26:06 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version
@@ -50,7 +50,9 @@ if [ ! "${PN}" = "linux-extras" ] ; then
SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
http://www.kernel.org/pub/linux/kernel/people/alan/linux-2.4/${OKV}/patch-${KV}.bz2
ftp://ftp.sistina.com/pub/LVM/1.0/lvm_${LVMV}.tar.gz
- http://www.knopper.net/download/knoppix/cloop_${CLOOPAV}.tar.gz"
+ http://www.knopper.net/download/knoppix/cloop_${CLOOPAV}.tar.gz
+ http://www.ibiblio.org/gentoo/distfiles/lvm-1.0.1-rc1-2.4.8-ac8.patch.bz2
+ http://www.ibiblio.org/gentoo/distfiles/lvm_perl_to_bash.patch.bz2"
fi
# http://www.zip.com.au/~akpm/ext3-${EXT3V}.gz
# http://oss.software.ibm.com/developerworks/opensource/jfs/project/pub/jfs-1.0.0-patch.tar.gz
@@ -136,17 +138,22 @@ src_unpack() {
cd ${S2}
echo "Unpacking and applying LVM patch..."
unpack lvm_${LVMV}.tar.gz
- cd LVM/${LVMV}
-
+ #cd LVM/${LVMV}
+ #We need to convert those 1.0.1-rc1 perl scripts to bash; This'll be fixed in 1.0.1 final. Thanks AJ :)
+ #cat ${DISTDIR}/lvm_perl_to_bash.patch.bz2 | bzip2 -d | patch -p1 || die
+
# I had to hack this in so that LVM will look in the current linux
# source directory instead of /usr/src/linux for stuff - pete
- CFLAGS="${CFLAGS} -I${S}/include" ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${S}" || die
- cd PATCHES
- make KERNEL_VERSION=${KV} KERNEL_DIR=${S} || die
- cd ${S}
+ #CFLAGS="${CFLAGS} -I${KS}/include" ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${KS}" || die
+ #cd PATCHES
+ #make KERNEL_VERSION=${KV} KERNEL_DIR=${S} || die
+ #cd ${S}
# the -l option allows this patch to apply cleanly (ignore whitespace changes)
# the -N option is an "auto no" to previously applied stuff. Needed for 2.4.8-ac8
- patch -N -l -p1 < ${S2}/LVM/${LVMV}/PATCHES/lvm-${LVMV}-${KV}.patch
+
+ #patch -N -l -p1 < ${S2}/LVM/${LVMV}/PATCHES/lvm-${LVMV}-${KV}.patch
+ cd ${S}
+ cat ${DISTDIR}/lvm-1.0.1-rc1-2.4.8-ac8.patch.bz2 | bzip2 -d | patch -N -l -p1
#|| die
#we removed || die because any stuff that hits -N causes an error code of 1
fi
@@ -251,12 +258,12 @@ src_compile() {
if [ "${PN}" = "linux-sources" ] || [ "${PN}" = "linux-headers" ]
then
cd ${KS}
- try make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep || die
else
if [ $PN = "linux" ]
then
cd ${KS}
- try make symlinks
+ make symlinks || die
fi
if [ "`use lvm`" ]
then
@@ -266,12 +273,12 @@ src_compile() {
# This is needed for linux-extras
if [ -f "Makefile" ]
then
- try make clean
+ make clean || die
fi
# I had to hack this in so that LVM will look in the current linux
# source directory instead of /usr/src/linux for stuff - pete
- CFLAGS="${CFLAGS} -I${KS}/include" try ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${KS}"
- try make
+ CFLAGS="${CFLAGS} -I${KS}/include" ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${KS}" || die
+ make || die
fi
# if [ "`use lm_sensors`" ]
@@ -294,9 +301,9 @@ src_compile() {
if [ "$PN" == "linux" ]
then
cd ${KS}
- try make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep
- try make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" bzImage
- try make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" modules
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep || die
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" bzImage || die
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" modules || die
fi
# if [ "`use pcmcia-cs`" ]
diff --git a/sys-kernel/linux-sources/files/digest-linux-sources-2.4.8.8 b/sys-kernel/linux-sources/files/digest-linux-sources-2.4.8.8
index af481f26d002..633a9bd05f82 100644
--- a/sys-kernel/linux-sources/files/digest-linux-sources-2.4.8.8
+++ b/sys-kernel/linux-sources/files/digest-linux-sources-2.4.8.8
@@ -1,4 +1,6 @@
MD5 568a3673324804e0ac846969a3e311cb cloop_0.61-1.tar.gz
MD5 b37d19b91ae334273b1fc2eb9897bedf linux-2.4.8.tar.bz2
+MD5 b02cb1bb5be17dc7b023b632c3356338 lvm-1.0.1-rc1-2.4.8-ac8.patch.bz2
MD5 4227d98ab42e1f08b4c0804b749b393e lvm_1.0.1-rc1.tar.gz
+MD5 14b33da66be00c77d04f79bc5d2b005c lvm_perl_to_bash.patch.bz2
MD5 0ba4ec924215aa8d96218fbc03f86830 patch-2.4.8-ac8.bz2
diff --git a/sys-kernel/linux-sources/linux-sources-2.4.8.8.ebuild b/sys-kernel/linux-sources/linux-sources-2.4.8.8.ebuild
index 00c6e6bdc959..bfa6c8246dad 100644
--- a/sys-kernel/linux-sources/linux-sources-2.4.8.8.ebuild
+++ b/sys-kernel/linux-sources/linux-sources-2.4.8.8.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.8.8.ebuild,v 1.1 2001/08/22 21:36:53 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.8.8.ebuild,v 1.2 2001/08/23 19:26:06 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version
@@ -50,7 +50,9 @@ if [ ! "${PN}" = "linux-extras" ] ; then
SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
http://www.kernel.org/pub/linux/kernel/people/alan/linux-2.4/${OKV}/patch-${KV}.bz2
ftp://ftp.sistina.com/pub/LVM/1.0/lvm_${LVMV}.tar.gz
- http://www.knopper.net/download/knoppix/cloop_${CLOOPAV}.tar.gz"
+ http://www.knopper.net/download/knoppix/cloop_${CLOOPAV}.tar.gz
+ http://www.ibiblio.org/gentoo/distfiles/lvm-1.0.1-rc1-2.4.8-ac8.patch.bz2
+ http://www.ibiblio.org/gentoo/distfiles/lvm_perl_to_bash.patch.bz2"
fi
# http://www.zip.com.au/~akpm/ext3-${EXT3V}.gz
# http://oss.software.ibm.com/developerworks/opensource/jfs/project/pub/jfs-1.0.0-patch.tar.gz
@@ -136,17 +138,22 @@ src_unpack() {
cd ${S2}
echo "Unpacking and applying LVM patch..."
unpack lvm_${LVMV}.tar.gz
- cd LVM/${LVMV}
-
+ #cd LVM/${LVMV}
+ #We need to convert those 1.0.1-rc1 perl scripts to bash; This'll be fixed in 1.0.1 final. Thanks AJ :)
+ #cat ${DISTDIR}/lvm_perl_to_bash.patch.bz2 | bzip2 -d | patch -p1 || die
+
# I had to hack this in so that LVM will look in the current linux
# source directory instead of /usr/src/linux for stuff - pete
- CFLAGS="${CFLAGS} -I${S}/include" ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${S}" || die
- cd PATCHES
- make KERNEL_VERSION=${KV} KERNEL_DIR=${S} || die
- cd ${S}
+ #CFLAGS="${CFLAGS} -I${KS}/include" ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${KS}" || die
+ #cd PATCHES
+ #make KERNEL_VERSION=${KV} KERNEL_DIR=${S} || die
+ #cd ${S}
# the -l option allows this patch to apply cleanly (ignore whitespace changes)
# the -N option is an "auto no" to previously applied stuff. Needed for 2.4.8-ac8
- patch -N -l -p1 < ${S2}/LVM/${LVMV}/PATCHES/lvm-${LVMV}-${KV}.patch
+
+ #patch -N -l -p1 < ${S2}/LVM/${LVMV}/PATCHES/lvm-${LVMV}-${KV}.patch
+ cd ${S}
+ cat ${DISTDIR}/lvm-1.0.1-rc1-2.4.8-ac8.patch.bz2 | bzip2 -d | patch -N -l -p1
#|| die
#we removed || die because any stuff that hits -N causes an error code of 1
fi
@@ -251,12 +258,12 @@ src_compile() {
if [ "${PN}" = "linux-sources" ] || [ "${PN}" = "linux-headers" ]
then
cd ${KS}
- try make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep || die
else
if [ $PN = "linux" ]
then
cd ${KS}
- try make symlinks
+ make symlinks || die
fi
if [ "`use lvm`" ]
then
@@ -266,12 +273,12 @@ src_compile() {
# This is needed for linux-extras
if [ -f "Makefile" ]
then
- try make clean
+ make clean || die
fi
# I had to hack this in so that LVM will look in the current linux
# source directory instead of /usr/src/linux for stuff - pete
- CFLAGS="${CFLAGS} -I${KS}/include" try ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${KS}"
- try make
+ CFLAGS="${CFLAGS} -I${KS}/include" ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${KS}" || die
+ make || die
fi
# if [ "`use lm_sensors`" ]
@@ -294,9 +301,9 @@ src_compile() {
if [ "$PN" == "linux" ]
then
cd ${KS}
- try make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep
- try make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" bzImage
- try make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" modules
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep || die
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" bzImage || die
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" modules || die
fi
# if [ "`use pcmcia-cs`" ]
diff --git a/sys-kernel/linux/files/digest-linux-2.4.8.8 b/sys-kernel/linux/files/digest-linux-2.4.8.8
index af481f26d002..633a9bd05f82 100644
--- a/sys-kernel/linux/files/digest-linux-2.4.8.8
+++ b/sys-kernel/linux/files/digest-linux-2.4.8.8
@@ -1,4 +1,6 @@
MD5 568a3673324804e0ac846969a3e311cb cloop_0.61-1.tar.gz
MD5 b37d19b91ae334273b1fc2eb9897bedf linux-2.4.8.tar.bz2
+MD5 b02cb1bb5be17dc7b023b632c3356338 lvm-1.0.1-rc1-2.4.8-ac8.patch.bz2
MD5 4227d98ab42e1f08b4c0804b749b393e lvm_1.0.1-rc1.tar.gz
+MD5 14b33da66be00c77d04f79bc5d2b005c lvm_perl_to_bash.patch.bz2
MD5 0ba4ec924215aa8d96218fbc03f86830 patch-2.4.8-ac8.bz2
diff --git a/sys-kernel/linux/linux-2.4.8.8.ebuild b/sys-kernel/linux/linux-2.4.8.8.ebuild
index 699e399afe12..25a49f740fa0 100644
--- a/sys-kernel/linux/linux-2.4.8.8.ebuild
+++ b/sys-kernel/linux/linux-2.4.8.8.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux/linux-2.4.8.8.ebuild,v 1.1 2001/08/22 21:36:53 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux/linux-2.4.8.8.ebuild,v 1.2 2001/08/23 19:26:06 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version
@@ -50,7 +50,9 @@ if [ ! "${PN}" = "linux-extras" ] ; then
SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
http://www.kernel.org/pub/linux/kernel/people/alan/linux-2.4/${OKV}/patch-${KV}.bz2
ftp://ftp.sistina.com/pub/LVM/1.0/lvm_${LVMV}.tar.gz
- http://www.knopper.net/download/knoppix/cloop_${CLOOPAV}.tar.gz"
+ http://www.knopper.net/download/knoppix/cloop_${CLOOPAV}.tar.gz
+ http://www.ibiblio.org/gentoo/distfiles/lvm-1.0.1-rc1-2.4.8-ac8.patch.bz2
+ http://www.ibiblio.org/gentoo/distfiles/lvm_perl_to_bash.patch.bz2"
fi
# http://www.zip.com.au/~akpm/ext3-${EXT3V}.gz
# http://oss.software.ibm.com/developerworks/opensource/jfs/project/pub/jfs-1.0.0-patch.tar.gz
@@ -136,17 +138,22 @@ src_unpack() {
cd ${S2}
echo "Unpacking and applying LVM patch..."
unpack lvm_${LVMV}.tar.gz
- cd LVM/${LVMV}
-
+ #cd LVM/${LVMV}
+ #We need to convert those 1.0.1-rc1 perl scripts to bash; This'll be fixed in 1.0.1 final. Thanks AJ :)
+ #cat ${DISTDIR}/lvm_perl_to_bash.patch.bz2 | bzip2 -d | patch -p1 || die
+
# I had to hack this in so that LVM will look in the current linux
# source directory instead of /usr/src/linux for stuff - pete
- CFLAGS="${CFLAGS} -I${S}/include" ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${S}" || die
- cd PATCHES
- make KERNEL_VERSION=${KV} KERNEL_DIR=${S} || die
- cd ${S}
+ #CFLAGS="${CFLAGS} -I${KS}/include" ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${KS}" || die
+ #cd PATCHES
+ #make KERNEL_VERSION=${KV} KERNEL_DIR=${S} || die
+ #cd ${S}
# the -l option allows this patch to apply cleanly (ignore whitespace changes)
# the -N option is an "auto no" to previously applied stuff. Needed for 2.4.8-ac8
- patch -N -l -p1 < ${S2}/LVM/${LVMV}/PATCHES/lvm-${LVMV}-${KV}.patch
+
+ #patch -N -l -p1 < ${S2}/LVM/${LVMV}/PATCHES/lvm-${LVMV}-${KV}.patch
+ cd ${S}
+ cat ${DISTDIR}/lvm-1.0.1-rc1-2.4.8-ac8.patch.bz2 | bzip2 -d | patch -N -l -p1
#|| die
#we removed || die because any stuff that hits -N causes an error code of 1
fi
@@ -251,12 +258,12 @@ src_compile() {
if [ "${PN}" = "linux-sources" ] || [ "${PN}" = "linux-headers" ]
then
cd ${KS}
- try make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep || die
else
if [ $PN = "linux" ]
then
cd ${KS}
- try make symlinks
+ make symlinks || die
fi
if [ "`use lvm`" ]
then
@@ -266,12 +273,12 @@ src_compile() {
# This is needed for linux-extras
if [ -f "Makefile" ]
then
- try make clean
+ make clean || die
fi
# I had to hack this in so that LVM will look in the current linux
# source directory instead of /usr/src/linux for stuff - pete
- CFLAGS="${CFLAGS} -I${KS}/include" try ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${KS}"
- try make
+ CFLAGS="${CFLAGS} -I${KS}/include" ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${KS}" || die
+ make || die
fi
# if [ "`use lm_sensors`" ]
@@ -294,9 +301,9 @@ src_compile() {
if [ "$PN" == "linux" ]
then
cd ${KS}
- try make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep
- try make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" bzImage
- try make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" modules
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep || die
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" bzImage || die
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" modules || die
fi
# if [ "`use pcmcia-cs`" ]
diff --git a/sys-libs/gpm/gpm-1.19.3-r3.ebuild b/sys-libs/gpm/gpm-1.19.3-r3.ebuild
index 5877c65de407..1711c4210ddf 100644
--- a/sys-libs/gpm/gpm-1.19.3-r3.ebuild
+++ b/sys-libs/gpm/gpm-1.19.3-r3.ebuild
@@ -1,65 +1,58 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.19.3-r3.ebuild,v 1.1 2001/05/22 15:19:05 pete Exp $
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.19.3-r3.ebuild,v 1.2 2001/08/23 19:26:06 drobbins Exp $
-#P=
-A="${P}.tar.gz devfs.patch"
S=${WORKDIR}/${P}
DESCRIPTION="Console-based mouse driver"
-SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/mouse/${A}
- ftp://ftp.prosa.it/pub/gpm/patches/devfs.patch"
-
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.2
- tex? ( app-text/tetex )"
-
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/mouse/${P}.tar.gz ftp://ftp.prosa.it/pub/gpm/patches/devfs.patch"
+DEPEND="virtual/glibc >=sys-libs/ncurses-5.2 tex? ( app-text/tetex ) sys-devel/autoconf"
RDEPEND="virtual/glibc"
src_unpack() {
-
- unpack ${P}.tar.gz
- cd ${S}
- cp ${FILESDIR}/gpmInt.h .
- patch -p1 < ${DISTDIR}/devfs.patch
-
+ unpack ${P}.tar.gz
+ cd ${S}
+ cp ${FILESDIR}/gpmInt.h .
+ patch -p1 < ${DISTDIR}/devfs.patch
+ #this little hack turns of EMACS byte compilation. Really don't want this thing auto-detecting emacs
+ cp configure.in configure.in.orig
+ sed -e '45i\' -e 'EMACS=:\' -e 'ELISP=' configure.in.orig > configure.in || die
+ autoconf || die
}
src_compile() {
-
- try ./configure --prefix=/usr --sysconfdir=/etc/gpm
- # without-curses is required to avoid cyclic dependencies to ncurses
- cp Makefile Makefile.orig
- if [ -z "`use tex`" ]
- then
- sed -e "s/doc//" Makefile.orig > Makefile
- fi
- try make ${MAKEOPTS}
+ ./configure --prefix=/usr --sysconfdir=/etc/gpm || die
+ # without-curses is required to avoid cyclic dependencies to ncurses
+ cp Makefile Makefile.orig
+ if [ -z "`use tex`" ]
+ then
+ #The emacs stuff turns off auto byte-"complication"
+ sed -e "s/doc//" Makefile.orig > Makefile
+ #-e '/$(EMACS)/c\' -e ' echo'
+ fi
+ emake || die
}
src_install() {
-
- try make prefix=${D}/usr install
-
- chmod 755 ${D}/usr/lib/libgpm.so.1.18.0
-
- dodoc Announce COPYING ChangeLog FAQ MANIFEST README.*
- docinto txt
- dodoc doc/gpmdoc.txt
-
- if [ "`use tex`" ]
- then
- docinto ps
- dodoc doc/*.ps
- fi
-
- insinto /etc/gpm
- doins gpm-root.conf
-
- exeinto /etc/rc.d/init.d
- newexe ${FILESDIR}/${PN}-${PVR} ${PN}
- newexe ${FILESDIR}/svc-${PN}-${PVR} svc-${PN}
- exeinto /var/lib/supervise/services/${PN}
- newexe ${FILESDIR}/${PN}-run-${PVR} run
-
+ make prefix=${D}/usr install || die
+ chmod 755 ${D}/usr/lib/libgpm.so.1.18.0
+ dodoc Announce COPYING ChangeLog FAQ MANIFEST README.*
+ docinto txt
+ dodoc doc/gpmdoc.txt
+
+ if [ "`use tex`" ]
+ then
+ docinto ps
+ dodoc doc/*.ps
+ fi
+
+ insinto /etc/gpm
+ doins gpm-root.conf
+
+ exeinto /etc/rc.d/init.d
+ newexe ${FILESDIR}/${PN}-${PVR} ${PN}
+ newexe ${FILESDIR}/svc-${PN}-${PVR} svc-${PN}
+ exeinto /var/lib/supervise/services/${PN}
+ newexe ${FILESDIR}/${PN}-run-${PVR} run
}