summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-04-11 20:51:25 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-04-11 20:51:25 +0000
commitcbc956260da44d098fdd383e726e1e9604e9d042 (patch)
treeeca590ac1adb671438b21033cd1725d6d0f96ed0
parentFix infinite loop in IMAP kioslave, causing local DoS. (diff)
downloadgentoo-2-cbc956260da44d098fdd383e726e1e9604e9d042.tar.gz
gentoo-2-cbc956260da44d098fdd383e726e1e9604e9d042.tar.bz2
gentoo-2-cbc956260da44d098fdd383e726e1e9604e9d042.zip
Grab several bugfixes from the 3.5 branch, for reference see the KDE bugs #66740, #71549, #79685, #96498, #102001, #113329, #113580, #113885, #115713, #117785, #117935, #118060, #121863, #126715, #132487, #137302, #138514, #140195 and #140660.
(Portage version: 2.1.2.3)
-rw-r--r--kde-base/kmail/ChangeLog10
-rw-r--r--kde-base/kmail/files/digest-kmail-3.5.6-r26
-rw-r--r--kde-base/kmail/kmail-3.5.6-r2.ebuild67
3 files changed, 82 insertions, 1 deletions
diff --git a/kde-base/kmail/ChangeLog b/kde-base/kmail/ChangeLog
index ff8aada097c5..e70bdd4e2d07 100644
--- a/kde-base/kmail/ChangeLog
+++ b/kde-base/kmail/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-base/kmail
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.99 2007/02/05 11:54:33 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.100 2007/04/11 20:51:25 carlo Exp $
+
+*kmail-3.5.6-r2 (11 Apr 2007)
+
+ 11 Apr 2007; Carsten Lohrke <carlo@gentoo.org> +kmail-3.5.6-r2.ebuild:
+ Grab several bugfixes from the 3.5 branch, for reference see the KDE bugs
+ #66740, #71549, #79685, #96498, #102001, #113329, #113580, #113885, #115713,
+ #117785, #117935, #118060, #121863, #126715, #132487, #137302, #138514,
+ #140195 and #140660.
05 Feb 2007; Diego Pettenò <flameeyes@gentoo.org>
-files/kmail-3.5.2-imap-fixes-2.diff, -files/kmail-3.5.2-misc-fixes.diff,
diff --git a/kde-base/kmail/files/digest-kmail-3.5.6-r2 b/kde-base/kmail/files/digest-kmail-3.5.6-r2
new file mode 100644
index 000000000000..e27a0017b6a2
--- /dev/null
+++ b/kde-base/kmail/files/digest-kmail-3.5.6-r2
@@ -0,0 +1,6 @@
+MD5 48f1592b07f784df47280baa0c8356b0 kdepim-3.5-patchset-03.tar.bz2 121475
+RMD160 e8aa4e812a3be3d4e13429d487e1e4d466e058b1 kdepim-3.5-patchset-03.tar.bz2 121475
+SHA256 30d4e8d7ac4e11f1a8209bbcb5b39beb044998d4b0d3fa810743a017b38b904b kdepim-3.5-patchset-03.tar.bz2 121475
+MD5 e37e6173fe9fd7f242c9502a4ae1d7de kdepim-3.5.6.tar.bz2 13643798
+RMD160 85f64349d8eedb531895a3591f6fee07c68bf1eb kdepim-3.5.6.tar.bz2 13643798
+SHA256 0b3a04f72fa640d804df1c4cf2c66ac3ccc5033c98e90a7ae9c62611ea8e3a55 kdepim-3.5.6.tar.bz2 13643798
diff --git a/kde-base/kmail/kmail-3.5.6-r2.ebuild b/kde-base/kmail/kmail-3.5.6-r2.ebuild
new file mode 100644
index 000000000000..74dca7409302
--- /dev/null
+++ b/kde-base/kmail/kmail-3.5.6-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-3.5.6-r2.ebuild,v 1.1 2007/04/11 20:51:25 carlo Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdepim-3.5-patchset-03.tar.bz2"
+
+DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt"
+DEPEND="$(deprange 3.5.4 $MAXKDEVER kde-base/libkdenetwork)
+ $(deprange $PV $MAXKDEVER kde-base/libkdepim)
+ $(deprange $PV $MAXKDEVER kde-base/libkpimidentities)
+ $(deprange $PV $MAXKDEVER kde-base/mimelib)
+ $(deprange $PV $MAXKDEVER kde-base/libksieve)
+ $(deprange $PV $MAXKDEVER kde-base/certmanager)
+ $(deprange $PV $MAXKDEVER kde-base/libkcal)
+ $(deprange $PV $MAXKDEVER kde-base/kontact)
+ $(deprange 3.5.4 $MAXKDEVER kde-base/libkpgp)
+ $(deprange $PV $MAXKDEVER kde-base/libkmime)"
+RDEPEND="${DEPEND}
+ crypt? ( app-crypt/pinentry )
+ $(deprange $PV $MAXKDEVER kde-base/kdepim-kioslaves)
+ $(deprange 3.5.5 $MAXKDEVER kde-base/kmailcvt)
+ $(deprange-dual $PV $MAXKDEVER kde-base/kdebase-kioslaves)
+ $(deprange-dual $PV $MAXKDEVER kde-base/kcontrol)" # for the "looknfeel" icon, and probably others.
+
+KMCOPYLIB="
+ libkdepim libkdepim/
+ libkpimidentities libkpimidentities/
+ libmimelib mimelib/
+ libksieve libksieve/
+ libkleopatra certmanager/lib/
+ libkcal libkcal
+ libkpinterfaces kontact/interfaces/
+ libkmime libkmime
+ libkpgp libkpgp"
+KMEXTRACTONLY="
+ libkdenetwork/
+ libkdepim/
+ libkpimidentities/
+ libksieve/
+ libkcal/
+ mimelib/
+ certmanager/
+ korganizer/korganizeriface.h
+ kontact/interfaces/
+ libkmime/
+ libkpgp
+ dcopidlng"
+KMCOMPILEONLY="libemailfunctions"
+# the kmail plugins are installed with kmail
+KMEXTRA="plugins/kmail/
+ kontact/plugins/kmail/" # We add here the kontact's plugin instead of compiling it with kontact because it needs a lot of this programs deps.
+
+
+src_install() {
+ kde-meta_src_install
+ # Install KMail icons with libkdepim to work around bug #136810.
+ #find ${D}/${KDEDIR}/share/icons/hicolor/ -name "kmail\.png" -exec rm '{}' \;
+ rm ${D}/${KDEDIR}/share/icons/hicolor/{16x16,22x22,32x32,48x48,64x64,128x128}/apps/kmail.png || die "bääh"
+} \ No newline at end of file