summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-04-28 08:07:39 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-04-28 08:07:39 +0000
commitcb3dbc65e4466df811894adaf13f195ba7e70627 (patch)
tree94c408590d01e9c214a6b447779b0a690f73be8c
parentFix compilation with new automake-1.13, bug #467674. Thanks to slepnoga (diff)
downloadgentoo-2-cb3dbc65e4466df811894adaf13f195ba7e70627.tar.gz
gentoo-2-cb3dbc65e4466df811894adaf13f195ba7e70627.tar.bz2
gentoo-2-cb3dbc65e4466df811894adaf13f195ba7e70627.zip
Update wayland useflag usage a bit. Patch by Nikoli.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
-rw-r--r--media-video/mpv/ChangeLog5
-rw-r--r--media-video/mpv/mpv-9999.ebuild14
2 files changed, 14 insertions, 5 deletions
diff --git a/media-video/mpv/ChangeLog b/media-video/mpv/ChangeLog
index 2a8ad136083b..c0b01de1afb2 100644
--- a/media-video/mpv/ChangeLog
+++ b/media-video/mpv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/mpv
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/ChangeLog,v 1.3 2013/04/27 18:57:40 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/ChangeLog,v 1.4 2013/04/28 08:07:39 scarabeus Exp $
+
+ 28 Apr 2013; Tomáš Chvátal <scarabeus@gentoo.org> mpv-9999.ebuild:
+ Update wayland useflag usage a bit. Patch by Nikoli.
27 Apr 2013; Tomáš Chvátal <scarabeus@gentoo.org> mpv-9999.ebuild:
Try to enable wayland stuff via useflag.
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index f7be87b65ef0..85c25d001f61 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-9999.ebuild,v 1.3 2013/04/27 18:57:40 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-9999.ebuild,v 1.4 2013/04/28 08:07:39 scarabeus Exp $
EAPI=5
@@ -27,9 +27,10 @@ REQUIRED_USE="
cddb? ( cdio network )
lcms? ( opengl )
libass? ( iconv )
- opengl? ( || ( aqua X ) )
+ opengl? ( || ( aqua wayland X ) )
radio? ( || ( dvb v4l ) )
vdpau? ( X )
+ wayland? ( opengl )
xinerama? ( X )
xscreensaver? ( X )
xv? ( X )
@@ -83,7 +84,11 @@ RDEPEND+="
pulseaudio? ( media-sound/pulseaudio )
quvi? ( >=media-libs/libquvi-0.4.1 )
samba? ( net-fs/samba )
- wayland? ( >=dev-libs/wayland-1.1.0 )
+ wayland? (
+ >=dev-libs/wayland-1.0.0
+ media-libs/mesa[egl,wayland]
+ >=x11-libs/libxkbcommon-0.2.0
+ )
>=virtual/ffmpeg-9[encode?]
"
ASM_DEP="dev-lang/yasm"
@@ -151,6 +156,7 @@ src_configure() {
###################
# SDL output is fallback for platforms where nothing better is available
myconf+=" --disable-sdl --disable-sdl2"
+ use wayland || myconf+=" --disable-wayland"
use encode || myconf+=" --disable-encoding"
use network || myconf+=" --disable-networking"
myconf+=" $(use_enable joystick)"
@@ -264,7 +270,7 @@ src_configure() {
# X enabled configuration #
###########################
use X || myconf+=" --disable-x11"
- uses="vdpau wayland xinerama xv"
+ uses="vdpau xinerama xv"
for i in ${uses}; do
use ${i} || myconf+=" --disable-${i}"
done