summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-05-13 22:22:12 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-05-13 22:22:12 +0000
commitca6546e3a0eaedbcc1d65bf1e56d1475a985eb1c (patch)
tree7dbe0268141eca32fc1b915802a17a0234d67ad7
parentAlways build shared libraries, so other programs can link against them withou... (diff)
downloadgentoo-2-ca6546e3a0eaedbcc1d65bf1e56d1475a985eb1c.tar.gz
gentoo-2-ca6546e3a0eaedbcc1d65bf1e56d1475a985eb1c.tar.bz2
gentoo-2-ca6546e3a0eaedbcc1d65bf1e56d1475a985eb1c.zip
(#132835) Bump to latest release. Ebuild based on work of Donald E. Curtis. Patch to fix blas/lapack detection by me.
(Portage version: 2.1_pre10-r5)
-rw-r--r--sci-libs/libghemical/files/2.00-really-find-blas-and-lapack.patch24
-rw-r--r--sci-libs/libghemical/files/digest-libghemical-2.003
-rw-r--r--sci-libs/libghemical/libghemical-2.00.ebuild38
3 files changed, 65 insertions, 0 deletions
diff --git a/sci-libs/libghemical/files/2.00-really-find-blas-and-lapack.patch b/sci-libs/libghemical/files/2.00-really-find-blas-and-lapack.patch
new file mode 100644
index 000000000000..bef730abbe4c
--- /dev/null
+++ b/sci-libs/libghemical/files/2.00-really-find-blas-and-lapack.patch
@@ -0,0 +1,24 @@
+diff -urN libghemical-2.00.orig/configure.ac libghemical-2.00/configure.ac
+--- libghemical-2.00.orig/configure.ac 2006-05-12 23:31:06.000000000 -0700
++++ libghemical-2.00/configure.ac 2006-05-12 23:54:20.000000000 -0700
+@@ -69,8 +69,18 @@
+ AC_CHECK_LIB([m], [acos])
+
+ if test $WITH_MPQC = yes; then
+- AC_CHECK_LIB([blas], [main], , AC_MSG_ERROR([Cannot find blas library needed for MPQC support]))
+- AC_CHECK_LIB([lapack], [main], , AC_MSG_ERROR([Cannot find lapack library needed for MPQC support]))
++ AC_CHECK_LIB([blas], [dgemm_], HAVE_BLAS="yes", , -lpthread)
++ AC_CHECK_LIB([blas], [dgemm], HAVE_BLAS="yes", , -lpthread)
++ AC_CHECK_LIB([blas], [dgemm__], HAVE_BLAS="yes", , -lpthread)
++ if test "x${HAVE_BLAS}" = "x"; then
++ AC_MSG_ERROR([Cannot find blas library needed for MPQC support])
++ fi
++ AC_CHECK_LIB([lapack], [cheev_], HAVE_LAPACK="yes", , -lpthread)
++ AC_CHECK_LIB([lapack], [cheev], HAVE_LAPACK="yes", , -lpthread)
++ AC_CHECK_LIB([lapack], [cheev__], HAVE_LAPACK="yes", , -lpthread)
++ if test "x${HAVE_LAPACK}" = "x"; then
++ AC_MSG_ERROR([Cannot find lapack library needed for MPQC support])
++ fi
+ AM_PATH_SC(1.2.5, HAVE_MPQC="yes", HAVE_MPQC="no")
+ if test "${HAVE_MPQC}" = "yes"; then
+ AC_DEFINE([ENABLE_MPQC], [], [Define if you are building a version that interfaces directly with MPQC])
diff --git a/sci-libs/libghemical/files/digest-libghemical-2.00 b/sci-libs/libghemical/files/digest-libghemical-2.00
new file mode 100644
index 000000000000..ae7c83b5d7a0
--- /dev/null
+++ b/sci-libs/libghemical/files/digest-libghemical-2.00
@@ -0,0 +1,3 @@
+MD5 19ee087b6f3c0ce816ed1722b4a5b002 libghemical-2.00.tar.gz 629479
+RMD160 8c49ce3f128ef937dfb4443e4ffebff0b9183a1d libghemical-2.00.tar.gz 629479
+SHA256 e873b3042df75fa1c9f37fc99f2ff14227965ed13c7680169f714ab6575d5f21 libghemical-2.00.tar.gz 629479
diff --git a/sci-libs/libghemical/libghemical-2.00.ebuild b/sci-libs/libghemical/libghemical-2.00.ebuild
new file mode 100644
index 000000000000..b196a32cb4e1
--- /dev/null
+++ b/sci-libs/libghemical/libghemical-2.00.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/libghemical-2.00.ebuild,v 1.1 2006/05/13 22:22:12 spyderous Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="Ghemical supports both quantum-mechanics (semi-empirical and ab initio) models and molecular mechanics models (there is an experimental Tripos 5.2-like force field for organic molecules). Also a tool for reduced protein models is included. Geometry optimization, molecular dynamics and a large set of visualization tools are currently available."
+HOMEPAGE="http://bioinformatics.org/ghemical/"
+SRC_URI="http://www.bioinformatics.org/ghemical/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="mopac7 mpqc"
+RDEPEND="mopac7? ( sci-chemistry/mopac7 )
+ mpqc? ( >=sci-chemistry/mpqc-2.3.1-r1
+ virtual/blas
+ virtual/lapack )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.15"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-really-find-blas-and-lapack.patch
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable mopac7) \
+ $(use_enable mpqc) \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+}