summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-08-06 06:56:53 +0000
committerTorsten Veller <tove@gentoo.org>2009-08-06 06:56:53 +0000
commitc7e407a115bb611c02faab14eb6b2f4a04e0520e (patch)
treea1e41779980370c0377a8494fb8ff6db9a8dfa4d
parent10.0 releng. (diff)
downloadgentoo-2-c7e407a115bb611c02faab14eb6b2f4a04e0520e.tar.gz
gentoo-2-c7e407a115bb611c02faab14eb6b2f4a04e0520e.tar.bz2
gentoo-2-c7e407a115bb611c02faab14eb6b2f4a04e0520e.zip
Version bump
(Portage version: 2.2_rc36/cvs/Linux x86_64)
-rw-r--r--net-mail/fetchmail/ChangeLog9
-rw-r--r--net-mail/fetchmail/fetchmail-6.3.11.ebuild108
2 files changed, 115 insertions, 2 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index 52d604447708..dac5cddf65ed 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/fetchmail
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.157 2009/02/20 16:49:50 dertobi123 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.158 2009/08/06 06:56:53 tove Exp $
+
+*fetchmail-6.3.11 (06 Aug 2009)
+
+ 06 Aug 2009; Torsten Veller <tove@gentoo.org> +fetchmail-6.3.11.ebuild:
+ Version bump
*fetchmail-6.3.9-r1 (20 Feb 2009)
diff --git a/net-mail/fetchmail/fetchmail-6.3.11.ebuild b/net-mail/fetchmail/fetchmail-6.3.11.ebuild
new file mode 100644
index 000000000000..bb0901b6c8f6
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.3.11.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.11.ebuild,v 1.1 2009/08/06 06:56:53 tove Exp $
+
+EAPI=2
+
+inherit multilib python eutils
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://fetchmail.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl nls kerberos krb4 hesiod"
+
+RDEPEND="hesiod? ( net-dns/hesiod )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( app-crypt/mit-krb5 )
+ nls? ( virtual/libintl )
+ elibc_FreeBSD? ( sys-libs/com_err )
+ virtual/python"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+}
+
+src_prepare() {
+ # this patch fixes bug #34788 (ticho@gentoo.org 2004-09-03)
+ epatch "${FILESDIR}"/${PN}-6.2.5-broken-headers.patch
+
+ # dont compile during src_install
+ : > "${S}"/py-compile
+}
+
+src_configure() {
+# PYTHON=: \
+ econf \
+ --disable-dependency-tracking \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ $(use_with krb4 kerberos) \
+ $(use_with ssl) \
+ $(use_with hesiod) \
+ ${myconf} || die "Configuration failed."
+}
+
+src_install() {
+ # dir for pidfile
+ dodir /var/run/${PN} || die "dodir failed"
+ keepdir /var/run/${PN}
+ fowners ${PN}:${PN} /var/run/${PN} || die "fowners failed"
+
+ # fetchmail's homedir (holds fetchmail's .fetchids)
+ dodir /var/lib/${PN} || die "dodir failed"
+ keepdir /var/lib/${PN}
+ fowners ${PN}:${PN} /var/lib/${PN} || die "fowners failed"
+ fperms 700 /var/lib/${PN} || die "fperms failed"
+
+ emake DESTDIR="${D}" install || die
+ python_need_rebuild
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO || die
+
+ newinitd "${FILESDIR}"/fetchmail.new fetchmail || die
+ newconfd "${FILESDIR}"/conf.d-fetchmail fetchmail || die
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
+
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ elog
+ elog "You will not be able to use fetchmailconf(1), because you"
+ elog "don't seem to have Python with tkinter support."
+ elog
+ elog "If you want to be able to use fetchmailconf(1), do the following:"
+ elog " 1. Add 'tk' to the USE variable in /etc/make.conf."
+ elog " 2. (Re-)merge Python."
+ elog
+ fi
+
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages
+}