summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-04-26 20:25:14 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-04-26 20:25:14 +0000
commitc2901093f4fa2babefae868676cd41ba3d8a9e72 (patch)
tree763fe0e33bc49c24ba34fcb29c2aa4984d529652
parentVersion bump zeromq to 2.1.6. (diff)
downloadgentoo-2-c2901093f4fa2babefae868676cd41ba3d8a9e72.tar.gz
gentoo-2-c2901093f4fa2babefae868676cd41ba3d8a9e72.tar.bz2
gentoo-2-c2901093f4fa2babefae868676cd41ba3d8a9e72.zip
fix building with boost-1.46 (bug #362933)
(Portage version: 2.1.9.42/cvs/Linux i686)
-rw-r--r--games-board/pokerth/ChangeLog5
-rw-r--r--games-board/pokerth/pokerth-0.8.3.ebuild4
2 files changed, 7 insertions, 2 deletions
diff --git a/games-board/pokerth/ChangeLog b/games-board/pokerth/ChangeLog
index 9415be63b450..d0ac8d0a993e 100644
--- a/games-board/pokerth/ChangeLog
+++ b/games-board/pokerth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-board/pokerth
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.27 2011/03/18 13:08:55 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.28 2011/04/26 20:25:14 mr_bones_ Exp $
+
+ 26 Apr 2011; Michael Sterrett <mr_bones_@gentoo.org> pokerth-0.8.3.ebuild:
+ fix building with boost-1.46 (bug #362933)
18 Mar 2011; Thomas Kahle <tomka@gentoo.org> pokerth-0.8.3.ebuild:
x86 stable per bug 356489
diff --git a/games-board/pokerth/pokerth-0.8.3.ebuild b/games-board/pokerth/pokerth-0.8.3.ebuild
index 16f45dcb2c48..123f1f75d2e5 100644
--- a/games-board/pokerth/pokerth-0.8.3.ebuild
+++ b/games-board/pokerth/pokerth-0.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.8.3.ebuild,v 1.5 2011/03/18 13:08:55 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.8.3.ebuild,v 1.6 2011/04/26 20:25:14 mr_bones_ Exp $
EAPI=2
inherit multilib flag-o-matic eutils qt4-r2 games
@@ -54,6 +54,8 @@ src_prepare() {
-I/usr/include/boost-${boost_ver}
append-ldflags \
-L/usr/$(get_libdir)/boost-${boost_ver}
+ append-flags -DBOOST_FILESYSTEM_VERSION=2
+
export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
}