summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-09-28 15:23:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-09-28 15:23:29 +0000
commitc197a0fd227ff37ac3db000f47635ed50713e643 (patch)
tree7295720b95663922445b2ca50cff3ca77101f177
parentNew application, fixes bug 107076. (diff)
downloadgentoo-2-c197a0fd227ff37ac3db000f47635ed50713e643.tar.gz
gentoo-2-c197a0fd227ff37ac3db000f47635ed50713e643.tar.bz2
gentoo-2-c197a0fd227ff37ac3db000f47635ed50713e643.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
-rw-r--r--games-strategy/warzone2100/ChangeLog8
-rw-r--r--games-strategy/warzone2100/warzone2100-2.3.5.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/games-strategy/warzone2100/ChangeLog b/games-strategy/warzone2100/ChangeLog
index 7fff05523c97..59a557f34ac0 100644
--- a/games-strategy/warzone2100/ChangeLog
+++ b/games-strategy/warzone2100/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/warzone2100
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.51 2010/09/20 20:47:11 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.52 2010/09/28 15:23:29 mr_bones_ Exp $
+
+*warzone2100-2.3.5 (28 Sep 2010)
+
+ 28 Sep 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +warzone2100-2.3.5.ebuild:
+ version bump
20 Sep 2010; Markos Chandras <hwoarang@gentoo.org>
warzone2100-2.3.4.ebuild:
diff --git a/games-strategy/warzone2100/warzone2100-2.3.5.ebuild b/games-strategy/warzone2100/warzone2100-2.3.5.ebuild
new file mode 100644
index 000000000000..c471312c2def
--- /dev/null
+++ b/games-strategy/warzone2100/warzone2100-2.3.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/warzone2100-2.3.5.ebuild,v 1.1 2010/09/28 15:23:29 mr_bones_ Exp $
+
+EAPI=2
+inherit versionator games
+
+MY_PV=$(get_version_component_range -2)
+VIDEOS_PV=2.2
+VIDEOS_P=${PN}-videos-${VIDEOS_PV}.wz
+DESCRIPTION="3D real-time strategy game"
+HOMEPAGE="http://wz2100.net/"
+SRC_URI="mirror://sourceforge/warzone2100/${P}.tar.gz
+ videos? ( mirror://sourceforge/warzone2100/warzone2100/Videos/${VIDEOS_PV}/high-quality-en/sequences.wz -> ${VIDEOS_P} )"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-3.0 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+# upstream requested debug support
+IUSE="debug nls videos"
+
+RDEPEND="dev-db/sqlite:3
+ >=dev-games/physfs-2[zip]
+ dev-libs/popt
+ media-libs/libogg
+ media-libs/libpng
+ media-libs/libsdl[opengl,video]
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl-net
+ media-libs/quesoglc
+ virtual/glu
+ virtual/opengl
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/zip
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}
+ media-fonts/dejavu"
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --docdir=/usr/share/doc/${PF} \
+ --localedir=/usr/share/locale \
+ --with-distributor="Gentoo ${PF}" \
+ --with-icondir=/usr/share/pixmaps \
+ --with-applicationdir=/usr/share/applications \
+ $(use_enable debug debug relaxed) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING*
+ if use videos ; then
+ insinto "${GAMES_DATADIR}"/${PN}
+ newins "${DISTDIR}"/${VIDEOS_P} sequences.wz \
+ || die "newins failed"
+ fi
+ prepgamesdirs
+}