summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-12 15:06:09 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-12 15:06:09 +0000
commitbfc5f69816d9c8bd3ad91e51035081753effdb13 (patch)
tree4bac130cd70847edbd438eb6f4adf8ef4acc85f1
parentsh KEYWORDS (Manifest recommit) (diff)
downloadgentoo-2-bfc5f69816d9c8bd3ad91e51035081753effdb13.tar.gz
gentoo-2-bfc5f69816d9c8bd3ad91e51035081753effdb13.tar.bz2
gentoo-2-bfc5f69816d9c8bd3ad91e51035081753effdb13.zip
sh KEYWORDS
-rw-r--r--app-arch/bzip2/bzip2-1.0.2-r3.ebuild10
-rw-r--r--app-arch/gzip/files/digest-gzip-1.3.3-r41
-rw-r--r--app-arch/gzip/files/gzip-1.3.3-security.patch91
-rw-r--r--app-arch/gzip/gzip-1.3.3-r4.ebuild79
-rw-r--r--app-arch/gzip/gzip-1.3.5-r2.ebuild4
-rw-r--r--app-arch/ncompress/ncompress-4.2.4-r1.ebuild4
-rw-r--r--app-arch/tar/files/digest-tar-1.14.901
-rw-r--r--app-arch/tar/tar-1.13.92-r3.ebuild5
-rw-r--r--app-arch/tar/tar-1.14.90-r1.ebuild4
-rw-r--r--app-arch/tar/tar-1.14.90.ebuild67
-rw-r--r--app-arch/tar/tar-1.14.ebuild4
-rw-r--r--sys-libs/db/db-4.1.25_p1-r3.ebuild4
-rw-r--r--sys-libs/db/db-4.1.25_p1-r4.ebuild4
13 files changed, 19 insertions, 259 deletions
diff --git a/app-arch/bzip2/bzip2-1.0.2-r3.ebuild b/app-arch/bzip2/bzip2-1.0.2-r3.ebuild
index 83eaff8bbdc1..047764b08260 100644
--- a/app-arch/bzip2/bzip2-1.0.2-r3.ebuild
+++ b/app-arch/bzip2/bzip2-1.0.2-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/bzip2-1.0.2-r3.ebuild,v 1.16 2004/08/15 07:00:16 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/bzip2-1.0.2-r3.ebuild,v 1.17 2004/11/12 15:02:51 vapier Exp $
-inherit gcc flag-o-matic
+inherit toolchain-funcs flag-o-matic
DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
HOMEPAGE="http://sources.redhat.com/bzip2/"
@@ -10,7 +10,7 @@ SRC_URI="ftp://sources.redhat.com/pub/bzip2/v102/${P}.tar.gz"
LICENSE="BZIP2"
SLOT="0"
-KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
IUSE="build static debug cross"
DEPEND="virtual/libc"
@@ -41,9 +41,9 @@ src_unpack() {
src_compile() {
if ! use build
then
- emake CC="$(gcc-getCC)" CXX="$(gcc-getCXX)" -f Makefile-libbz2_so all || die "Make failed"
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f Makefile-libbz2_so all || die "Make failed"
fi
- emake CC="$(gcc-getCC)" CXX="$(gcc-getCXX)" all || die "Make failed"
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" all || die "Make failed"
}
src_install() {
diff --git a/app-arch/gzip/files/digest-gzip-1.3.3-r4 b/app-arch/gzip/files/digest-gzip-1.3.3-r4
deleted file mode 100644
index 8ee90a6f0a0d..000000000000
--- a/app-arch/gzip/files/digest-gzip-1.3.3-r4
+++ /dev/null
@@ -1 +0,0 @@
-MD5 52eaf713673507d21f7abefee98ba662 gzip-1.3.3.tar.gz 312263
diff --git a/app-arch/gzip/files/gzip-1.3.3-security.patch b/app-arch/gzip/files/gzip-1.3.3-security.patch
deleted file mode 100644
index a54b7b0fc6ab..000000000000
--- a/app-arch/gzip/files/gzip-1.3.3-security.patch
+++ /dev/null
@@ -1,91 +0,0 @@
---- gzip-1.3.2.orig/znew.in
-+++ gzip-1.3.2/znew.in
-@@ -16,8 +16,8 @@
- warn="(does not preserve modes and timestamp)"
- tmp=/tmp/zfoo.$$
- set -C
--echo hi > $tmp.1
--echo hi > $tmp.2
-+echo hi > $tmp.1 || exit 1
-+echo hi > $tmp.2 || exit 1
- if test -z "`(${CPMOD-cpmod} $tmp.1 $tmp.2) 2>&1`"; then
- cpmod=${CPMOD-cpmod}
- warn=""
-
---- gzip-1.3.2.orig/gzexe.in 1998-09-17 20:43:06.000000000 -0400
-+++ gzip-1.3.2/gzexe.in 2004-06-23 18:20:31.840776483 -0400
-@@ -21,8 +21,10 @@
- exit 1
- fi
-
-+set -C
- tmp=gz$$
- trap "rm -f $tmp; exit 1" 1 2 3 5 10 13 15
-+: > $tmp || exit 1
-
- decomp=0
- res=0
-@@ -32,8 +34,8 @@
- shift
- fi
-
--echo hi > zfoo1$$
--echo hi > zfoo2$$
-+echo hi > zfoo1$$ || exit 1
-+echo hi > zfoo2$$ || exit 1
- if test -z "`(${CPMOD-cpmod} zfoo1$$ zfoo2$$) 2>&1`"; then
- cpmod=${CPMOD-cpmod}
- fi
-@@ -86,26 +88,28 @@
- writable=0
- chmod u+w $tmp 2>/dev/null
- fi
-+ : >| $tmp # truncate the file, ignoring set -C
- fi
- if test $decomp -eq 0; then
-- sed 1q $0 > $tmp
-+ sed 1q $0 >> $tmp
- sed "s|^if tail|if $tail|" >> $tmp <<'EOF'
--skip=22
-+skip=23
- set -C
- umask=`umask`
- umask 77
--if tail +$skip $0 | "BINDIR"/gzip -cd > /tmp/gztmp$$; then
-+tmpfile=`tempfile -p gztmp -d /tmp` || exit 1
-+if tail -n +$skip "$0" | /bin/gzip -cd >> $tmpfile; then
- umask $umask
-- /bin/chmod 700 /tmp/gztmp$$
-+ /bin/chmod 700 $tmpfile
- prog="`echo $0 | /bin/sed 's|^.*/||'`"
-- if /bin/ln /tmp/gztmp$$ "/tmp/$prog" 2>/dev/null; then
-- trap '/bin/rm -f /tmp/gztmp$$ "/tmp/$prog"; exit $res' 0
-- (/bin/sleep 5; /bin/rm -f /tmp/gztmp$$ "/tmp/$prog") 2>/dev/null &
-+ if /bin/ln $tmpfile "/tmp/$prog" 2>/dev/null; then
-+ trap '/bin/rm -f $tmpfile "/tmp/$prog"; exit $res' 0
-+ (/bin/sleep 5; /bin/rm -f $tmpfile "/tmp/$prog") 2>/dev/null &
- /tmp/"$prog" ${1+"$@"}; res=$?
- else
-- trap '/bin/rm -f /tmp/gztmp$$; exit $res' 0
-- (/bin/sleep 5; /bin/rm -f /tmp/gztmp$$) 2>/dev/null &
-- /tmp/gztmp$$ ${1+"$@"}; res=$?
-+ trap '/bin/rm -f $tmpfile; exit $res' 0
-+ (/bin/sleep 5; /bin/rm -f $tmpfile) 2>/dev/null &
-+ $tmpfile ${1+"$@"}; res=$?
- fi
- else
- echo Cannot decompress $0; exit 1
-@@ -120,11 +124,11 @@
-
- else
- # decompression
-- skip=22
-+ skip=23
- if sed -e 1d -e 2q "$i" | grep "^skip=[0-9]*$" >/dev/null; then
- eval `sed -e 1d -e 2q "$i"`
- fi
-- if tail +$skip "$i" | gzip -cd > $tmp; then
-+ if tail -n +$skip "$i" | gzip -cd >> $tmp; then
- :
- else
- echo ${x}: $i probably not in gzexe format, file unchanged.
diff --git a/app-arch/gzip/gzip-1.3.3-r4.ebuild b/app-arch/gzip/gzip-1.3.3-r4.ebuild
deleted file mode 100644
index 89becce6343e..000000000000
--- a/app-arch/gzip/gzip-1.3.3-r4.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.3-r4.ebuild,v 1.3 2004/06/25 23:50:35 vapier Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Standard GNU compressor"
-HOMEPAGE="http://www.gnu.org/software/gzip/gzip.html"
-SRC_URI="http://www.gzip.org/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc sparc mips -alpha arm hppa amd64 ia64 ppc64 s390"
-IUSE="nls build static"
-
-RDEPEND="virtual/libc"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-PROVIDE="virtual/gzip"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-security.patch
-}
-
-src_compile() {
- use static && append-flags -static
-
- econf \
- --exec-prefix=/ \
- `use_enable nls` \
- || die
- emake || die
-}
-
-src_install() {
- dodir /usr/bin /usr/share/man/man1
- make prefix=${D}/usr \
- exec_prefix=${D}/ \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
-
- cd ${D}/bin
- for i in gzexe zforce zgrep zmore znew zcmp
- do
- dosed -e "1d" -e "s:${D}::" ${i}
- chmod 755 ${i}
- done
-
- # No need to waste space -- these guys should be links
- # gzcat is equivilant to zcat, but historically zcat
- # was a link to compress.
- rm -f gunzip zcat zcmp zegrep zfgrep
- dosym gzip /bin/gunzip
- dosym gzip /bin/gzcat
- dosym gzip /bin/zcat
- dosym zdiff /bin/zcmp
- dosym zgrep /bin/zegrep
- dosym zgrep /bin/zfgrep
-
- if ! use build
- then
- cd ${D}/usr/share/man/man1
- rm -f gunzip.* zcmp.* zcat.*
- ln -s gzip.1.gz gunzip.1.gz
- ln -s zdiff.1.gz zcmp.1.gz
- ln -s gzip.1.gz zcat.1.gz
- ln -s gzip.1.gz gzcat.1.gz
- cd ${S}
- rm -rf ${D}/usr/man ${D}/usr/lib
- dodoc ChangeLog NEWS README THANKS TODO
- docinto txt
- dodoc algorithm.doc gzip.doc
- else
- rm -rf ${D}/usr
- fi
-}
diff --git a/app-arch/gzip/gzip-1.3.5-r2.ebuild b/app-arch/gzip/gzip-1.3.5-r2.ebuild
index dd6b9cc951de..c2ba218fa0e5 100644
--- a/app-arch/gzip/gzip-1.3.5-r2.ebuild
+++ b/app-arch/gzip/gzip-1.3.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.5-r2.ebuild,v 1.9 2004/10/30 15:58:49 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.5-r2.ebuild,v 1.10 2004/11/12 15:04:27 vapier Exp $
inherit eutils flag-o-matic
@@ -13,7 +13,7 @@ SRC_URI="mirror://debian/pool/main/g/gzip/gzip_${PV}.orig.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc s390 x86"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
IUSE="nls build static pic"
RDEPEND="virtual/libc"
diff --git a/app-arch/ncompress/ncompress-4.2.4-r1.ebuild b/app-arch/ncompress/ncompress-4.2.4-r1.ebuild
index 4b5385af9a8a..0c57cfd43b67 100644
--- a/app-arch/ncompress/ncompress-4.2.4-r1.ebuild
+++ b/app-arch/ncompress/ncompress-4.2.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/ncompress/ncompress-4.2.4-r1.ebuild,v 1.10 2004/10/26 13:13:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ncompress/ncompress-4.2.4-r1.ebuild,v 1.11 2004/11/12 15:05:58 vapier Exp $
inherit eutils toolchain-funcs
@@ -11,7 +11,7 @@ SRC_URI="ftp://ftp.leo.org/pub/comp/os/unix/linux/sunsite/utils/compress/${P}.ta
LICENSE="public-domain"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
IUSE="build"
src_unpack() {
diff --git a/app-arch/tar/files/digest-tar-1.14.90 b/app-arch/tar/files/digest-tar-1.14.90
deleted file mode 100644
index 7b1ccdf80dfa..000000000000
--- a/app-arch/tar/files/digest-tar-1.14.90
+++ /dev/null
@@ -1 +0,0 @@
-MD5 dd816b09dadaf6a4e9a46d22993f6d44 tar-1.14.90.tar.bz2 1309070
diff --git a/app-arch/tar/tar-1.13.92-r3.ebuild b/app-arch/tar/tar-1.13.92-r3.ebuild
index a74b55a82cd4..f7cae877b0a7 100644
--- a/app-arch/tar/tar-1.13.92-r3.ebuild
+++ b/app-arch/tar/tar-1.13.92-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.13.92-r3.ebuild,v 1.17 2004/10/11 17:46:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.13.92-r3.ebuild,v 1.18 2004/11/12 15:06:09 vapier Exp $
inherit eutils gnuconfig
@@ -10,13 +10,12 @@ SRC_URI="ftp://alpha.gnu.org/pub/pub/gnu/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ~ia64 ~ppc64 s390"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
IUSE="nls static build"
DEPEND="app-arch/gzip
app-arch/bzip2
app-arch/ncompress"
-
RDEPEND="nls? ( >=sys-devel/gettext-0.10.35 )"
src_unpack() {
diff --git a/app-arch/tar/tar-1.14.90-r1.ebuild b/app-arch/tar/tar-1.14.90-r1.ebuild
index d6447366e36a..80f79dee9489 100644
--- a/app-arch/tar/tar-1.14.90-r1.ebuild
+++ b/app-arch/tar/tar-1.14.90-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.14.90-r1.ebuild,v 1.2 2004/11/03 15:48:16 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.14.90-r1.ebuild,v 1.3 2004/11/12 15:06:09 vapier Exp $
inherit flag-o-matic eutils gnuconfig
@@ -12,7 +12,7 @@ SRC_URI="http://dev.gentoo.org/~seemant/distfiles/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="nls static build"
DEPEND="virtual/libc
diff --git a/app-arch/tar/tar-1.14.90.ebuild b/app-arch/tar/tar-1.14.90.ebuild
deleted file mode 100644
index 4264b5d75ed4..000000000000
--- a/app-arch/tar/tar-1.14.90.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.14.90.ebuild,v 1.8 2004/10/13 19:38:49 vapier Exp $
-
-inherit flag-o-matic eutils gnuconfig
-
-DESCRIPTION="Use this to make tarballs :)"
-HOMEPAGE="http://www.gnu.org/software/tar/"
-SRC_URI="http://dev.gentoo.org/~seemant/distfiles/${P}.tar.bz2
- http://alpha.gnu.org/gnu/tar/${P}.tar.bz2
- mirror://gnu/tar/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="nls static build"
-
-DEPEND="virtual/libc
- app-arch/gzip
- app-arch/bzip2
- app-arch/ncompress"
-RDEPEND="${DEPEND}
- nls? ( >=sys-devel/gettext-0.10.35 )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-remote-shell.patch #66959
- epatch ${FILESDIR}/${PV}-tests.patch #67023
- epatch ${FILESDIR}/${PV}-gnulib.patch #67038
- gnuconfig_update
- use static && append-ldflags -static
-}
-
-src_compile() {
- # Work around bug in sandbox #67051
- gl_cv_func_chown_follows_symlink=yes \
- econf \
- --disable-dependency-tracking \
- --bindir=/bin \
- --libexecdir=/usr/sbin \
- $(use_enable nls) || die
- emake || die "emake failed"
-}
-
-src_test() {
- if [ "${ARCH}" == "x86" ] ; then
- einfo "Skipping make test due to a glibc bug (See #67051)."
- einfo "Then again, it probably would have worked anyways."
- einfo "So have some faith and pretend everything is OK."
- else
- make test || die "make test failed"
- fi
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- # a nasty yet required symlink:
- dodir /etc
- dosym ../usr/sbin/rmt /etc/rmt
- if use build ; then
- rm -rf ${D}/usr
- else
- dodoc AUTHORS ChangeLog* NEWS README* PORTS THANKS
- doman "${FILESDIR}/tar.1"
- fi
-}
diff --git a/app-arch/tar/tar-1.14.ebuild b/app-arch/tar/tar-1.14.ebuild
index bbec3ae6af92..f6eec5cf8f70 100644
--- a/app-arch/tar/tar-1.14.ebuild
+++ b/app-arch/tar/tar-1.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.14.ebuild,v 1.14 2004/10/10 07:01:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.14.ebuild,v 1.15 2004/11/12 15:06:09 vapier Exp $
inherit flag-o-matic eutils gnuconfig
@@ -10,7 +10,7 @@ SRC_URI="http://ftp.gnu.org/gnu/tar/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
IUSE="nls static build"
DEPEND="virtual/libc
diff --git a/sys-libs/db/db-4.1.25_p1-r3.ebuild b/sys-libs/db/db-4.1.25_p1-r3.ebuild
index dfdb237fe738..982521017f2e 100644
--- a/sys-libs/db/db-4.1.25_p1-r3.ebuild
+++ b/sys-libs/db/db-4.1.25_p1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.25_p1-r3.ebuild,v 1.26 2004/10/01 14:33:56 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.25_p1-r3.ebuild,v 1.27 2004/11/12 15:01:58 vapier Exp $
inherit eutils gnuconfig db
@@ -27,7 +27,7 @@ done
LICENSE="DB"
SLOT="4.1"
-KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390 sh"
IUSE="tcltk java doc"
DEPEND="tcltk? ( dev-lang/tcl )
diff --git a/sys-libs/db/db-4.1.25_p1-r4.ebuild b/sys-libs/db/db-4.1.25_p1-r4.ebuild
index bdce3b33b47c..447e826649ea 100644
--- a/sys-libs/db/db-4.1.25_p1-r4.ebuild
+++ b/sys-libs/db/db-4.1.25_p1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.25_p1-r4.ebuild,v 1.8 2004/10/01 14:33:56 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.25_p1-r4.ebuild,v 1.9 2004/11/12 15:01:58 vapier Exp $
inherit eutils gnuconfig db
@@ -27,7 +27,7 @@ done
LICENSE="DB"
SLOT="4.1"
-KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390 ~sh"
IUSE="tcltk java doc uclibc"
DEPEND="tcltk? ( dev-lang/tcl )