summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-08-11 08:35:38 +0000
committerHans de Graaff <graaff@gentoo.org>2012-08-11 08:35:38 +0000
commitbfb7dee0bf0369ec6c3ef00192c678b8cfe84fb8 (patch)
tree410201a0d09131f43c0e3e9a55e86f50e6a72743
parentadd ruby19 support; migrate to EAPI4 and rspec2 (diff)
downloadgentoo-2-bfb7dee0bf0369ec6c3ef00192c678b8cfe84fb8.tar.gz
gentoo-2-bfb7dee0bf0369ec6c3ef00192c678b8cfe84fb8.tar.bz2
gentoo-2-bfb7dee0bf0369ec6c3ef00192c678b8cfe84fb8.zip
Version bumps for security bug 430718.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
-rw-r--r--dev-ruby/activesupport/ChangeLog9
-rw-r--r--dev-ruby/activesupport/activesupport-3.0.17.ebuild48
-rw-r--r--dev-ruby/activesupport/activesupport-3.1.8.ebuild62
3 files changed, 118 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 29456183335f..12eb867895d8 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.183 2012/08/10 06:42:29 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.184 2012/08/11 08:35:38 graaff Exp $
+
+*activesupport-3.1.8 (11 Aug 2012)
+*activesupport-3.0.17 (11 Aug 2012)
+
+ 11 Aug 2012; Hans de Graaff <graaff@gentoo.org> +activesupport-3.0.17.ebuild,
+ +activesupport-3.1.8.ebuild:
+ Version bumps for security bug 430718.
*activesupport-3.2.8 (10 Aug 2012)
diff --git a/dev-ruby/activesupport/activesupport-3.0.17.ebuild b/dev-ruby/activesupport/activesupport-3.0.17.ebuild
new file mode 100644
index 000000000000..e6bee9e6750c
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.0.17.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.0.17.ebuild,v 1.1 2012/08/11 08:35:38 graaff Exp $
+
+EAPI=4
+
+# jruby fails tests.
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/${PN}"
+
+ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8"
+
+# libxml-ruby and nokogiri are not strictly needed, but there are tests
+# using this code.
+ruby_add_bdepend "test? ( >=dev-ruby/libxml-2.0.0 dev-ruby/nokogiri >=dev-ruby/mocha-0.10.5 )"
+
+all_ruby_prepare() {
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-3.0.3-mocha-0.9.5.patch
+
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Avoid tests that do not work with newer versions of mocha.
+ rm test/whiny_nil_test.rb || die
+}
diff --git a/dev-ruby/activesupport/activesupport-3.1.8.ebuild b/dev-ruby/activesupport/activesupport-3.1.8.ebuild
new file mode 100644
index 000000000000..c032c914abba
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.1.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.1.8.ebuild,v 1.1 2012/08/11 08:35:38 graaff Exp $
+
+EAPI=4
+
+# jruby fails tests.
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/${PN}"
+
+ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8
+ >=dev-ruby/multi_json-1.0
+ dev-ruby/i18n:0.6
+ !!<dev-ruby/activesupport-3.0.11-r1:3.0"
+
+# libxml-ruby, nokogiri, and builder are not strictly needed, but there
+# are tests using this code.
+ruby_add_bdepend "test? (
+ virtual/ruby-test-unit
+ >=dev-ruby/libxml-2.0.0
+ dev-ruby/nokogiri
+ dev-ruby/builder:0
+ )"
+
+all_ruby_prepare() {
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-3.0.3-mocha-0.9.5.patch
+
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Remove upper restriction from gemspec. All tests pass with
+ # multi_json 1.3.5. The upstream commit doesn't give details but
+ # most likely this was added to avoid multi_json 1.3.0 which broke
+ # compatibility. This was later fixed in 1.3.1. 1.3.0 is no longer
+ # in portage so from a Gentoo point of view it is safe to depend on
+ # => 1.0.
+ sed -i -e "s/, '< 1.3'//" activesupport.gemspec || die
+
+ # Avoid tests that do not work with newer versions of mocha.
+ rm test/whiny_nil_test.rb || die
+}