summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-01-16 04:46:04 +0000
committerTim Harder <radhermit@gentoo.org>2012-01-16 04:46:04 +0000
commitbcbf94c0430c3b552ac51905fc94423dd9a00339 (patch)
treec0af7c9f4a80061f5ebce5dd3ac71c84e009511d
parentLet's unmask rhythmbox-2.9x, the worst bugs seem to be fixed (diff)
downloadgentoo-2-bcbf94c0430c3b552ac51905fc94423dd9a00339.tar.gz
gentoo-2-bcbf94c0430c3b552ac51905fc94423dd9a00339.tar.bz2
gentoo-2-bcbf94c0430c3b552ac51905fc94423dd9a00339.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
-rw-r--r--dev-libs/libexplain/ChangeLog9
-rw-r--r--dev-libs/libexplain/libexplain-0.50.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/dev-libs/libexplain/ChangeLog b/dev-libs/libexplain/ChangeLog
index 92520b9fb450..4074f5ecaf36 100644
--- a/dev-libs/libexplain/ChangeLog
+++ b/dev-libs/libexplain/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libexplain
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/ChangeLog,v 1.12 2011/11/28 01:53:50 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/ChangeLog,v 1.13 2012/01/16 04:46:04 radhermit Exp $
+
+*libexplain-0.50 (16 Jan 2012)
+
+ 16 Jan 2012; Tim Harder <radhermit@gentoo.org> +libexplain-0.50.ebuild:
+ Version bump.
28 Nov 2011; Tim Harder <radhermit@gentoo.org> libexplain-0.49.ebuild:
Re-add the eautoreconf call and other minor fixes.
diff --git a/dev-libs/libexplain/libexplain-0.50.ebuild b/dev-libs/libexplain/libexplain-0.50.ebuild
new file mode 100644
index 000000000000..40039ab45090
--- /dev/null
+++ b/dev-libs/libexplain/libexplain-0.50.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/libexplain-0.50.ebuild,v 1.1 2012/01/16 04:46:04 radhermit Exp $
+
+EAPI=4
+inherit autotools-utils
+
+MY_P="${P}.D001"
+
+DESCRIPTION="Library which may be used to explain Unix and Linux system call errors"
+HOMEPAGE="http://libexplain.sourceforge.net/"
+SRC_URI="http://libexplain.sourceforge.net/${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE="static-libs"
+
+DEPEND="
+ >=sys-kernel/linux-headers-2.6.35
+ sys-libs/libcap
+ >=sys-libs/glibc-2.11"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( README )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.45-configure.patch
+)
+
+src_prepare() {
+ # Portage incompatible test
+ sed \
+ -e '/t0524a/d' \
+ -e '/t0363a/d' \
+ -i Makefile.in || die
+
+ cp "${S}"/etc/configure.ac "${S}"
+
+ autotools-utils_src_prepare
+ eautoreconf
+}