summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2004-10-18 17:03:04 +0000
committerAndres Loeh <kosmikus@gentoo.org>2004-10-18 17:03:04 +0000
commitb6f3a1361fdaee4afe8f778ecd00c03150533345 (patch)
treebe7bd48903bb2915904a9b6377e27159072020da
parentFixed missing dependencies; bug #68021. (Manifest recommit) (diff)
downloadgentoo-2-b6f3a1361fdaee4afe8f778ecd00c03150533345.tar.gz
gentoo-2-b6f3a1361fdaee4afe8f778ecd00c03150533345.tar.bz2
gentoo-2-b6f3a1361fdaee4afe8f778ecd00c03150533345.zip
new version for x86
-rw-r--r--dev-lang/ghc-bin/ChangeLog7
-rw-r--r--dev-lang/ghc-bin/files/digest-ghc-bin-6.2.21
-rw-r--r--dev-lang/ghc-bin/ghc-bin-6.2.2.ebuild59
3 files changed, 66 insertions, 1 deletions
diff --git a/dev-lang/ghc-bin/ChangeLog b/dev-lang/ghc-bin/ChangeLog
index 95819cbe5f21..582966120424 100644
--- a/dev-lang/ghc-bin/ChangeLog
+++ b/dev-lang/ghc-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ghc-bin
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ChangeLog,v 1.17 2004/10/17 09:05:32 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ChangeLog,v 1.18 2004/10/18 17:03:04 kosmikus Exp $
+
+*ghc-bin-6.2.2 (18 Oct 2004)
+
+ 18 Oct 2004; Andres Loeh <kosmikus@gentoo.org> ghc-bin-6.2.2.ebuild:
+ Version bump for x86.
*ghc-bin-6.2.1 (17 Oct 2004)
diff --git a/dev-lang/ghc-bin/files/digest-ghc-bin-6.2.2 b/dev-lang/ghc-bin/files/digest-ghc-bin-6.2.2
new file mode 100644
index 000000000000..e0a3f407e2c2
--- /dev/null
+++ b/dev-lang/ghc-bin/files/digest-ghc-bin-6.2.2
@@ -0,0 +1 @@
+MD5 ee3c9d20763ff5b23291e0be2c307ccc ghc-6.2.2-i386-unknown-linux.tar.bz2 14136384
diff --git a/dev-lang/ghc-bin/ghc-bin-6.2.2.ebuild b/dev-lang/ghc-bin/ghc-bin-6.2.2.ebuild
new file mode 100644
index 000000000000..874056bc0c86
--- /dev/null
+++ b/dev-lang/ghc-bin/ghc-bin-6.2.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ghc-bin-6.2.2.ebuild,v 1.1 2004/10/18 17:03:04 kosmikus Exp $
+
+IUSE="" # opengl not included in binary
+
+S="${WORKDIR}/ghc-${PV}"
+DESCRIPTION="Glasgow Haskell Compiler"
+SRC_URI="http://www.haskell.org/ghc/dist/${PV}/ghc-${PV}-i386-unknown-linux.tar.bz2"
+HOMEPAGE="http://www.haskell.org"
+
+LICENSE="as-is"
+KEYWORDS="~x86 -ppc -sparc -alpha"
+SLOT="0"
+
+LOC="/opt/ghc"
+
+DEPEND="virtual/libc"
+RDEPEND=">=dev-lang/perl-5.6.1
+ >=sys-devel/gcc-2.95.3
+ >=dev-libs/gmp-4.1"
+
+PROVIDE="virtual/ghc"
+
+src_compile() {
+ econf || die "./configure failed"
+}
+
+src_install () {
+ make \
+ prefix=${D}${LOC} \
+ datadir=${D}${LOC}/share \
+ mandir=${D}${LOC}/share/man \
+ infodir=${D}${LOC}/share/info \
+ install || die
+
+ # Install documentation.
+ dodoc ANNOUNCE INSTALL LICENSE README VERSION
+
+ cd ${D}${LOC}/share
+ mv hslibs.ps users_guide.ps html ${D}/usr/share/doc/${PF}
+
+ #ghc seems to set locations in wrapper scripts from make install
+ #need to strip the ${D} part out
+ cd ${D}${LOC}/bin
+ clean_wrappers ghc-${PV} ghci-${PV} ghc-pkg-${PV} hsc2hs
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/10ghc
+}
+
+clean_wrappers () {
+ for i in $*; do
+ mv ${i} ${i}-orig
+ sed -e "s:${D}::" ${i}-orig > ${i}
+ chmod a+x ${i}
+ rm ${i}-orig
+ done
+}