summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2015-02-28 15:52:03 +0000
committerAgostino Sarubbo <ago@gentoo.org>2015-02-28 15:52:03 +0000
commitb1a92dfda2a0957543c77451fe28cd8e5f03600f (patch)
treef68eddf33a17df33575c0e9006b5c9a629a71296
parentRemove old. (diff)
downloadgentoo-2-b1a92dfda2a0957543c77451fe28cd8e5f03600f.tar.gz
gentoo-2-b1a92dfda2a0957543c77451fe28cd8e5f03600f.tar.bz2
gentoo-2-b1a92dfda2a0957543c77451fe28cd8e5f03600f.zip
Fix bug #541654
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 7194459F)
-rw-r--r--media-video/vlc/ChangeLog7
-rw-r--r--media-video/vlc/files/vlc-2.1-mem_undefined_functions.patch14
-rw-r--r--media-video/vlc/vlc-2.1.2.ebuild5
-rw-r--r--media-video/vlc/vlc-2.1.5-r1.ebuild5
4 files changed, 28 insertions, 3 deletions
diff --git a/media-video/vlc/ChangeLog b/media-video/vlc/ChangeLog
index 4959af7b6cc9..4fdf7926ece3 100644
--- a/media-video/vlc/ChangeLog
+++ b/media-video/vlc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/vlc
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.931 2015/02/16 08:48:37 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.932 2015/02/28 15:52:03 ago Exp $
+
+ 28 Feb 2015; Agostino Sarubbo <ago@gentoo.org>
+ +files/vlc-2.1-mem_undefined_functions.patch, vlc-2.1.2.ebuild,
+ vlc-2.1.5-r1.ebuild:
+ Fix bug #541654
16 Feb 2015; Yixun Lan <dlan@gentoo.org> vlc-2.1.9999.ebuild:
foward libavcodec patch to 2.1.9999, disable bogus version check
diff --git a/media-video/vlc/files/vlc-2.1-mem_undefined_functions.patch b/media-video/vlc/files/vlc-2.1-mem_undefined_functions.patch
new file mode 100644
index 000000000000..7289c073641b
--- /dev/null
+++ b/media-video/vlc/files/vlc-2.1-mem_undefined_functions.patch
@@ -0,0 +1,14 @@
+# Fixes gentoo bug 541654
+# https://bugs.gentoo.org/show_bug.cgi?id=541654
+# Committed on behalf of Luca Barbato <lu_zero@gentoo.org>
+
+--- modules/codec/avcodec/avcommon.h.orig 2015-02-28 15:19:33.449761287 +0000
++++ modules/codec/avcodec/avcommon.h 2015-02-28 15:20:10.469537179 +0000
+@@ -81,6 +81,7 @@
+ #ifdef HAVE_LIBAVUTIL_AVUTIL_H
+ # include <libavutil/avutil.h>
+ # include <libavutil/dict.h>
++# include <libavutil/mem.h>
+
+ #define AV_OPTIONS_TEXT "Advanced options."
+ #define AV_OPTIONS_LONGTEXT "Advanced options, in the form {opt=val,opt2=val2} ."
diff --git a/media-video/vlc/vlc-2.1.2.ebuild b/media-video/vlc/vlc-2.1.2.ebuild
index 98fa81a12cc7..17d682176d0d 100644
--- a/media-video/vlc/vlc-2.1.2.ebuild
+++ b/media-video/vlc/vlc-2.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-2.1.2.ebuild,v 1.22 2015/02/16 02:16:22 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-2.1.2.ebuild,v 1.23 2015/02/28 15:52:03 ago Exp $
EAPI="5"
@@ -229,6 +229,9 @@ src_prepare() {
# Fix up broken audio; first is a fixed reversed bisected commit, latter two are backported.
epatch "${FILESDIR}"/${PN}-2.1.0-TomWij-bisected-PA-broken-underflow.patch
+ # Fix bug #541654
+ epatch "${FILESDIR}"/${PN}-2.1-mem_undefined_functions.patch
+
# Disable avcodec checks when avcodec is not used.
if ! use avcodec; then
sed -i 's/^#if LIBAVCODEC_VERSION_CHECK(.*)$/#if 0/' modules/codec/avcodec/fourcc.c || die
diff --git a/media-video/vlc/vlc-2.1.5-r1.ebuild b/media-video/vlc/vlc-2.1.5-r1.ebuild
index bd73ae52a7f9..2bf527f52e76 100644
--- a/media-video/vlc/vlc-2.1.5-r1.ebuild
+++ b/media-video/vlc/vlc-2.1.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-2.1.5-r1.ebuild,v 1.4 2015/02/16 08:27:10 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-2.1.5-r1.ebuild,v 1.5 2015/02/28 15:52:03 ago Exp $
EAPI="5"
@@ -246,6 +246,9 @@ src_prepare() {
# Fix up broken audio when skipping using a fixed reversed bisected commit.
epatch "${FILESDIR}"/${PN}-2.1.0-TomWij-bisected-PA-broken-underflow.patch
+ # Fix bug #541654
+ epatch "${FILESDIR}"/${PN}-2.1-mem_undefined_functions.patch
+
# Disable avcodec checks when avcodec is not used.
if ! use avcodec; then
sed -i 's/^#if LIBAVCODEC_VERSION_CHECK(.*)$/#if 0/' modules/codec/avcodec/fourcc.c || die