summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-20 22:28:28 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-20 22:28:28 +0000
commita5b9e54a5aa0d49db746a587eb67b1d06c92dd39 (patch)
treeea5369d61d1a37f2b4969b25c554446a73e2372a
parentMask dev-ruby/test-unit since it's only needed for 1.9. (diff)
downloadgentoo-2-a5b9e54a5aa0d49db746a587eb67b1d06c92dd39.tar.gz
gentoo-2-a5b9e54a5aa0d49db746a587eb67b1d06c92dd39.tar.bz2
gentoo-2-a5b9e54a5aa0d49db746a587eb67b1d06c92dd39.zip
Drop old ebuilds and drop ruby 1.8 support from 2.0.5: installed as a gem does not override the old one and causes problems.
(Portage version: 2.2_rc60/cvs/Linux x86_64)
-rw-r--r--dev-ruby/test-unit/ChangeLog8
-rw-r--r--dev-ruby/test-unit/test-unit-2.0.2-r1.ebuild51
-rw-r--r--dev-ruby/test-unit/test-unit-2.0.3.ebuild51
-rw-r--r--dev-ruby/test-unit/test-unit-2.0.5.ebuild5
4 files changed, 10 insertions, 105 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index 21a3faaa22aa..5c664b3e25f0 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.12 2009/12/16 18:15:34 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.13 2009/12/20 22:28:28 flameeyes Exp $
+
+ 20 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ -test-unit-2.0.2-r1.ebuild, -test-unit-2.0.3.ebuild,
+ test-unit-2.0.5.ebuild:
+ Drop old ebuilds and drop ruby 1.8 support from 2.0.5: installed as a gem
+ does not override the old one and causes problems.
16 Dec 2009; Jeroen Roovers <jer@gentoo.org> test-unit-2.0.5.ebuild:
Marked ~hppa (bug #297046).
diff --git a/dev-ruby/test-unit/test-unit-2.0.2-r1.ebuild b/dev-ruby/test-unit/test-unit-2.0.2-r1.ebuild
deleted file mode 100644
index 2b0a2980c7e9..000000000000
--- a/dev-ruby/test-unit/test-unit-2.0.2-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.0.2-r1.ebuild,v 1.4 2009/10/31 21:42:00 volkmar Exp $
-
-inherit ruby
-
-DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
-HOMEPAGE="http://test-unit.rubyforge.org/"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-IUSE="doc"
-
-DEPEND="
- doc? ( dev-ruby/rake
- dev-ruby/hoe )"
-# test? ( dev-ruby/rake
-# dev-ruby/hoe
-# dev-ruby/zentest )"
-RDEPEND=""
-
-USE_RUBY="ruby18 ruby19"
-
-src_compile() {
- if use doc; then
- rake doc || die "rake doc failed"
- fi
-}
-
-src_test() {
- for ruby in $USE_RUBY; do
- [[ -n `type -p $ruby` ]] || continue
- # the rake audit using dev-ruby/zentest currently fails, and we
- # just need to call the testsuite directly.
- # rake audit || die "rake audit failed"
- $ruby test/run-test.rb || die "testsuite failed"
- done
-}
-
-src_install() {
- cd "${S}"/lib
- doruby -r * || die "doruby failed"
-
- if use doc; then
- dohtml -r "${S}"/doc/* || die "dohtml failed"
- fi
-
- dodoc "${S}"/{TODO,README.txt,History.txt} || die "dodoc failed"
-}
diff --git a/dev-ruby/test-unit/test-unit-2.0.3.ebuild b/dev-ruby/test-unit/test-unit-2.0.3.ebuild
deleted file mode 100644
index cf8d46ef19c1..000000000000
--- a/dev-ruby/test-unit/test-unit-2.0.3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.0.3.ebuild,v 1.3 2009/10/31 21:42:00 volkmar Exp $
-
-inherit ruby
-
-DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
-HOMEPAGE="http://test-unit.rubyforge.org/"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="doc"
-
-DEPEND="
- doc? ( dev-ruby/rake
- dev-ruby/hoe )"
-# test? ( dev-ruby/rake
-# dev-ruby/hoe
-# dev-ruby/zentest )"
-RDEPEND=""
-
-USE_RUBY="ruby18 ruby19"
-
-src_compile() {
- if use doc; then
- rake doc || die "rake doc failed"
- fi
-}
-
-src_test() {
- for ruby in $USE_RUBY; do
- [[ -n `type -p $ruby` ]] || continue
- # the rake audit using dev-ruby/zentest currently fails, and we
- # just need to call the testsuite directly.
- # rake audit || die "rake audit failed"
- $ruby test/run-test.rb || die "testsuite failed"
- done
-}
-
-src_install() {
- cd "${S}"/lib
- doruby -r * || die "doruby failed"
-
- if use doc; then
- dohtml -r "${S}"/doc/* || die "dohtml failed"
- fi
-
- dodoc "${S}"/{TODO,README.txt,History.txt} || die "dodoc failed"
-}
diff --git a/dev-ruby/test-unit/test-unit-2.0.5.ebuild b/dev-ruby/test-unit/test-unit-2.0.5.ebuild
index 7b2117dc3f85..87253602943e 100644
--- a/dev-ruby/test-unit/test-unit-2.0.5.ebuild
+++ b/dev-ruby/test-unit/test-unit-2.0.5.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.0.5.ebuild,v 1.2 2009/12/16 18:15:34 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.0.5.ebuild,v 1.3 2009/12/20 22:28:28 flameeyes Exp $
EAPI=2
# One test fails on jruby, might be a jruby bug
-USE_RUBY="ruby18 ruby19"
+# When enabled on ruby18 it breaks too many things, so don't enable it for that just yet
+USE_RUBY="ruby19"
# Don't enable docs yet since this requires hoe
RUBY_FAKEGEM_TASK_DOC="" # doc