summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2008-08-28 21:18:33 +0000
committerOlivier Fisette <ribosome@gentoo.org>2008-08-28 21:18:33 +0000
commit992c5dd27087f34f21476e8dd39b17aec3c27122 (patch)
tree3e39df1ca11008d92db0843af154f83e94c9a7be
parentNew upstream version. (diff)
downloadgentoo-2-992c5dd27087f34f21476e8dd39b17aec3c27122.tar.gz
gentoo-2-992c5dd27087f34f21476e8dd39b17aec3c27122.tar.bz2
gentoo-2-992c5dd27087f34f21476e8dd39b17aec3c27122.zip
New upstream version.
(Portage version: 2.1.4.4)
-rw-r--r--sci-biology/clustalx/ChangeLog7
-rw-r--r--sci-biology/clustalx/clustalx-2.0.9.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/sci-biology/clustalx/ChangeLog b/sci-biology/clustalx/ChangeLog
index 5d91281533d1..a33f32834a6b 100644
--- a/sci-biology/clustalx/ChangeLog
+++ b/sci-biology/clustalx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/clustalx
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/clustalx/ChangeLog,v 1.15 2008/08/27 23:15:53 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/clustalx/ChangeLog,v 1.16 2008/08/28 21:18:33 ribosome Exp $
+
+*clustalx-2.0.9 (28 Aug 2008)
+
+ 28 Aug 2008; Olivier Fisette <ribosome@gentoo.org> +clustalx-2.0.9.ebuild:
+ New upstream version (complete rewrite based on Qt).
27 Aug 2008; Olivier Fisette <ribosome@gentoo.org>
clustalx-1.83-r2.ebuild:
diff --git a/sci-biology/clustalx/clustalx-2.0.9.ebuild b/sci-biology/clustalx/clustalx-2.0.9.ebuild
new file mode 100644
index 000000000000..58decc180e4d
--- /dev/null
+++ b/sci-biology/clustalx/clustalx-2.0.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/clustalx/clustalx-2.0.9.ebuild,v 1.1 2008/08/28 21:18:33 ribosome Exp $
+
+EAPI=1
+
+inherit qt4 eutils
+
+DESCRIPTION="Graphical interface for the ClustalW multiple alignment program"
+HOMEPAGE="http://www.ebi.ac.uk/tools/clustalw2/"
+SRC_URI="ftp://ftp.ebi.ac.uk/pub/software/clustalw2/${PV}/${P}-src.tar.gz"
+
+LICENSE="clustalw"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="x11-libs/qt:4"
+
+RDEPEND="sci-biology/clustalw:2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s|colprot.xml|/usr/share/${PN}/colprot.xml|" \
+ -e "s|coldna.xml|/usr/share/${PN}/coldna.xml|" \
+ -e "s|colprint.xml|/usr/share/${PN}/colprint.xml|" \
+ -i ClustalQtParams.h || \
+ die "Failed to patch shared files location."
+ sed -e "s|clustalx.hlp|/usr/share/${PN}/clustalx.hlp|" \
+ -i HelpDisplayWidget.cpp || \
+ die "Failed to patch help file location."
+}
+
+src_compile() {
+ eqmake4
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ dobin clustalx || die "Failed to install program."
+ insinto "/usr/share/${PN}"
+ doins colprot.xml coldna.xml colprint.xml clustalx.hlp || \
+ die "Failed to install shared files."
+ make_desktop_entry ${PN} ClustalX "" "Application;Science"
+}