summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Kroah-Hartman <gregkh@gentoo.org>2005-11-06 21:47:08 +0000
committerGreg Kroah-Hartman <gregkh@gentoo.org>2005-11-06 21:47:08 +0000
commit984094a3b1c21d5555cc961776fb90c9492b12b8 (patch)
tree6b4796fd99a93456b824a12b04893d19b76134d7
parentAdd missing xrdb runtime dependency (compnerd). (diff)
downloadgentoo-2-984094a3b1c21d5555cc961776fb90c9492b12b8.tar.gz
gentoo-2-984094a3b1c21d5555cc961776fb90c9492b12b8.tar.bz2
gentoo-2-984094a3b1c21d5555cc961776fb90c9492b12b8.zip
072 release
(Portage version: 2.0.53_rc7)
-rw-r--r--sys-fs/udev/ChangeLog8
-rw-r--r--sys-fs/udev/Manifest2
-rw-r--r--sys-fs/udev/files/digest-udev-0721
-rw-r--r--sys-fs/udev/udev-072.ebuild220
4 files changed, 230 insertions, 1 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index 481c3410fe4a..a53bdbeabfc7 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.152 2005/10/25 21:22:01 gregkh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.153 2005/11/06 21:47:07 gregkh Exp $
+
+*udev-072 (06 Nov 2005)
+
+ 06 Nov 2005; Greg Kroah-Hartman <gregkh@gentoo.org> +udev-072.ebuild:
+ 072 release. Careful about running this on kernels older
+ than 2.6.14, I do not know what will happen with that...
25 Oct 2005; Greg Kroah-Hartman <gregkh@gentoo.org> -udev-045.ebuild,
-udev-056.ebuild, -udev-058.ebuild, -udev-068.ebuild:
diff --git a/sys-fs/udev/Manifest b/sys-fs/udev/Manifest
index d2ed4bd91187..49296d2ea732 100644
--- a/sys-fs/udev/Manifest
+++ b/sys-fs/udev/Manifest
@@ -3,6 +3,7 @@ MD5 d03e92ce93131fd7d29fcae1b3f2627b files/digest-udev-068-r1 61
MD5 05abfc4c9a5cad86f814161806c97148 files/digest-udev-069 61
MD5 760a25fb7cc243e76c1889076b6ec829 files/digest-udev-070-r1 61
MD5 b8f96ffaea8ab8ce1de26b1a4649e4c5 files/digest-udev-071 61
+MD5 4e8f7bc5bce2959bd11ae13fdd04a247 files/digest-udev-072 61
MD5 f00e3e0d3382e93cbd0c64fcef99f826 files/udev-021-udev_add_c-gcc295-compat.patch 493
MD5 7b0a35c905183730e4dfdcf29f5a1816 files/udev-050-udev_volume_id.patch 388
MD5 622f085dff7fb6138f3e2c992d569593 files/udev-start.sh 2460
@@ -23,3 +24,4 @@ MD5 0b0240991924922eab433e39cf1ca953 udev-068-r1.ebuild 6698
MD5 0bd16f42f1bd404a650da235c6eda855 udev-069.ebuild 6648
MD5 8873c4eb5a966c5cd4ec554896c3cb33 udev-070-r1.ebuild 6696
MD5 81f1035916968128390fef68bd7ae7a6 udev-071.ebuild 6759
+MD5 5ea3aa4195091e9c8fc46293bccecfdd udev-072.ebuild 6983
diff --git a/sys-fs/udev/files/digest-udev-072 b/sys-fs/udev/files/digest-udev-072
new file mode 100644
index 000000000000..171988864612
--- /dev/null
+++ b/sys-fs/udev/files/digest-udev-072
@@ -0,0 +1 @@
+MD5 cbcc5528fdce7b100bc2f20788c0bf67 udev-072.tar.bz2 434594
diff --git a/sys-fs/udev/udev-072.ebuild b/sys-fs/udev/udev-072.ebuild
new file mode 100644
index 000000000000..ffa7b6df0ef2
--- /dev/null
+++ b/sys-fs/udev/udev-072.ebuild
@@ -0,0 +1,220 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-072.ebuild,v 1.1 2005/11/06 21:47:07 gregkh Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html"
+SRC_URI="mirror://kernel/linux/utils/kernel/hotplug/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static selinux"
+
+DEPEND="sys-apps/hotplug-base"
+RDEPEND="${DEPEND}
+ >=sys-apps/baselayout-1.8.6.12-r3"
+# We need some changes for devfs type layout
+PROVIDE="virtual/dev-manager"
+
+if use static ; then
+ USE_KLIBC=true
+else
+ USE_KLIBC=false
+fi
+export USE_KLIBC
+
+
+pkg_setup() {
+ # Why is check_KV needed here?!
+ [ "${USE_KLIBC}" = "true" ] && check_KV
+
+ return 0
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # patches go here...
+ #epatch ${FILESDIR}/${P}-udev_volume_id.patch
+
+ # No need to clutter the logs ...
+ sed -ie '/^DEBUG/ c\DEBUG = false' Makefile
+ # Do not use optimization flags from the package
+ sed -ie 's|$(OPTIMIZATION)||g' Makefile
+
+ # Make sure there is no sudden changes to udev.rules.gentoo
+ # (more for my own needs than anything else ...)
+ MD5=`md5sum < "${S}/etc/udev/gentoo/udev.rules"`
+ MD5=${MD5/ -/}
+ if [ "${MD5}" != "84fa41fd643ad2afeb922b3048cfd05f" ]
+ then
+ echo
+ eerror "gentoo/udev.rules has been updated, please validate!"
+ die "gentoo/udev.rules has been updated, please validate!"
+ fi
+}
+
+src_compile() {
+ filter-flags -fprefetch-loop-arrays
+ local myconf=
+ local extras="extras/scsi_id extras/volume_id extras/ata_id extras/run_directory extras/usb_id extras/floppy extras/cdrom_id extras/firmware"
+
+ use selinux && myconf="${myconf} USE_SELINUX=true"
+
+ # Not everyone has full $CHOST-{ld,ar,etc...} yet
+ local mycross=""
+ type -p ${CHOST}-ar && mycross=${CHOST}-
+
+ # Do not work with emake
+ make \
+ EXTRAS="${extras}" \
+ udevdir="/dev/" \
+ CROSS=${mycross} \
+ ${myconf} || die
+}
+
+src_install() {
+ # we install everything by "hand" and don't rely on the udev Makefile to do
+ # it for us (why? it's easier that way...)
+ dobin udevinfo
+ dobin udevtest
+ dobin udevmonitor
+ into /
+ dosbin udev
+ dosbin udevd
+ dosbin udevsend
+ dosbin udevstart
+ dosbin udeveventrecorder
+ dosbin udevcontrol
+ dosbin extras/run_directory/udev_run_devd
+ dosbin extras/run_directory/udev_run_hotplugd
+ dosbin extras/ata_id/ata_id
+ dosbin extras/volume_id/vol_id
+ dosbin extras/scsi_id/scsi_id
+ dosbin extras/usb_id/usb_id
+ dosbin extras/cdrom_id/cdrom_id
+ dosbin extras/path_id
+ dosbin extras/floppy/create_floppy_devices
+ dosbin extras/firmware/firmware_helper
+
+ exeinto /etc/udev/scripts
+ doexe extras/ide-devfs.sh
+ doexe extras/scsi-devfs.sh
+ doexe extras/raid-devfs.sh
+ doexe extras/dvb.sh
+
+ # Our udev config file
+ insinto /etc/udev
+ newins ${FILESDIR}/udev.conf.post_059 udev.conf
+
+ # Our rules files
+ insinto /etc/udev/rules.d/
+ newins etc/udev/gentoo/udev.rules 50-udev.rules
+
+ # scsi_id configuration
+ insinto /etc
+ doins extras/scsi_id/scsi_id.config
+
+ # set up symlinks in /etc/hotplug.d/default
+ dodir /etc/hotplug.d/default
+ dosym ../../../sbin/udevsend /etc/hotplug.d/default/10-udev.hotplug
+
+ # set up the /etc/dev.d directory tree
+ dodir /etc/dev.d/default
+ dodir /etc/dev.d/net
+ exeinto /etc/dev.d/net
+ doexe extras/run_directory/dev.d/net/hotplug.dev
+
+ # all of the man pages
+ doman *.8
+ doman extras/ata_id/ata_id.8
+ doman extras/edd_id/edd_id.8
+ doman extras/scsi_id/scsi_id.8
+ doman extras/volume_id/vol_id.8
+ doman extras/dasd_id/dasd_id.8
+ doman extras/cdrom_id/cdrom_id.8
+
+ # our udev hooks into the rc system
+ insinto /lib/rcscripts/addons
+ doins "${FILESDIR}"/udev-{start,stop}.sh
+
+ dodoc COPYING ChangeLog FAQ HOWTO-udev_for_dev README TODO RELEASE-NOTES
+ dodoc docs/{overview,udev_vs_devfs}
+ dodoc docs/writing_udev_rules/*
+
+ newdoc extras/volume_id/README README_volume_id
+}
+
+pkg_preinst() {
+ if [ -f "${ROOT}/etc/udev/udev.config" -a \
+ ! -f "${ROOT}/etc/udev/udev.rules" ]
+ then
+ mv -f ${ROOT}/etc/udev/udev.config ${ROOT}/etc/udev/udev.rules
+ fi
+
+ # delete the old udev.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/udev.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/udev.hotplug
+ fi
+
+ # delete the old wait_for_sysfs.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/05-wait_for_sysfs.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/05-wait_for_sysfs.hotplug
+ fi
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" -a -n "`pidof udevd`" ]
+ then
+ killall -15 udevd &>/dev/null
+ sleep 1
+ killall -9 udevd &>/dev/null
+ fi
+
+ # people want reminders, I'll give them reminders. Odds are they will
+ # just ignore them anyway...
+ ewarn "Note: If you are upgrading from a version of udev prior to 046"
+ ewarn " and you rely on the output of udevinfo for anything, please"
+ ewarn " either run 'udevstart' now, or reboot, in order to get a"
+ ewarn " up-to-date udev database."
+ ewarn
+ ewarn "Note: If you are upgrading from a version of udev prior to 050"
+ ewarn " and you had written some custom permissions rules, please"
+ ewarn " realize that the permission rules are now part of the main"
+ ewarn " udev rules files and are not stand-alone anymore. This means"
+ ewarn " you need to rewrite them."
+ ewarn
+ ewarn "Note: If you are upgrading from a version of udev prior to 057"
+ ewarn " and you have written custom rules, and rely on the etc/dev.d/"
+ ewarn " functionality, please read the RELEASE-NOTES file for details"
+ ewarn " on what has changed with this feature, and how to change your"
+ ewarn " rules to work properly."
+ ewarn
+ ewarn "Note: If you are upgrading from a version of udev prior to 059"
+ ewarn " and you have written custom rules, and rely on the etc/dev.d/"
+ ewarn " functionality, or the etc/hotplug.d functionality, or just"
+ ewarn " want to write some very cool and power udev rules, please "
+ ewarn " read the RELEASE-NOTES file for details on what has changed"
+ ewarn " with this feature, and how to change your rules to work properly."
+ ewarn
+ ewarn "Note: If you are upgrading from a version of udev prior to 063"
+ ewarn " and you use the devfs-style names for your block devices"
+ ewarn " or use devfs-style names in /etc/inittab or /etc/securetty or"
+ ewarn " your GRUB or LILO kernel boot command line, you need to"
+ ewarn " change them back to LSB compliant names, as the devfs names are"
+ ewarn " now gone. If you wish to use some persistent names for your"
+ ewarn " block devices, look at the symlinks in /dev/disk/ for the names"
+ ewarn " you can use."
+
+ einfo
+ einfo "For more information on udev on Gentoo, writing udev rules, and"
+ einfo " fixing known issues visit:"
+ einfo " http://www.gentoo.org/doc/en/udev-guide.xml"
+}