summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2007-07-10 03:35:55 +0000
committerSteve Arnold <nerdboy@gentoo.org>2007-07-10 03:35:55 +0000
commit90a7a0bcf90f7a84c42fd74e69482c068f9f9df0 (patch)
tree91a5bd471a0414edd2583e2f49ffde530ddfdad8
parentVersion bump (diff)
downloadgentoo-2-90a7a0bcf90f7a84c42fd74e69482c068f9f9df0.tar.gz
gentoo-2-90a7a0bcf90f7a84c42fd74e69482c068f9f9df0.tar.bz2
gentoo-2-90a7a0bcf90f7a84c42fd74e69482c068f9f9df0.zip
updated desktop category and added desktop_database_update to pkg_post
(Portage version: 2.1.3_rc6)
-rw-r--r--sci-mathematics/wxmaxima/ChangeLog7
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-0.7.1.ebuild18
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild18
3 files changed, 32 insertions, 11 deletions
diff --git a/sci-mathematics/wxmaxima/ChangeLog b/sci-mathematics/wxmaxima/ChangeLog
index 0ea867ed40da..ae44c612bb40 100644
--- a/sci-mathematics/wxmaxima/ChangeLog
+++ b/sci-mathematics/wxmaxima/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/wxmaxima
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/ChangeLog,v 1.3 2007/04/18 10:10:55 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/ChangeLog,v 1.4 2007/07/10 03:35:55 nerdboy Exp $
+
+ 10 Jul 2007; Steve Arnold <nerdboy@gentoo.org> wxmaxima-0.7.1.ebuild,
+ wxmaxima-0.7.2.ebuild:
+ Updated desktop category and added desktop_database_update to pkg_post.
+ Seemed like the right thing to do...
*wxmaxima-0.7.2 (18 Apr 2007)
diff --git a/sci-mathematics/wxmaxima/wxmaxima-0.7.1.ebuild b/sci-mathematics/wxmaxima/wxmaxima-0.7.1.ebuild
index f209d0f18c2e..f80ab67e167f 100644
--- a/sci-mathematics/wxmaxima/wxmaxima-0.7.1.ebuild
+++ b/sci-mathematics/wxmaxima/wxmaxima-0.7.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/wxmaxima-0.7.1.ebuild,v 1.1 2007/02/23 11:33:05 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/wxmaxima-0.7.1.ebuild,v 1.2 2007/07/10 03:35:55 nerdboy Exp $
-inherit eutils autotools wxwidgets
+inherit eutils autotools wxwidgets fdo-mime
MYP=wxMaxima-${PV}
@@ -50,11 +50,19 @@ src_compile () {
src_install () {
emake DESTDIR="${D}" install || die "emake install failed"
- insinto /usr/share/pixmaps/
- newins maxima-new.png wxmaxima.png
- make_desktop_entry wxmaxima wxMaxima wxmaxima
+ newicon maxima-new.png wxmaxima.png
+ make_desktop_entry wxmaxima "wxMaxima ${PV}" wxmaxima \
+ "Science;Math;Education"
dosym ${PORTDIR}/licenses/${LICENSE} /usr/share/${PN}/COPYING
dodir /usr/share/doc/${PF}
dosym /usr/share/${PN}/README /usr/share/doc/${PF}/README
}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild b/sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild
index 1fc0083f0e47..4e8fd214f228 100644
--- a/sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild
+++ b/sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild,v 1.1 2007/04/18 10:10:55 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/wxmaxima-0.7.2.ebuild,v 1.2 2007/07/10 03:35:55 nerdboy Exp $
-inherit eutils autotools wxwidgets
+inherit eutils autotools wxwidgets fdo-mime
MYP=wxMaxima-${PV}
@@ -50,11 +50,19 @@ src_compile () {
src_install () {
emake DESTDIR="${D}" install || die "emake install failed"
- insinto /usr/share/pixmaps/
- newins maxima-new.png wxmaxima.png
- make_desktop_entry wxmaxima wxMaxima wxmaxima
+ newicon maxima-new.png wxmaxima.png
+ make_desktop_entry wxmaxima "wxMaxima ${PV}" wxmaxima \
+ "Science;Math;Education"
dosym ${PORTDIR}/licenses/${LICENSE} /usr/share/${PN}/COPYING
dodir /usr/share/doc/${PF}
dosym /usr/share/${PN}/README /usr/share/doc/${PF}/README
}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}