summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2009-06-10 07:22:19 +0000
committerRémi Cardona <remi@gentoo.org>2009-06-10 07:22:19 +0000
commit81e42700e1f1721df4cd85ac9dcf64fbf4de8443 (patch)
tree5e1b33acfaad6bfd6ed088da0f77e99155a1c3c2
parentstable x86, bug 265587 (diff)
downloadgentoo-2-81e42700e1f1721df4cd85ac9dcf64fbf4de8443.tar.gz
gentoo-2-81e42700e1f1721df4cd85ac9dcf64fbf4de8443.tar.bz2
gentoo-2-81e42700e1f1721df4cd85ac9dcf64fbf4de8443.zip
x11-libs/vte: bump to 0.20.5, drop preserve_old_lib hacks
(Portage version: 2.2_rc33/cvs/Linux x86_64)
-rw-r--r--x11-libs/vte/ChangeLog7
-rw-r--r--x11-libs/vte/vte-0.20.5.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index dfcbbc8a32c3..54d8ef6a432d 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/vte
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.228 2009/06/03 22:33:22 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.229 2009/06/10 07:22:19 remi Exp $
+
+*vte-0.20.5 (10 Jun 2009)
+
+ 10 Jun 2009; Rémi Cardona <remi@gentoo.org> +vte-0.20.5.ebuild:
+ bump to 0.20.5, drop preserve_old_lib hacks
*vte-0.20.4 (03 Jun 2009)
diff --git a/x11-libs/vte/vte-0.20.5.ebuild b/x11-libs/vte/vte-0.20.5.ebuild
new file mode 100644
index 000000000000..36aa5410773e
--- /dev/null
+++ b/x11-libs/vte/vte-0.20.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.20.5.ebuild,v 1.1 2009/06/10 07:22:19 remi Exp $
+
+EAPI="2"
+
+inherit gnome2 eutils
+
+DESCRIPTION="Gnome terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc glade python"
+
+RDEPEND=">=dev-libs/glib-2.18.0
+ >=x11-libs/gtk+-2.14.0
+ >=x11-libs/pango-1.22.0
+ sys-libs/ncurses
+ glade? ( dev-util/glade:3 )
+ python? ( >=dev-python/pygtk-2.4 )
+ x11-libs/libX11
+ x11-libs/libXft"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-deprecation
+ --disable-static
+ $(use_enable debug)
+ $(use_enable glade glade-catalogue)
+ $(use_enable python)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die "sed failed"
+}