summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-21 22:21:04 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-21 22:21:04 +0000
commit81864c40004d472a3c86814d1cb05578daead042 (patch)
treee61db8c3f3d7152e38fe3beb9df7d5524a75f9e5
parentinitial commit; #45058 (Manifest recommit) (diff)
downloadgentoo-2-81864c40004d472a3c86814d1cb05578daead042.tar.gz
gentoo-2-81864c40004d472a3c86814d1cb05578daead042.tar.bz2
gentoo-2-81864c40004d472a3c86814d1cb05578daead042.zip
sync ebuild with xmame
-rw-r--r--games-emulation/xmess/ChangeLog6
-rw-r--r--games-emulation/xmess/files/0.81.1-glx-fix.patch11
-rw-r--r--games-emulation/xmess/xmess-0.81.1.ebuild5
3 files changed, 19 insertions, 3 deletions
diff --git a/games-emulation/xmess/ChangeLog b/games-emulation/xmess/ChangeLog
index f95b9c5e40e5..5b333d1569ca 100644
--- a/games-emulation/xmess/ChangeLog
+++ b/games-emulation/xmess/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/xmess
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/ChangeLog,v 1.12 2004/04/19 10:30:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/ChangeLog,v 1.13 2004/04/21 22:21:04 mr_bones_ Exp $
+
+ 21 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> xmess-0.81.1.ebuild,
+ files/0.81.1-glx-fix.patch:
+ sync ebuild with xmame
*xmess-0.81.1 (19 Apr 2004)
diff --git a/games-emulation/xmess/files/0.81.1-glx-fix.patch b/games-emulation/xmess/files/0.81.1-glx-fix.patch
new file mode 100644
index 000000000000..cbcb32d8a7dc
--- /dev/null
+++ b/games-emulation/xmess/files/0.81.1-glx-fix.patch
@@ -0,0 +1,11 @@
+--- src/unix/osd_cpu.h.orig 2004-04-20 14:30:49.000000000 -0700
++++ src/unix/osd_cpu.h 2004-04-20 14:31:48.000000000 -0700
+@@ -38,7 +38,7 @@
+ #endif
+ #endif
+
+-#ifndef __ARCH_solaris
++#if !defined __ARCH_solaris && !defined xgl
+ /* grrr work around some stupid header conflicts */
+ #if !defined __XF86_DGA_C && !defined __XOPENGL_C_ && !defined LONG64
+ typedef signed char INT8;
diff --git a/games-emulation/xmess/xmess-0.81.1.ebuild b/games-emulation/xmess/xmess-0.81.1.ebuild
index cc8146c2f82e..5036a8e5dc4b 100644
--- a/games-emulation/xmess/xmess-0.81.1.ebuild
+++ b/games-emulation/xmess/xmess-0.81.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.81.1.ebuild,v 1.1 2004/04/19 10:30:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.81.1.ebuild,v 1.2 2004/04/21 22:21:04 mr_bones_ Exp $
-inherit games flag-o-matic gcc eutils
+inherit flag-o-matic gcc eutils games
TARGET="${PN}"
@@ -36,6 +36,7 @@ S="${WORKDIR}/xmame-${PV}"
src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/${PV}-glx-fix.patch
sed -i \
-e 's:JOY_BUTTONS 16:JOY_BUTTONS 32:' src/unix/devices.h \
|| die "setting joybuttons failed" #36818