summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-12-27 11:05:47 +0000
committerPacho Ramos <pacho@gentoo.org>2013-12-27 11:05:47 +0000
commit808dd7ceb2710a4e9b304eb1caa3d65ffc219632 (patch)
tree9bf2f87e9f839caf28cf50cbc960a9e15d8e03aa
parentDrop s390/sh/m68k to unstable (diff)
downloadgentoo-2-808dd7ceb2710a4e9b304eb1caa3d65ffc219632.tar.gz
gentoo-2-808dd7ceb2710a4e9b304eb1caa3d65ffc219632.tar.bz2
gentoo-2-808dd7ceb2710a4e9b304eb1caa3d65ffc219632.zip
Fix menu borders when not running with a composited WM (# by ac.serbanescu)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
-rw-r--r--x11-themes/gnome-themes-standard/ChangeLog9
-rw-r--r--x11-themes/gnome-themes-standard/files/gnome-themes-standard-3.8.4-menu-borders.patch24
-rw-r--r--x11-themes/gnome-themes-standard/gnome-themes-standard-3.8.4-r1.ebuild67
3 files changed, 99 insertions, 1 deletions
diff --git a/x11-themes/gnome-themes-standard/ChangeLog b/x11-themes/gnome-themes-standard/ChangeLog
index dd38641a4ba0..a90cc151b056 100644
--- a/x11-themes/gnome-themes-standard/ChangeLog
+++ b/x11-themes/gnome-themes-standard/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-themes/gnome-themes-standard
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/ChangeLog,v 1.49 2013/12/24 17:48:11 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/ChangeLog,v 1.50 2013/12/27 11:05:47 pacho Exp $
+
+*gnome-themes-standard-3.8.4-r1 (27 Dec 2013)
+
+ 27 Dec 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/gnome-themes-standard-3.8.4-menu-borders.patch,
+ +gnome-themes-standard-3.8.4-r1.ebuild:
+ Fix menu borders when not running with a composited WM (# by ac.serbanescu)
*gnome-themes-standard-3.10.0 (24 Dec 2013)
diff --git a/x11-themes/gnome-themes-standard/files/gnome-themes-standard-3.8.4-menu-borders.patch b/x11-themes/gnome-themes-standard/files/gnome-themes-standard-3.8.4-menu-borders.patch
new file mode 100644
index 000000000000..c2c6b04248de
--- /dev/null
+++ b/x11-themes/gnome-themes-standard/files/gnome-themes-standard-3.8.4-menu-borders.patch
@@ -0,0 +1,24 @@
+From d10116eb77b09d8372a82de2e25894371805726c Mon Sep 17 00:00:00 2001
+From: Cosimo Cecchi <cosimoc@gnome.org>
+Date: Fri, 06 Sep 2013 02:13:28 +0000
+Subject: gtk3: fix menu borders when not running under gnome-shell
+
+We can just use a transparent background for the insensitive items.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=707358
+---
+diff --git a/themes/Adwaita/gtk-3.0/gtk-widgets.css b/themes/Adwaita/gtk-3.0/gtk-widgets.css
+index c013581..eb80e37 100644
+--- a/themes/Adwaita/gtk-3.0/gtk-widgets.css
++++ b/themes/Adwaita/gtk-3.0/gtk-widgets.css
+@@ -2364,7 +2364,7 @@ GtkTreeMenu .menuitem,
+ }
+
+ .menu .menuitem:insensitive {
+- background-color: @menu_bg_color;
++ background-color: transparent;
+ }
+
+ .menu .menuitem:active,
+--
+cgit v0.9.2
diff --git a/x11-themes/gnome-themes-standard/gnome-themes-standard-3.8.4-r1.ebuild b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.8.4-r1.ebuild
new file mode 100644
index 000000000000..d522d1485928
--- /dev/null
+++ b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.8.4-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/gnome-themes-standard-3.8.4-r1.ebuild,v 1.1 2013/12/27 11:05:47 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="Standard Themes for GNOME Applications"
+HOMEPAGE="https://git.gnome.org/browse/gnome-themes-standard/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+gtk"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+COMMON_DEPEND="
+ gnome-base/librsvg:2
+ x11-libs/cairo
+ >=x11-themes/gtk-engines-2.15.3:2
+ gtk? (
+ >=x11-libs/gtk+-2.24.15:2
+ >=x11-libs/gtk+-3.6.2:3 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# gnome-themes{,-extras} are OBSOLETE for GNOME 3
+# http://comments.gmane.org/gmane.comp.gnome.desktop/44130
+# Depend on gsettings-desktop-schemas-3.4 to make sure 3.2 users don't lose
+# their default background image
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/gsettings-desktop-schemas-3.4
+ !<x11-themes/gnome-themes-2.32.1-r1
+"
+
+src_prepare() {
+ # Install cursors in the right place
+ sed -e 's:^\(cursordir.*\)icons\(.*\):\1cursors/xorg-x11\2:' \
+ -i themes/Adwaita/cursors/Makefile.am \
+ -i themes/Adwaita/cursors/Makefile.in || die
+
+ # fix menu borders when not running under gnome-shell (from 3.10)
+ epatch "${FILESDIR}/${P}-menu-borders.patch"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # The icon cache needs to be generated in pkg_postinst()
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable gtk gtk2-engine) \
+ $(use_enable gtk gtk3-engine) \
+ GTK_UPDATE_ICON_CACHE=$(type -P true)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Make it the default cursor theme
+ dosym Adwaita /usr/share/cursors/xorg-x11/default
+}