summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-10-24 19:40:39 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-10-24 19:40:39 +0000
commit7b3b695ca11d9157d53957a357b251af869881c9 (patch)
tree6acab5556c35b1211bde522fd176b6e8d21f7d27
parentUpdate dependency after package move from x11-libs/openmotif to x11-libs/motif. (diff)
downloadgentoo-2-7b3b695ca11d9157d53957a357b251af869881c9.tar.gz
gentoo-2-7b3b695ca11d9157d53957a357b251af869881c9.tar.bz2
gentoo-2-7b3b695ca11d9157d53957a357b251af869881c9.zip
add upstream fix to build on FreeBSD. Bug #438942 by Yuta SATOH
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
-rw-r--r--net-misc/dhcpcd/ChangeLog6
-rw-r--r--net-misc/dhcpcd/dhcpcd-5.6.2.ebuild3
-rw-r--r--net-misc/dhcpcd/files/dhcpcd-5.6.2-if-bsd.patch30
3 files changed, 37 insertions, 2 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index f4dd4c4a6f13..1b384753372c 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.334 2012/09/26 15:05:35 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.335 2012/10/24 19:40:39 aballier Exp $
+
+ 24 Oct 2012; Alexis Ballier <aballier@gentoo.org> dhcpcd-5.6.2.ebuild,
+ +files/dhcpcd-5.6.2-if-bsd.patch:
+ add upstream fix to build on FreeBSD. Bug #438942 by Yuta SATOH
*dhcpcd-5.6.2 (26 Sep 2012)
diff --git a/net-misc/dhcpcd/dhcpcd-5.6.2.ebuild b/net-misc/dhcpcd/dhcpcd-5.6.2.ebuild
index fd18e969c220..fa0857d8ee22 100644
--- a/net-misc/dhcpcd/dhcpcd-5.6.2.ebuild
+++ b/net-misc/dhcpcd/dhcpcd-5.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-5.6.2.ebuild,v 1.1 2012/09/26 15:05:35 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-5.6.2.ebuild,v 1.2 2012/10/24 19:40:39 aballier Exp $
EAPI=4
@@ -33,6 +33,7 @@ src_prepare() {
echo "noipv4ll"
} >> dhcpcd.conf
fi
+ epatch "${FILESDIR}/${P}-if-bsd.patch" #438942
}
src_configure() {
diff --git a/net-misc/dhcpcd/files/dhcpcd-5.6.2-if-bsd.patch b/net-misc/dhcpcd/files/dhcpcd-5.6.2-if-bsd.patch
new file mode 100644
index 000000000000..c24a2fa3d894
--- /dev/null
+++ b/net-misc/dhcpcd/files/dhcpcd-5.6.2-if-bsd.patch
@@ -0,0 +1,30 @@
+Fixes building on FreeBSD.
+https://bugs.gentoo.org/show_bug.cgi?id=438942
+
+From upstream:
+http://roy.marples.name/projects/dhcpcd/changeset/4d6bbabd08d1a1696f5db67af60c9883c4c367f4
+
+git-committer: Roy Marples <roy@marples.name> (10/24/12 13:59:20)
+Message: Fix compile fr systems without RTF_CLONING such as FreeBSD-8
+
+
+Index: if-bsd.c
+===================================================================
+--- if-bsd.c (revision 84ad87e1287453ca05a7cbd5775322374e07a7ee)
++++ if-bsd.c (revision 4d6bbabd08d1a1696f5db67af60c9883c4c367f4)
+@@ -363,6 +363,8 @@
+ IN6_IS_ADDR_UNSPECIFIED(&rt->net))
+ rtm.hdr.rtm_flags |= RTF_GATEWAY;
++#ifdef RTF_CLONING
+ else
+ rtm.hdr.rtm_flags |= RTF_CLONING;
++#endif
+
+ rtm.hdr.rtm_addrs = RTA_DST | RTA_GATEWAY | RTA_NETMASK;
+@@ -371,5 +373,5 @@
+
+ ADDADDR(&rt->dest);
+- if (rtm.hdr.rtm_flags & (RTF_HOST | RTF_CLONING)) {
++ if (!(rtm.hdr.rtm_flags & RTF_GATEWAY)) {
+ /* Make us a link layer socket for the host gateway */
+ memset(&su, 0, sizeof(su));