summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Johnson <livewire@gentoo.org>2003-02-13 17:57:08 +0000
committerBob Johnson <livewire@gentoo.org>2003-02-13 17:57:08 +0000
commit7a867009d1bc056ebb51f82446eb0c27e1cabcf7 (patch)
tree841a4b593a88b5793f9441a5c6069970905ab586
parentUpdate Copyright years (diff)
downloadgentoo-2-7a867009d1bc056ebb51f82446eb0c27e1cabcf7.tar.gz
gentoo-2-7a867009d1bc056ebb51f82446eb0c27e1cabcf7.tar.bz2
gentoo-2-7a867009d1bc056ebb51f82446eb0c27e1cabcf7.zip
added -pre10 ebuild
-rw-r--r--sys-kernel/wolk-sources/ChangeLog45
-rw-r--r--sys-kernel/wolk-sources/files/digest-wolk-sources-4.0_pre102
-rw-r--r--sys-kernel/wolk-sources/wolk-sources-4.0_pre10.ebuild49
3 files changed, 95 insertions, 1 deletions
diff --git a/sys-kernel/wolk-sources/ChangeLog b/sys-kernel/wolk-sources/ChangeLog
index f8aad54c0056..1d80bc1f8063 100644
--- a/sys-kernel/wolk-sources/ChangeLog
+++ b/sys-kernel/wolk-sources/ChangeLog
@@ -1,6 +1,49 @@
# ChangeLog for sys-kernel/wolk-sources
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/wolk-sources/ChangeLog,v 1.6 2003/02/12 09:18:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/wolk-sources/ChangeLog,v 1.7 2003/02/13 17:57:08 livewire Exp $
+
+*wolk-sources-4.0s-pre10
+
+ 13 Feb 2003; Bob Johnson <livewire@gentoo.org>:
+
+ Changelog from v4.0s-pre9 -> 4.0s-pre10
+ - add: TCP/IP Low Latency via sysctl
+ - add: sys_sendfile64
+ - add: ./userspace-patches: linux-dvb-2002-12-08 for rmap15b
+ - add: LSI MegaRAID support (driver series v2.00.2)
+ - add: check for swapon on mounted devices
+ - add: Opteron/Athlon64/Hammer/K8 support
+ - re-add: vservers (ctx) v16 (non-breaking gradm version)
+ - fixed: IPMI build error due to new ACPI merge in -pre9
+ - fixed: add missing bits from -ac ethernet packet padding fix
+ fixes 'skb_pad' unresolved symbols in many NIC drivers
+ - fixed: some compiler warnings
+ - fixed: trivial NTFS build error
+ - fixed: Unknown interrupt on some systems
+ - fixed: Failover routing
+ - fixed: PPC32 build errors
+ - fixed: AMD K6 wrongly sets PGE=y - results in a nonbootable kernel
+ - fixed: aic7xxx with firmware build enabled compile error
+ - fixed: make xconfig looks strange in the first menu
+ - fixed: SMP deadlock on some $MONSTERBOXEN
+ - fixed: nfs: mishandling of nfsroot port= option
+ - fixed: nfs: fixed SMP deadlock
+ - fixed: ext3fs: crash deleting a single non sparse file exceeding 1 Tb
+ - fixed: Disable Loop IV hack of CryptoAPI because we have loop-jari
+ - update: Matrox mga_vid / Radeon/Rage128 Driver
+ - update: ReiserFS data-logging v35-aa
+ - update: rmap VM v15d
+ - update: XFS v1.2-cvs as of 2003-02-09 including kdb v3.0
+ - update: Super FreeS/WAN v1.99-kb4 Final
+ - update: LSI MegaRAID support (driver series v1.18f)
+ - update: Broadcom Tigon3 v1.4
+ - update: grsecurity v1.99c Final
+ - removed: kernel ksymoops: now also part of kdb v3.0
+ - changed: Desktop Scheduler Tweaks: More interactivity
+ - changed: Disable EARLY_PRINTK config option and make it always-on.
+ Or: I don't like to receive emails anymore saying:
+ "My screen is black" ;)
+ - changed: braindead "Conntrack CLOSE_WAIT" from 3days to 2mins
*wolk-sources-4.0s-pre9
diff --git a/sys-kernel/wolk-sources/files/digest-wolk-sources-4.0_pre10 b/sys-kernel/wolk-sources/files/digest-wolk-sources-4.0_pre10
new file mode 100644
index 000000000000..6d3c4d3ec8ce
--- /dev/null
+++ b/sys-kernel/wolk-sources/files/digest-wolk-sources-4.0_pre10
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 8370244741119ebd9f00eb3131b7f8dd linux-2.4.20-wolk4.0s-pre10.patch.bz2 8552524
diff --git a/sys-kernel/wolk-sources/wolk-sources-4.0_pre10.ebuild b/sys-kernel/wolk-sources/wolk-sources-4.0_pre10.ebuild
new file mode 100644
index 000000000000..df83ac8a1a84
--- /dev/null
+++ b/sys-kernel/wolk-sources/wolk-sources-4.0_pre10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/wolk-sources/wolk-sources-4.0_pre10.ebuild,v 1.1 2003/02/13 17:57:08 livewire Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+ETYPE="sources"
+
+inherit kernel || die
+
+OKV=2.4.20
+EXTRAVERSION=-wolk4.0s-pre10
+KV=${OKV}${EXTRAVERSION}
+S=${WORKDIR}/linux-${KV}
+DESCRIPTION="Working Overloaded Linux Kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://sourceforge/wolk/linux-${KV}.patch.bz2"
+KEYWORDS="~x86"
+SLOT="${KV}"
+HOMEPAGE="http://wolk.sourceforge.net http://www.kernel.org"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${WORKDIR}/linux-${KV}
+ bzcat ${DISTDIR}/linux-${OKV}${EXTRAVERSION}.patch.bz2 | patch -p1
+}
+src_install() {
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ dodoc ${FILESDIR}/patches.txt
+ mv ${WORKDIR}/linux* ${D}/usr/src
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "If you use Nvidia modules, you will need to use the supplied"
+ einfo "rmap patch in /usr/src/linux-2.4.2-wolk4.0s-pre10/userspace-patches"
+ einfo "against your nvidia kernel driver source"
+ einfo "cd NVIDIA_kernel-1.0-XXXX "
+ einfo "patch -p1 </usr/src/linux-2.4.2-wolk4.0s-pre10/userspace-patches/"
+ einfo "NVIDIA_kernel-1.0-4191-2.4-rmap15b.patch"
+ einfo "This patch works fine with NVIDIA_kernel-1.0-3123 also"
+ einfo
+}
+