summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-11-02 00:21:04 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-11-02 00:21:04 +0000
commit77af4e8d9ed974203e8aef584b4dcef82f492e15 (patch)
tree2b011793faa727c010ea130f30d90d012f898769
parentMove from java-pkg to java-pkg-2. Dropped old ebuild. (diff)
downloadgentoo-2-77af4e8d9ed974203e8aef584b4dcef82f492e15.tar.gz
gentoo-2-77af4e8d9ed974203e8aef584b4dcef82f492e15.tar.bz2
gentoo-2-77af4e8d9ed974203e8aef584b4dcef82f492e15.zip
Use autotools eclass
(Portage version: 2.1.2_rc1-r2)
-rw-r--r--games-emulation/gsnes9x/ChangeLog5
-rw-r--r--games-emulation/gsnes9x/gsnes9x-3.12.ebuild28
2 files changed, 19 insertions, 14 deletions
diff --git a/games-emulation/gsnes9x/ChangeLog b/games-emulation/gsnes9x/ChangeLog
index 40a0a183c5a2..6e392ba1cf6d 100644
--- a/games-emulation/gsnes9x/ChangeLog
+++ b/games-emulation/gsnes9x/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/gsnes9x
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gsnes9x/ChangeLog,v 1.2 2006/02/28 21:01:35 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gsnes9x/ChangeLog,v 1.3 2006/11/02 00:21:04 nyhm Exp $
+
+ 02 Nov 2006; Tristan Heaven <nyhm@gentoo.org> gsnes9x-3.12.ebuild:
+ Use autotools eclass
28 Feb 2006; <Tupone@gentoo.org> +files/gsnes9x-3.12-sandbox.patch,
gsnes9x-3.12.ebuild:
diff --git a/games-emulation/gsnes9x/gsnes9x-3.12.ebuild b/games-emulation/gsnes9x/gsnes9x-3.12.ebuild
index 8ad1e73a0407..1877fc3f669b 100644
--- a/games-emulation/gsnes9x/gsnes9x-3.12.ebuild
+++ b/games-emulation/gsnes9x/gsnes9x-3.12.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gsnes9x/gsnes9x-3.12.ebuild,v 1.2 2006/02/28 21:01:35 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gsnes9x/gsnes9x-3.12.ebuild,v 1.3 2006/11/02 00:21:04 nyhm Exp $
-inherit eutils
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=1.9
+inherit autotools eutils
DESCRIPTION="GNOME front-end for the Snes9X SNES emulator"
HOMEPAGE="http://sourceforge.net/projects/gsnes9x/"
@@ -11,11 +13,14 @@ SRC_URI="mirror://sourceforge/gsnes9x/GSnes9x-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="nls esd debug"
+IUSE="debug esd nls"
-DEPEND="=gnome-base/gnome-libs-1*
+RDEPEND="=gnome-base/gnome-libs-1*
=gnome-base/orbit-0*
- esd? ( media-sound/esound )"
+ esd? ( media-sound/esound )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
S=${WORKDIR}/GSnes9x-${PV}
@@ -23,24 +28,21 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${P}-sandbox.patch"
- autoheader && \
- aclocal -I macros && \
- automake --gnu --include-deps Makefile -c -a && \
- autoconf || die
+ AT_M4DIR=macros eautoreconf
}
src_compile() {
econf \
$(use_with esd) \
- $(use_with debug) \
+ $(use_enable debug) \
$(use_enable nls) \
|| die
- emake || die
+ emake || die "emake failed"
}
src_install() {
- make install DESTDIR="${D}" || die
- rm -r "${D}"/usr/share/gnome/apps
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -rf "${D}"/usr/share/gnome/apps
make_desktop_entry GSnes9x GSnes9x gsnes9x-icon.png
dodoc AUTHORS ChangeLog NEWS README
}