summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-04-25 15:18:47 +0000
committerMike Frysinger <vapier@gentoo.org>2003-04-25 15:18:47 +0000
commit70d006b67b7dbe4a514fbdfa7ac0307e2c1e720c (patch)
tree987191584ee2ec0d895423f4144572e2cb3cbd11
parentVersion bump, latest nano (diff)
downloadgentoo-2-70d006b67b7dbe4a514fbdfa7ac0307e2c1e720c.tar.gz
gentoo-2-70d006b67b7dbe4a514fbdfa7ac0307e2c1e720c.tar.bz2
gentoo-2-70d006b67b7dbe4a514fbdfa7ac0307e2c1e720c.zip
touchups
-rw-r--r--dev-db/xindice/xindice-1.0.ebuild12
-rw-r--r--dev-libs/dvthread/dvthread-0.4.4.ebuild19
-rw-r--r--dev-libs/expat/expat-1.95.4.ebuild11
-rw-r--r--dev-libs/expat/expat-1.95.5-r1.ebuild14
-rw-r--r--dev-libs/expat/expat-1.95.6-r1.ebuild18
-rw-r--r--dev-libs/expat/expat-1.95.6.ebuild14
6 files changed, 42 insertions, 46 deletions
diff --git a/dev-db/xindice/xindice-1.0.ebuild b/dev-db/xindice/xindice-1.0.ebuild
index 488672941fe3..42219d35d52c 100644
--- a/dev-db/xindice/xindice-1.0.ebuild
+++ b/dev-db/xindice/xindice-1.0.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/xindice/xindice-1.0.ebuild,v 1.1 2003/04/11 20:10:21 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/xindice/xindice-1.0.ebuild,v 1.2 2003/04/25 15:15:04 vapier Exp $
+
+inherit eutils
DESCRIPTION="A native java XML database"
HOMEPAGE="http://xml.apache.org/xindice"
SRC_URI="http://xml.apache.org/xindice/dist/xml-xindice-${PV}.tar.gz"
-LICENSE="Apache-1.1"
+LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~x86"
IUSE="doc"
-DEPEND=">=sun-jdk-1.3"
-
-S="${WORKDIR}/xml-${P}"
+DEPEND=">=dev-java/sun-jdk-1.3"
-inherit eutils
+S=${WORKDIR}/xml-${P}
pkg_preinst() {
enewgroup xindice || die "Adding group xindice failed"
diff --git a/dev-libs/dvthread/dvthread-0.4.4.ebuild b/dev-libs/dvthread/dvthread-0.4.4.ebuild
index e8863169a4b0..b79ac82bc911 100644
--- a/dev-libs/dvthread/dvthread-0.4.4.ebuild
+++ b/dev-libs/dvthread/dvthread-0.4.4.ebuild
@@ -1,27 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvthread/dvthread-0.4.4.ebuild,v 1.3 2003/03/13 23:18:51 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvthread/dvthread-0.4.4.ebuild,v 1.4 2003/04/25 15:16:44 vapier Exp $
-A=dvthread-${PV}.tar.gz
-S=${WORKDIR}/dvthread-${PV}
-DESCRIPTION="dvthread provides classes for threads and monitors, wrapped around the posix thread library"
-SRC_URI="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvthread/download/${A}"
+inherit eutils
+
+DESCRIPTION="classes for threads and monitors, wrapped around the posix thread library"
+SRC_URI="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvthread/download/${P}.tar.gz"
HOMEPAGE="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvthread/html/"
+
KEYWORDS="x86 ppc"
LICENSE="GPL-2"
SLOT="0"
-inherit eutils
-
-IUSE=""
DEPEND="virtual/glibc"
-RDEPEND=${DEPEND}
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/gentoo-0.4.4.patch
+ epatch ${FILESDIR}/gentoo-${PV}.patch
}
src_install() {
- make prefix=${D}/usr install
+ make prefix=${D}/usr install || die
}
diff --git a/dev-libs/expat/expat-1.95.4.ebuild b/dev-libs/expat/expat-1.95.4.ebuild
index ad434210fcf0..fba09a58361d 100644
--- a/dev-libs/expat/expat-1.95.4.ebuild
+++ b/dev-libs/expat/expat-1.95.4.ebuild
@@ -1,20 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.4.ebuild,v 1.13 2003/02/13 10:37:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.4.ebuild,v 1.14 2003/04/25 15:18:47 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="XML parsing libraries"
SRC_URI="mirror://sourceforge/expat/${P}.tar.gz"
-HOMEPAGE="http://expat.sourceforge.net"
-
-DEPEND="virtual/glibc"
+HOMEPAGE="http://expat.sourceforge.net/"
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 ppc sparc alpha mips hppa"
+DEPEND="virtual/glibc"
+
src_compile() {
- ./configure \
+ ./configure \
--prefix=/usr \
--mandir=/usr/share/man/man1 || die "configure failed"
diff --git a/dev-libs/expat/expat-1.95.5-r1.ebuild b/dev-libs/expat/expat-1.95.5-r1.ebuild
index e5a1a3db737e..c320d88c8052 100644
--- a/dev-libs/expat/expat-1.95.5-r1.ebuild
+++ b/dev-libs/expat/expat-1.95.5-r1.ebuild
@@ -1,25 +1,25 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.5-r1.ebuild,v 1.6 2003/02/22 00:35:21 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.5-r1.ebuild,v 1.7 2003/04/25 15:18:47 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="XML parsing libraries"
SRC_URI="mirror://sourceforge/expat/${P}.tar.gz"
-HOMEPAGE="http://expat.sourceforge.net"
-DEPEND="virtual/glibc"
+HOMEPAGE="http://expat.sourceforge.net/"
+
SLOT="0"
LICENSE="as-is"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa arm"
+DEPEND="virtual/glibc"
+
src_compile() {
- econf
+ econf || die
# parallel make doesnt work
make || die
}
src_install() {
- einstall \
- mandir=${D}/usr/share/man/man1
+ einstall mandir=${D}/usr/share/man/man1
dodoc COPYING Changes MANIFEST README
dohtml doc/*
}
diff --git a/dev-libs/expat/expat-1.95.6-r1.ebuild b/dev-libs/expat/expat-1.95.6-r1.ebuild
index b9a8a2f7250a..ff8fdb6e651b 100644
--- a/dev-libs/expat/expat-1.95.6-r1.ebuild
+++ b/dev-libs/expat/expat-1.95.6-r1.ebuild
@@ -1,33 +1,33 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.6-r1.ebuild,v 1.3 2003/04/02 14:00:00 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.6-r1.ebuild,v 1.4 2003/04/25 15:18:47 vapier Exp $
+
+inherit eutils
-S=${WORKDIR}/${P}
DESCRIPTION="XML parsing libraries"
SRC_URI="mirror://sourceforge/expat/${P}.tar.gz"
-HOMEPAGE="http://expat.sourceforge.net"
-DEPEND="virtual/glibc"
+HOMEPAGE="http://expat.sourceforge.net/"
+
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 ~ppc sparc ~alpha ~hppa ~arm"
-inherit eutils
+DEPEND="virtual/glibc"
src_unpack() {
unpack ${A}
cd ${S}/lib
- epatch ${FILESDIR}/xmlstatus.patch || die "patch failed"
+ epatch ${FILESDIR}/xmlstatus.patch
}
src_compile() {
- econf
+ econf || die
# parallel make doesnt work
make || die
}
src_install() {
- einstall \
- mandir=${D}/usr/share/man/man1
+ einstall mandir=${D}/usr/share/man/man1
dodoc COPYING Changes MANIFEST README
dohtml doc/*
}
diff --git a/dev-libs/expat/expat-1.95.6.ebuild b/dev-libs/expat/expat-1.95.6.ebuild
index 1bf9b486697f..93571b1b90ee 100644
--- a/dev-libs/expat/expat-1.95.6.ebuild
+++ b/dev-libs/expat/expat-1.95.6.ebuild
@@ -1,25 +1,25 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.6.ebuild,v 1.1 2003/03/08 23:09:24 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.6.ebuild,v 1.2 2003/04/25 15:18:47 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="XML parsing libraries"
SRC_URI="mirror://sourceforge/expat/${P}.tar.gz"
-HOMEPAGE="http://expat.sourceforge.net"
-DEPEND="virtual/glibc"
+HOMEPAGE="http://expat.sourceforge.net/"
+
SLOT="0"
LICENSE="as-is"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~arm"
+DEPEND="virtual/glibc"
+
src_compile() {
- econf
+ econf || die
# parallel make doesnt work
make || die
}
src_install() {
- einstall \
- mandir=${D}/usr/share/man/man1
+ einstall mandir=${D}/usr/share/man/man1
dodoc COPYING Changes MANIFEST README
dohtml doc/*
}