summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2008-02-29 14:21:52 +0000
committerVlastimil Babka <caster@gentoo.org>2008-02-29 14:21:52 +0000
commit70511333a7988146c608470c9a6ad33943be9f91 (patch)
treeec080e0bf9d8854d1e9e7ed70c2616421fdeeea0
parent Revise the post install notice and put the information into an external file... (diff)
downloadgentoo-2-70511333a7988146c608470c9a6ad33943be9f91.tar.gz
gentoo-2-70511333a7988146c608470c9a6ad33943be9f91.tar.bz2
gentoo-2-70511333a7988146c608470c9a6ad33943be9f91.zip
Fix USE=java - remove the bundled jar file. Has 1.5 bytecode, breaking build with 1.4 JDK, besides others. Revbump so that everyone installs the same file.
(Portage version: 2.1.4.4)
-rw-r--r--net-dns/libidn/ChangeLog9
-rw-r--r--net-dns/libidn/libidn-1.5-r1.ebuild72
2 files changed, 80 insertions, 1 deletions
diff --git a/net-dns/libidn/ChangeLog b/net-dns/libidn/ChangeLog
index 4cb95876c5a6..b17f5a75ee58 100644
--- a/net-dns/libidn/ChangeLog
+++ b/net-dns/libidn/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dns/libidn
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/libidn/ChangeLog,v 1.75 2008/02/29 10:06:33 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/libidn/ChangeLog,v 1.76 2008/02/29 14:21:52 caster Exp $
+
+*libidn-1.5-r1 (29 Feb 2008)
+
+ 29 Feb 2008; Vlastimil Babka <caster@gentoo.org> +libidn-1.5-r1.ebuild:
+ Fix USE=java - remove the bundled jar file. Has 1.5 bytecode, breaking build
+ with 1.4 JDK, besides others. Revbump so that everyone installs the same
+ file.
29 Feb 2008; Santiago M. Mola <coldwind@gentoo.org> libidn-1.0-r1.ebuild:
amd64 stable wrt bug #211857
diff --git a/net-dns/libidn/libidn-1.5-r1.ebuild b/net-dns/libidn/libidn-1.5-r1.ebuild
new file mode 100644
index 000000000000..4cacfd93faf9
--- /dev/null
+++ b/net-dns/libidn/libidn-1.5-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/libidn/libidn-1.5-r1.ebuild,v 1.1 2008/02/29 14:21:52 caster Exp $
+
+inherit java-pkg-opt-2 mono autotools elisp-common
+
+DESCRIPTION="Internationalized Domain Names (IDN) implementation"
+HOMEPAGE="http://www.gnu.org/software/libidn/"
+SRC_URI="ftp://alpha.gnu.org/pub/gnu/libidn/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="java doc emacs mono nls"
+
+DEPEND="mono? ( >=dev-lang/mono-0.95 )
+ java? ( >=virtual/jdk-1.4 dev-java/gjdoc )"
+RDEPEND="java? ( >=virtual/jre-1.4 )
+ mono? ( >=dev-lang/mono-0.95 )
+ emacs? ( virtual/emacs )"
+
+src_unpack() {
+ unpack ${A}
+ # bundled, with wrong bytecode
+ rm "${S}/java/${P}.jar" || die
+}
+
+src_compile() {
+ local myconf=" --disable-csharp"
+
+ use mono && myconf="--enable-csharp=mono"
+ use emacs && myconf="${myconf} --with-lispdir=${SITELISP}/${PN}"
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable java) \
+ ${myconf} \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog FAQ NEWS README THANKS TODO || die
+
+ use emacs || rm -rf "${D}/usr/share/emacs"
+ #use xemacs || rm -rf "${D}/usr/lib/xemacs"
+
+ if use doc ; then
+ dohtml -r doc/reference/html/* || die
+ fi
+
+ if use java ; then
+ java-pkg_newjar "${D}"/usr/share/java/${P}.jar || die
+ rm -rf "${D}"/usr/share/java || die
+
+ if use doc ; then
+ java-pkg_dojavadoc doc/java
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if use emacs ; then
+ elog "activate Emacs support by adding the following lines"
+ elog "to your ~/.emacs file:"
+ elog " (add-to-list 'load-path \"${SITELISP}/${PN}\")"
+ elog " (load idna)"
+ elog " (load punycode)"
+ fi
+}