summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2005-02-25 12:45:00 +0000
committerBenedikt Boehm <hollow@gentoo.org>2005-02-25 12:45:00 +0000
commit6f0bd2a75de47c5d38dac8b5081dc3670bdab273 (patch)
tree74e46c0897b20f8f31ec10d46d9330881acd5948
parentadded mod_bw-0.5 (diff)
downloadgentoo-2-6f0bd2a75de47c5d38dac8b5081dc3670bdab273.tar.gz
gentoo-2-6f0bd2a75de47c5d38dac8b5081dc3670bdab273.tar.bz2
gentoo-2-6f0bd2a75de47c5d38dac8b5081dc3670bdab273.zip
version bump + fixes
(Portage version: 2.0.51.16)
-rw-r--r--net-www/mod_bw/ChangeLog8
-rw-r--r--net-www/mod_bw/Manifest16
-rw-r--r--net-www/mod_bw/files/digest-mod_bw-0.51
-rw-r--r--net-www/mod_bw/mod_bw-0.5.ebuild29
-rw-r--r--net-www/mod_bw/mod_bw-0.5_rc1.ebuild3
5 files changed, 42 insertions, 15 deletions
diff --git a/net-www/mod_bw/ChangeLog b/net-www/mod_bw/ChangeLog
index 646843e1314b..6a7a33f1e6e4 100644
--- a/net-www/mod_bw/ChangeLog
+++ b/net-www/mod_bw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/mod_bw
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_bw/ChangeLog,v 1.1 2005/02/14 17:14:50 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_bw/ChangeLog,v 1.2 2005/02/25 12:45:00 hollow Exp $
+
+*mod_bw-0.5 (25 Feb 2005)
+
+ 25 Feb 2005; Benedikt Boehm <hollow@gentoo.org> +mod_bw-0.5.ebuild,
+ mod_bw-0.5_rc1.ebuild:
+ version bump + removed redundant code
*mod_bw-0.5_rc1 (14 Feb 2005)
diff --git a/net-www/mod_bw/Manifest b/net-www/mod_bw/Manifest
index a2a4a1f3d4ae..d60efd5ccea6 100644
--- a/net-www/mod_bw/Manifest
+++ b/net-www/mod_bw/Manifest
@@ -1,15 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 7b2c84986fb350fef1c93d6c179a47c7 ChangeLog 538
MD5 41d6c0ba999d7b4af929e07368693a3f metadata.xml 261
-MD5 eb095528668f38d1814a450a718c1924 mod_bw-0.5_rc1.ebuild 720
-MD5 543d1b7f5a1d8bec846c74f1aea3550c ChangeLog 375
+MD5 839035c1ade21b13b5d749b60ca76acb mod_bw-0.5_rc1.ebuild 696
+MD5 839035c1ade21b13b5d749b60ca76acb mod_bw-0.5.ebuild 696
MD5 e45b84221c7a081fd11c7f44b083b0e9 files/11_mod_bw.conf 511
+MD5 7fff28dc6fff1c1ce2dcc9d6a36ffe5b files/digest-mod_bw-0.5 58
MD5 e115388638f885e2b23d665bae2bed12 files/digest-mod_bw-0.5_rc1 61
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCEO0cmPFBzbX68WERAvduAKCG0BdK9noPAl8yaOJkFHlktYqdJgCfevJw
-ClftPDr/OB2Pkq7+KFEug2Y=
-=OSVf
------END PGP SIGNATURE-----
diff --git a/net-www/mod_bw/files/digest-mod_bw-0.5 b/net-www/mod_bw/files/digest-mod_bw-0.5
new file mode 100644
index 000000000000..a01ca0775c4a
--- /dev/null
+++ b/net-www/mod_bw/files/digest-mod_bw-0.5
@@ -0,0 +1 @@
+MD5 d03f484013f4dc39b77c19bbf3171e57 bw_mod-0.5.tgz 21772
diff --git a/net-www/mod_bw/mod_bw-0.5.ebuild b/net-www/mod_bw/mod_bw-0.5.ebuild
new file mode 100644
index 000000000000..7ca652cbcdac
--- /dev/null
+++ b/net-www/mod_bw/mod_bw-0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_bw/mod_bw-0.5.ebuild,v 1.1 2005/02/25 12:45:00 hollow Exp $
+
+inherit eutils apache-module
+
+MYP="bw_mod-${PV}"
+
+DESCRIPTION="Bandwidth Management Module for Apache 2.0"
+HOMEPAGE="http://www.ivn.cl/apache/"
+SRC_URI="http://www.ivn.cl/apache/${MYP/_rc/rc}.tgz"
+
+KEYWORDS="~x86"
+DEPEND=""
+LICENSE="Apache-1.1"
+SLOT="1"
+IUSE=""
+
+APACHE2_MOD_CONF="11_${PN}"
+APACHE2_MOD_DEFINE="BW"
+
+need_apache2
+
+S=${WORKDIR}/${MYP/_rc*}
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ mv ${S}/{${MYP/_rc/rc}.c,${PN}.c} || die "cannot move source file"
+}
diff --git a/net-www/mod_bw/mod_bw-0.5_rc1.ebuild b/net-www/mod_bw/mod_bw-0.5_rc1.ebuild
index 78ab8b5973f7..9148887e5c4e 100644
--- a/net-www/mod_bw/mod_bw-0.5_rc1.ebuild
+++ b/net-www/mod_bw/mod_bw-0.5_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_bw/mod_bw-0.5_rc1.ebuild,v 1.1 2005/02/14 17:14:50 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_bw/mod_bw-0.5_rc1.ebuild,v 1.2 2005/02/25 12:45:00 hollow Exp $
inherit eutils apache-module
@@ -16,7 +16,6 @@ LICENSE="Apache-1.1"
SLOT="1"
IUSE=""
-APXS2_ARGS="-c ${PN}.c"
APACHE2_MOD_CONF="11_${PN}"
APACHE2_MOD_DEFINE="BW"