summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-21 14:20:45 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-21 14:20:45 +0000
commit69e26d99248df72b5ad4e50480f9a7b3bed4a687 (patch)
tree4882bedb5b12a6afc4d04a1d7b42b0a9c9d24a17
parentRemove old ebuilds (diff)
downloadgentoo-2-69e26d99248df72b5ad4e50480f9a7b3bed4a687.tar.gz
gentoo-2-69e26d99248df72b5ad4e50480f9a7b3bed4a687.tar.bz2
gentoo-2-69e26d99248df72b5ad4e50480f9a7b3bed4a687.zip
Use sys-apps/gentoo-functions, bug #504390.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
-rw-r--r--games-emulation/virtualjaguar/ChangeLog8
-rw-r--r--games-emulation/virtualjaguar/files/virtualjaguar6
-rw-r--r--games-emulation/virtualjaguar/virtualjaguar-1.0.7-r1.ebuild60
3 files changed, 70 insertions, 4 deletions
diff --git a/games-emulation/virtualjaguar/ChangeLog b/games-emulation/virtualjaguar/ChangeLog
index 392b66eda96f..bf5aadf06cc9 100644
--- a/games-emulation/virtualjaguar/ChangeLog
+++ b/games-emulation/virtualjaguar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/virtualjaguar
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/virtualjaguar/ChangeLog,v 1.16 2014/10/15 03:50:52 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/virtualjaguar/ChangeLog,v 1.17 2014/12/21 14:20:45 mgorny Exp $
+
+*virtualjaguar-1.0.7-r1 (21 Dec 2014)
+
+ 21 Dec 2014; Michał Górny <mgorny@gentoo.org> +virtualjaguar-1.0.7-r1.ebuild,
+ files/virtualjaguar:
+ Use sys-apps/gentoo-functions, bug #504390.
*virtualjaguar-2.1.2 (15 Oct 2014)
diff --git a/games-emulation/virtualjaguar/files/virtualjaguar b/games-emulation/virtualjaguar/files/virtualjaguar
index 90ab9cda82c2..bc607d5aaf42 100644
--- a/games-emulation/virtualjaguar/files/virtualjaguar
+++ b/games-emulation/virtualjaguar/files/virtualjaguar
@@ -1,11 +1,11 @@
#!/bin/bash
#
# Script for launching virtualjaguar
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/virtualjaguar/files/virtualjaguar,v 1.6 2007/05/05 05:17:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/virtualjaguar/files/virtualjaguar,v 1.7 2014/12/21 14:20:45 mgorny Exp $
-source /etc/init.d/functions.sh || exit 1
+source /lib/gentoo/functions.sh || exit 1
shopt -s nullglob
diff --git a/games-emulation/virtualjaguar/virtualjaguar-1.0.7-r1.ebuild b/games-emulation/virtualjaguar/virtualjaguar-1.0.7-r1.ebuild
new file mode 100644
index 000000000000..10e0f6875434
--- /dev/null
+++ b/games-emulation/virtualjaguar/virtualjaguar-1.0.7-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/virtualjaguar/virtualjaguar-1.0.7-r1.ebuild,v 1.1 2014/12/21 14:20:45 mgorny Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="an Atari Jaguar emulator"
+HOMEPAGE="http://www.icculus.org/virtualjaguar/"
+SRC_URI="http://www.icculus.org/virtualjaguar/tarballs/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ media-libs/libsdl[sound,joystick,opengl,video]
+ sys-apps/gentoo-functions"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${P}-src
+
+src_prepare() {
+ mkdir obj || die
+ edos2unix src/sdlemu_config.cpp
+ epatch \
+ "${FILESDIR}"/${PV}-cdintf_linux.patch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-makefile.patch \
+ "${FILESDIR}"/${P}-array.patch
+
+ sed -e "s:GENTOODIR:${GAMES_BINDIR}:" \
+ "${FILESDIR}/virtualjaguar" > "${T}/virtualjaguar" || die
+}
+
+src_compile() {
+ export SYSTYPE=__GCCUNIX__ \
+ GLLIB=-lGL \
+ SDLLIBTYPE=--libs
+ emake obj/m68kops.h || die
+ emake LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dogamesbin vj "${T}/virtualjaguar" || die "dogamebin failed"
+ dodoc docs/{README,TODO,WHATSNEW}
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "Please run ${PN} to create the necessary directories"
+ elog "in your home directory. After that you may place ROM files"
+ elog "in ~/.vj/ROMs and they will be detected when you run virtualjaguar."
+ elog "You may then select which ROM to run from inside the emulator."
+ elog
+ elog "If you have previously run a version of ${PV} please note that"
+ elog "the location of the ROMs has changed."
+}