summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-07-28 04:02:22 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-07-28 04:02:22 +0000
commit67693ccb93dda571450b84e84a68be4513ec3c85 (patch)
treebdf78c4c5837a465a81f446fcd9b704deb0c2780
parentnew package for blackboxlike window managers to set window properties (diff)
downloadgentoo-2-67693ccb93dda571450b84e84a68be4513ec3c85.tar.gz
gentoo-2-67693ccb93dda571450b84e84a68be4513ec3c85.tar.bz2
gentoo-2-67693ccb93dda571450b84e84a68be4513ec3c85.zip
shoot me
-rw-r--r--sys-devel/gcc/gcc-3.2_pre.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-devel/gcc/gcc-3.2_pre.ebuild b/sys-devel/gcc/gcc-3.2_pre.ebuild
index d0c2bdeab9bf..65bd9830abff 100644
--- a/sys-devel/gcc/gcc-3.2_pre.ebuild
+++ b/sys-devel/gcc/gcc-3.2_pre.ebuild
@@ -11,7 +11,7 @@
inherit libtool
-MY_PV="`echo ${PV} | cut -d. -f1,2`"
+MY_PV="`echo ${PV/_pre} | cut -d. -f1,2`"
GCC_SUFFIX=-${MY_PV}
LOC="/usr"
# dont install in /usr/include/g++-v3/, as it will nuke gcc-3.0.x installs
@@ -170,8 +170,8 @@ src_install() {
[ -e ${D}${LOC}/bin/gcc${GCC_SUFFIX} ] || die "gcc not found in ${D}"
- FULLPATH=${LOC}/lib/gcc-lib/${CHOST}/${PV}
- FULLPATH_D=${D}${LOC}/lib/gcc-lib/${CHOST}/${PV}
+ FULLPATH=${LOC}/lib/gcc-lib/${CHOST}/${PV/_pre}
+ FULLPATH_D=${D}${LOC}/lib/gcc-lib/${CHOST}/${PV/_pre}
cd ${FULLPATH_D}
dodir /lib
dodir /etc/env.d