summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-03-10 00:55:38 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-03-10 00:55:38 +0000
commit66ddba9aedef675c8e06b885aeb69754a8ebf1ea (patch)
tree7fdfe913209e3714569d0877205494d9d685d1fd
parentDrop to ~mips to match dependencies (diff)
downloadgentoo-2-66ddba9aedef675c8e06b885aeb69754a8ebf1ea.tar.gz
gentoo-2-66ddba9aedef675c8e06b885aeb69754a8ebf1ea.tar.bz2
gentoo-2-66ddba9aedef675c8e06b885aeb69754a8ebf1ea.zip
Fix license file ownership, remove some versions (security bug #210317)
(Portage version: 2.1.4.4)
-rw-r--r--net-misc/nxnode/ChangeLog8
-rw-r--r--net-misc/nxnode/nxnode-3.0.0-r3.ebuild12
-rw-r--r--net-misc/nxnode/nxnode-3.0.0-r4.ebuild110
-rw-r--r--net-misc/nxnode/nxnode-3.1.0-r1.ebuild110
-rw-r--r--net-misc/nxnode/nxnode-3.1.0-r2.ebuild9
-rw-r--r--net-misc/nxnode/nxnode-3.1.0.ebuild110
6 files changed, 23 insertions, 336 deletions
diff --git a/net-misc/nxnode/ChangeLog b/net-misc/nxnode/ChangeLog
index cba4930f5f0d..4c7fe1c54882 100644
--- a/net-misc/nxnode/ChangeLog
+++ b/net-misc/nxnode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/nxnode
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxnode/ChangeLog,v 1.22 2008/02/18 17:54:44 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxnode/ChangeLog,v 1.23 2008/03/10 00:55:38 voyageur Exp $
+
+ 07 Mar 2008; Bernard Cafarelli <voyageur@gentoo.org>
+ nxnode-3.0.0-r3.ebuild, -nxnode-3.0.0-r4.ebuild, -nxnode-3.1.0.ebuild,
+ -nxnode-3.1.0-r1.ebuild, nxnode-3.1.0-r2.ebuild:
+ Fix chown on license file (create nx user preventively, use nx:0), thanks pva
+ Remove some versions (security bug #210317)
18 Feb 2008; Christian Faulhammer <opfer@gentoo.org>
nxnode-3.1.0-r2.ebuild:
diff --git a/net-misc/nxnode/nxnode-3.0.0-r3.ebuild b/net-misc/nxnode/nxnode-3.0.0-r3.ebuild
index 6413adee95e4..ec5b6756bae8 100644
--- a/net-misc/nxnode/nxnode-3.0.0-r3.ebuild
+++ b/net-misc/nxnode/nxnode-3.0.0-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxnode/nxnode-3.0.0-r3.ebuild,v 1.4 2007/12/14 12:11:41 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxnode/nxnode-3.0.0-r3.ebuild,v 1.5 2008/03/10 00:55:38 voyageur Exp $
inherit eutils
@@ -31,6 +31,12 @@ RDEPEND="=net-misc/nxclient-3.0*
S=${WORKDIR}/NX
+pkg_preinst()
+{
+ enewuser nx -1 -1 /usr/NX/home/nx
+}
+
+
pkg_setup() {
if use vnc; then
if has_version net-misc/vnc && ! built_with_use net-misc/vnc server;
@@ -89,7 +95,7 @@ pkg_postinst()
if [ ! -f /usr/NX/etc/node.lic ]; then
cp ${ROOT}/usr/NX/etc/node.lic.sample ${ROOT}/usr/NX/etc/node.lic || die
chmod 0400 ${ROOT}/usr/NX/etc/node.lic
- chown nx:root ${ROOT}/usr/NX/etc/node.lic
+ chown nx:0 ${ROOT}/usr/NX/etc/node.lic
fi
# only run install on the first time
diff --git a/net-misc/nxnode/nxnode-3.0.0-r4.ebuild b/net-misc/nxnode/nxnode-3.0.0-r4.ebuild
deleted file mode 100644
index e4c7dea4154c..000000000000
--- a/net-misc/nxnode/nxnode-3.0.0-r4.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxnode/nxnode-3.0.0-r4.ebuild,v 1.2 2007/12/14 12:11:41 voyageur Exp $
-
-inherit eutils
-
-MY_PV="${PV}-93"
-DESCRIPTION="nxnode provides the components that are shared between the different editions of NoMachine's NX Server"
-HOMEPAGE="http://www.nomachine.com/"
-SRC_URI="amd64? ( http://64.34.161.181/download/3.0.0/Linux/nxnode-${MY_PV}.x86_64.tar.gz )
- x86? ( http://64.34.161.181/download/3.0.0/Linux/nxnode-${MY_PV}.i386.tar.gz )"
-
-LICENSE="nomachine"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="rdesktop vnc"
-RESTRICT="strip"
-
-DEPEND="!net-misc/nxserver-freenx
- !<net-misc/nxserver-freeedition-3.0.0"
-
-RDEPEND="=net-misc/nxclient-3.0*
- x11-libs/libICE
- x11-libs/libXmu
- x11-libs/libSM
- x11-libs/libXt
- x11-libs/libXaw
- x11-libs/libXpm
- x11-apps/xrdb
- rdesktop? ( net-misc/rdesktop )
- vnc? ( || ( net-misc/vnc net-misc/tightvnc ) )"
-
-S=${WORKDIR}/NX
-
-pkg_setup() {
- if use vnc; then
- if has_version net-misc/vnc && ! built_with_use net-misc/vnc server;
- then
- die "net-misc/vnc needs to be built with USE=\"server\" for VNC support"
- fi
-
- if has_version net-misc/tightvnc && ! built_with_use net-misc/tightvnc server;
- then
- die "net-misc/tightvnc needs to be built with USE=\"server\" for VNC support"
- fi
- fi
-}
-
-src_unpack()
-{
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/nxnode-3.0.0-setup.patch
-}
-
-src_install()
-{
- # we install nxnode into /usr/NX, to make sure it doesn't clash
- # with libraries installed for FreeNX
-
- into /usr/NX
- for x in nxagent nxnode nxsensor nxspool nxuexec ; do
- dobin bin/$x
- done
-
- dodir /usr/NX/etc
- cp etc/node-debian.cfg.sample "${D}"/usr/NX/etc/node-gentoo.cfg.sample || die
- sed -e 's|COMMAND_FUSER = .*|COMMAND_FUSER = "/usr/bin/fuser"|;' -i "${D}"/usr/NX/etc/node-gentoo.cfg.sample || die
- cp etc/node.lic.sample "${D}"/usr/NX/etc/node.lic.sample || die
-
- dodir /usr/NX/lib
- cp -R lib "${D}"/usr/NX || die
-
- dodir /usr/NX/scripts
- cp -R scripts "${D}"/usr/NX || die
-
- dodir /usr/NX/share
- cp -R share "${D}"/usr/NX || die
-
- dodir /usr/NX/var
- cp -R var "${D}"/usr/NX || die
-
- dodir /etc/init.d
- newinitd "${FILESDIR}"/nxnode-3.0.0-init nxsensor
-}
-
-pkg_postinst()
-{
- # Only install license file if none is found
- if [ ! -f /usr/NX/etc/node.lic ]; then
- cp "${ROOT}"/usr/NX/etc/node.lic.sample "${ROOT}"/usr/NX/etc/node.lic || die
- chmod 0400 "${ROOT}"/usr/NX/etc/node.lic
- chown nx:root "${ROOT}"/usr/NX/etc/node.lic
- fi
-
- # only run install on the first time
- if [ -f /usr/NX/etc/node.cfg ]; then
- einfo "Running NoMachine's update script"
- "${ROOT}"/usr/NX/scripts/setup/nxnode --update
- else
- einfo "Running NoMachine's setup script"
- "${ROOT}"/usr/NX/scripts/setup/nxnode --install
- fi
-
- elog "If you want server statistics, please add nxsensor to your default runlevel"
- elog
- elog " rc-update add nxsensor default"
- elog
- elog "You will also need to change EnableSensor to 1 in /usr/NX/etc/node.cfg"
-}
diff --git a/net-misc/nxnode/nxnode-3.1.0-r1.ebuild b/net-misc/nxnode/nxnode-3.1.0-r1.ebuild
deleted file mode 100644
index a26e3ff3eea9..000000000000
--- a/net-misc/nxnode/nxnode-3.1.0-r1.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxnode/nxnode-3.1.0-r1.ebuild,v 1.1 2008/01/24 14:30:10 voyageur Exp $
-
-inherit eutils
-
-MY_PV="${PV}-5"
-DESCRIPTION="nxnode provides the components that are shared between the different editions of NoMachine's NX Server"
-HOMEPAGE="http://www.nomachine.com/"
-SRC_URI="amd64? ( http://64.34.161.181/download/${PV}/Linux/nxnode-${MY_PV}.x86_64.tar.gz )
- x86? ( http://64.34.161.181/download/${PV}/Linux/nxnode-${MY_PV}.i386.tar.gz )"
-
-LICENSE="nomachine"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="rdesktop vnc"
-RESTRICT="strip"
-
-DEPEND="!net-misc/nxserver-freenx
- !<net-misc/nxserver-freeedition-3.0.0"
-
-RDEPEND="=net-misc/nxclient-3.1*
- x11-libs/libICE
- x11-libs/libXmu
- x11-libs/libSM
- x11-libs/libXt
- x11-libs/libXaw
- x11-libs/libXpm
- x11-apps/xrdb
- rdesktop? ( net-misc/rdesktop )
- vnc? ( || ( net-misc/vnc net-misc/tightvnc ) )"
-
-S=${WORKDIR}/NX
-
-pkg_setup() {
- if use vnc; then
- if has_version net-misc/vnc && ! built_with_use net-misc/vnc server;
- then
- die "net-misc/vnc needs to be built with USE=\"server\" for VNC support"
- fi
-
- if has_version net-misc/tightvnc && ! built_with_use net-misc/tightvnc server;
- then
- die "net-misc/tightvnc needs to be built with USE=\"server\" for VNC support"
- fi
- fi
-}
-
-src_unpack()
-{
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/nxnode-3.0.0-setup.patch
-}
-
-src_install()
-{
- # we install nxnode into /usr/NX, to make sure it doesn't clash
- # with libraries installed for FreeNX
-
- into /usr/NX
- for x in nxagent nxnode nxsensor nxspool nxuexec ; do
- dobin bin/$x
- done
-
- dodir /usr/NX/etc
- cp etc/node-debian.cfg.sample "${D}"/usr/NX/etc/node-gentoo.cfg.sample || die
- sed -e 's|COMMAND_FUSER = .*|COMMAND_FUSER = "/usr/bin/fuser"|;' -i "${D}"/usr/NX/etc/node-gentoo.cfg.sample || die
- cp etc/node.lic.sample "${D}"/usr/NX/etc/node.lic.sample || die
-
- dodir /usr/NX/lib
- cp -R lib "${D}"/usr/NX || die
-
- dodir /usr/NX/scripts
- cp -R scripts "${D}"/usr/NX || die
-
- dodir /usr/NX/share
- cp -R share "${D}"/usr/NX || die
-
- dodir /usr/NX/var
- cp -R var "${D}"/usr/NX || die
-
- dodir /etc/init.d
- newinitd "${FILESDIR}"/nxnode-3.0.0-init nxsensor
-}
-
-pkg_postinst()
-{
- # Only install license file if none is found
- if [ ! -f /usr/NX/etc/node.lic ]; then
- cp "${ROOT}"/usr/NX/etc/node.lic.sample "${ROOT}"/usr/NX/etc/node.lic || die
- chmod 0400 "${ROOT}"/usr/NX/etc/node.lic
- chown nx:root "${ROOT}"/usr/NX/etc/node.lic
- fi
-
- # only run install on the first time
- if [ -f /usr/NX/etc/node.cfg ]; then
- einfo "Running NoMachine's update script"
- "${ROOT}"/usr/NX/scripts/setup/nxnode --update
- else
- einfo "Running NoMachine's setup script"
- "${ROOT}"/usr/NX/scripts/setup/nxnode --install
- fi
-
- elog "If you want server statistics, please add nxsensor to your default runlevel"
- elog
- elog " rc-update add nxsensor default"
- elog
- elog "You will also need to change EnableSensor to 1 in /usr/NX/etc/node.cfg"
-}
diff --git a/net-misc/nxnode/nxnode-3.1.0-r2.ebuild b/net-misc/nxnode/nxnode-3.1.0-r2.ebuild
index 54ad7cb8a729..93752aade15d 100644
--- a/net-misc/nxnode/nxnode-3.1.0-r2.ebuild
+++ b/net-misc/nxnode/nxnode-3.1.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxnode/nxnode-3.1.0-r2.ebuild,v 1.2 2008/02/18 17:54:44 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxnode/nxnode-3.1.0-r2.ebuild,v 1.3 2008/03/10 00:55:38 voyageur Exp $
inherit eutils
@@ -33,6 +33,11 @@ RDEPEND="=net-misc/nxclient-3.1*
S=${WORKDIR}/NX
+pkg_preinst()
+{
+ enewuser nx -1 -1 /usr/NX/home/nx
+}
+
pkg_setup() {
if use vnc; then
if has_version net-misc/vnc && ! built_with_use net-misc/vnc server;
@@ -91,7 +96,7 @@ pkg_postinst()
if [ ! -f /usr/NX/etc/node.lic ]; then
cp "${ROOT}"/usr/NX/etc/node.lic.sample "${ROOT}"/usr/NX/etc/node.lic || die
chmod 0400 "${ROOT}"/usr/NX/etc/node.lic
- chown nx:root "${ROOT}"/usr/NX/etc/node.lic
+ chown nx:0 "${ROOT}"/usr/NX/etc/node.lic
fi
# only run install on the first time
diff --git a/net-misc/nxnode/nxnode-3.1.0.ebuild b/net-misc/nxnode/nxnode-3.1.0.ebuild
deleted file mode 100644
index e63f68546140..000000000000
--- a/net-misc/nxnode/nxnode-3.1.0.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxnode/nxnode-3.1.0.ebuild,v 1.1 2007/12/14 12:11:41 voyageur Exp $
-
-inherit eutils
-
-MY_PV="${PV}-3"
-DESCRIPTION="nxnode provides the components that are shared between the different editions of NoMachine's NX Server"
-HOMEPAGE="http://www.nomachine.com/"
-SRC_URI="amd64? ( http://64.34.161.181/download/${PV}/Linux/nxnode-${MY_PV}.x86_64.tar.gz )
- x86? ( http://64.34.161.181/download/${PV}/Linux/nxnode-${MY_PV}.i386.tar.gz )"
-
-LICENSE="nomachine"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="rdesktop vnc"
-RESTRICT="strip"
-
-DEPEND="!net-misc/nxserver-freenx
- !<net-misc/nxserver-freeedition-3.0.0"
-
-RDEPEND="=net-misc/nxclient-3.1*
- x11-libs/libICE
- x11-libs/libXmu
- x11-libs/libSM
- x11-libs/libXt
- x11-libs/libXaw
- x11-libs/libXpm
- x11-apps/xrdb
- rdesktop? ( net-misc/rdesktop )
- vnc? ( || ( net-misc/vnc net-misc/tightvnc ) )"
-
-S=${WORKDIR}/NX
-
-pkg_setup() {
- if use vnc; then
- if has_version net-misc/vnc && ! built_with_use net-misc/vnc server;
- then
- die "net-misc/vnc needs to be built with USE=\"server\" for VNC support"
- fi
-
- if has_version net-misc/tightvnc && ! built_with_use net-misc/tightvnc server;
- then
- die "net-misc/tightvnc needs to be built with USE=\"server\" for VNC support"
- fi
- fi
-}
-
-src_unpack()
-{
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/nxnode-3.0.0-setup.patch
-}
-
-src_install()
-{
- # we install nxnode into /usr/NX, to make sure it doesn't clash
- # with libraries installed for FreeNX
-
- into /usr/NX
- for x in nxagent nxnode nxsensor nxspool nxuexec ; do
- dobin bin/$x
- done
-
- dodir /usr/NX/etc
- cp etc/node-debian.cfg.sample "${D}"/usr/NX/etc/node-gentoo.cfg.sample || die
- sed -e 's|COMMAND_FUSER = .*|COMMAND_FUSER = "/usr/bin/fuser"|;' -i "${D}"/usr/NX/etc/node-gentoo.cfg.sample || die
- cp etc/node.lic.sample "${D}"/usr/NX/etc/node.lic.sample || die
-
- dodir /usr/NX/lib
- cp -R lib "${D}"/usr/NX || die
-
- dodir /usr/NX/scripts
- cp -R scripts "${D}"/usr/NX || die
-
- dodir /usr/NX/share
- cp -R share "${D}"/usr/NX || die
-
- dodir /usr/NX/var
- cp -R var "${D}"/usr/NX || die
-
- dodir /etc/init.d
- newinitd "${FILESDIR}"/nxnode-3.0.0-init nxsensor
-}
-
-pkg_postinst()
-{
- # Only install license file if none is found
- if [ ! -f /usr/NX/etc/node.lic ]; then
- cp "${ROOT}"/usr/NX/etc/node.lic.sample "${ROOT}"/usr/NX/etc/node.lic || die
- chmod 0400 "${ROOT}"/usr/NX/etc/node.lic
- chown nx:root "${ROOT}"/usr/NX/etc/node.lic
- fi
-
- # only run install on the first time
- if [ -f /usr/NX/etc/node.cfg ]; then
- einfo "Running NoMachine's update script"
- "${ROOT}"/usr/NX/scripts/setup/nxnode --update
- else
- einfo "Running NoMachine's setup script"
- "${ROOT}"/usr/NX/scripts/setup/nxnode --install
- fi
-
- elog "If you want server statistics, please add nxsensor to your default runlevel"
- elog
- elog " rc-update add nxsensor default"
- elog
- elog "You will also need to change EnableSensor to 1 in /usr/NX/etc/node.cfg"
-}