summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda XU <heroxbd@gentoo.org>2014-12-01 05:54:08 +0000
committerBenda XU <heroxbd@gentoo.org>2014-12-01 05:54:08 +0000
commit61ea09af1a67b1f988707b5489c4aed6ccc33a88 (patch)
tree955028986e7a7f64127a80e28b1452c6e2ad815f
parentclean old python impl, minor upgrade to fix to qa issue, remove many old (diff)
downloadgentoo-2-61ea09af1a67b1f988707b5489c4aed6ccc33a88.tar.gz
gentoo-2-61ea09af1a67b1f988707b5489c4aed6ccc33a88.tar.bz2
gentoo-2-61ea09af1a67b1f988707b5489c4aed6ccc33a88.zip
Version bump to 1.3.11 and to EAPI 5 for bug #517072; thanks Mark R. Pariente. Drop old ebuilds and python 2.5/2.6 dependencies. Rebase -9999 to 1.3.11. Migrate from distutils to distutils-r1.
(Portage version: 2.2.14/cvs/Linux x86_64, RepoMan options: --force, unsigned Manifest commit)
-rw-r--r--net-p2p/deluge/ChangeLog11
-rw-r--r--net-p2p/deluge/deluge-1.3.11.ebuild (renamed from net-p2p/deluge/deluge-1.3.5-r2.ebuild)53
-rw-r--r--net-p2p/deluge/deluge-1.3.3.ebuild69
-rw-r--r--net-p2p/deluge/deluge-1.3.5.ebuild71
-rw-r--r--net-p2p/deluge/deluge-9999.ebuild54
5 files changed, 67 insertions, 191 deletions
diff --git a/net-p2p/deluge/ChangeLog b/net-p2p/deluge/ChangeLog
index 67dc4900f260..011376180a52 100644
--- a/net-p2p/deluge/ChangeLog
+++ b/net-p2p/deluge/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-p2p/deluge
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.189 2014/08/10 20:36:34 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.190 2014/12/01 05:54:08 heroxbd Exp $
+
+*deluge-1.3.11 (01 Dec 2014)
+
+ 01 Dec 2014; Benda Xu <heroxbd@gentoo.org> +deluge-1.3.11.ebuild,
+ -deluge-1.3.3.ebuild, -deluge-1.3.5-r2.ebuild, -deluge-1.3.5.ebuild,
+ deluge-9999.ebuild:
+ Version bump to 1.3.11 and to EAPI 5 for bug #517072; thanks Mark R. Pariente.
+ Drop old ebuilds and python 2.5/2.6 dependencies. Rebase -9999 to 1.3.11.
+ Migrate from distutils to distutils-r1.
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> deluge-1.3.3.ebuild,
deluge-1.3.5-r2.ebuild, deluge-1.3.5.ebuild, deluge-1.3.6.ebuild,
diff --git a/net-p2p/deluge/deluge-1.3.5-r2.ebuild b/net-p2p/deluge/deluge-1.3.11.ebuild
index c4c3b4a59d76..2322482b454d 100644
--- a/net-p2p/deluge/deluge-1.3.5-r2.ebuild
+++ b/net-p2p/deluge/deluge-1.3.11.ebuild
@@ -1,34 +1,42 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.3.5-r2.ebuild,v 1.6 2014/08/10 20:36:34 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.3.11.ebuild,v 1.1 2014/12/01 05:54:08 heroxbd Exp $
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
+EAPI="5"
-inherit distutils eutils flag-o-matic python
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1 eutils systemd
DESCRIPTION="BitTorrent client with a client/server model"
HOMEPAGE="http://deluge-torrent.org/"
-SRC_URI="http://download.deluge-torrent.org/source/${P}.tar.lzma"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://deluge-torrent.org/${PN}.git
+ http://git.deluge-torrent.org/${PN}"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.deluge-torrent.org/source/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+fi
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
-IUSE="geoip gtk libnotify setproctitle webinterface"
+IUSE="geoip gtk libnotify setproctitle sound webinterface"
DEPEND=">=net-libs/rb_libtorrent-0.14.9[python]
- dev-python/setuptools
dev-util/intltool"
-RDEPEND="${DEPEND}
+RDEPEND=">=net-libs/rb_libtorrent-0.14.9[python]
dev-python/chardet
dev-python/pyopenssl
dev-python/pyxdg
- || ( dev-lang/python:2.7 dev-lang/python:2.6 dev-python/simplejson )
>=dev-python/twisted-core-8.1
>=dev-python/twisted-web-8.1
geoip? ( dev-libs/geoip )
gtk? (
- dev-python/pygame
+ sound? ( dev-python/pygame )
dev-python/pygobject:2
>=dev-python/pygtk-2.12
gnome-base/librsvg
@@ -37,28 +45,23 @@ RDEPEND="${DEPEND}
setproctitle? ( dev-python/setproctitle )
webinterface? ( dev-python/mako )"
-pkg_setup() {
- append-ldflags $(no-as-needed)
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- distutils_src_prepare
- python_convert_shebangs -r 2 .
- epatch "${FILESDIR}/${P}-rb_libtorrent-disable-python-bindings"
- epatch "${FILESDIR}/${P}-disable_libtorrent_internal_copy.patch"
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.5-disable_libtorrent_internal_copy.patch
+ )
+ distutils-r1_python_prepare_all
}
-src_install() {
- distutils_src_install
+python_install_all() {
+ distutils-r1_python_install_all
newinitd "${FILESDIR}"/deluged.init deluged
newconfd "${FILESDIR}"/deluged.conf deluged
+ systemd_dounit "${FILESDIR}"/deluged.service
+ systemd_dounit "${FILESDIR}"/deluge-web.service
}
pkg_postinst() {
- distutils_pkg_postinst
elog
elog "If after upgrading it doesn't work, please remove the"
elog "'~/.config/deluge' directory and try again, but make a backup"
diff --git a/net-p2p/deluge/deluge-1.3.3.ebuild b/net-p2p/deluge/deluge-1.3.3.ebuild
deleted file mode 100644
index 35284f52c88c..000000000000
--- a/net-p2p/deluge/deluge-1.3.3.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.3.3.ebuild,v 1.7 2014/08/10 20:36:34 slyfox Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-
-inherit distutils flag-o-matic
-
-DESCRIPTION="BitTorrent client with a client/server model"
-HOMEPAGE="http://deluge-torrent.org/"
-SRC_URI="http://download.deluge-torrent.org/source/${P}.tar.lzma"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc ~sparc x86"
-IUSE="gtk libnotify webinterface"
-
-DEPEND=">=net-libs/rb_libtorrent-0.14.9[python]
- dev-python/setuptools
- dev-util/intltool"
-RDEPEND="${DEPEND}
- dev-python/chardet
- dev-python/pyopenssl
- dev-python/pyxdg
- || ( dev-lang/python:2.7 dev-lang/python:2.6 dev-python/simplejson )
- >=dev-python/twisted-core-8.1
- >=dev-python/twisted-web-8.1
- gtk? (
- dev-python/pygame
- dev-python/pygobject:2
- >=dev-python/pygtk-2.12
- gnome-base/librsvg
- libnotify? ( dev-python/notify-python )
- )
- webinterface? ( dev-python/mako )"
-
-pkg_setup() {
- append-ldflags $(no-as-needed)
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- distutils_src_prepare
- python_convert_shebangs -r 2 .
-}
-
-src_install() {
- distutils_src_install
- newinitd "${FILESDIR}"/deluged.init deluged
- newconfd "${FILESDIR}"/deluged.conf deluged
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- elog
- elog "If after upgrading it doesn't work, please remove the"
- elog "'~/.config/deluge' directory and try again, but make a backup"
- elog "first!"
- elog
- elog "To start the daemon either run 'deluged' as user"
- elog "or modify /etc/conf.d/deluged and run"
- elog "/etc/init.d/deluged start as root"
- elog "You can still use deluge the old way"
- elog
- elog "For more information look at http://dev.deluge-torrent.org/wiki/Faq"
- elog
-}
diff --git a/net-p2p/deluge/deluge-1.3.5.ebuild b/net-p2p/deluge/deluge-1.3.5.ebuild
deleted file mode 100644
index d9ae0b447bfd..000000000000
--- a/net-p2p/deluge/deluge-1.3.5.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.3.5.ebuild,v 1.6 2014/08/10 20:36:34 slyfox Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-
-inherit distutils flag-o-matic
-
-DESCRIPTION="BitTorrent client with a client/server model"
-HOMEPAGE="http://deluge-torrent.org/"
-SRC_URI="http://download.deluge-torrent.org/source/${P}.tar.lzma"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc ~sparc x86"
-IUSE="geoip gtk libnotify setproctitle webinterface"
-
-DEPEND=">=net-libs/rb_libtorrent-0.14.9[python]
- dev-python/setuptools
- dev-util/intltool"
-RDEPEND="${DEPEND}
- dev-python/chardet
- dev-python/pyopenssl
- dev-python/pyxdg
- || ( dev-lang/python:2.7 dev-lang/python:2.6 dev-python/simplejson )
- >=dev-python/twisted-core-8.1
- >=dev-python/twisted-web-8.1
- geoip? ( dev-libs/geoip )
- gtk? (
- dev-python/pygame
- dev-python/pygobject:2
- >=dev-python/pygtk-2.12
- gnome-base/librsvg
- libnotify? ( dev-python/notify-python )
- )
- setproctitle? ( dev-python/setproctitle )
- webinterface? ( dev-python/mako )"
-
-pkg_setup() {
- append-ldflags $(no-as-needed)
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- distutils_src_prepare
- python_convert_shebangs -r 2 .
-}
-
-src_install() {
- distutils_src_install
- newinitd "${FILESDIR}"/deluged.init deluged
- newconfd "${FILESDIR}"/deluged.conf deluged
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- elog
- elog "If after upgrading it doesn't work, please remove the"
- elog "'~/.config/deluge' directory and try again, but make a backup"
- elog "first!"
- elog
- elog "To start the daemon either run 'deluged' as user"
- elog "or modify /etc/conf.d/deluged and run"
- elog "/etc/init.d/deluged start as root"
- elog "You can still use deluge the old way"
- elog
- elog "For more information look at http://dev.deluge-torrent.org/wiki/Faq"
- elog
-}
diff --git a/net-p2p/deluge/deluge-9999.ebuild b/net-p2p/deluge/deluge-9999.ebuild
index e345fe20b33c..d1d0831f3e9b 100644
--- a/net-p2p/deluge/deluge-9999.ebuild
+++ b/net-p2p/deluge/deluge-9999.ebuild
@@ -1,36 +1,42 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-9999.ebuild,v 1.35 2014/08/10 20:36:34 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-9999.ebuild,v 1.36 2014/12/01 05:54:08 heroxbd Exp $
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
+EAPI="5"
-inherit distutils git-2
-
-EGIT_REPO_URI="git://deluge-torrent.org/${PN}.git
- http://git.deluge-torrent.org/${PN}/"
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1 eutils systemd
DESCRIPTION="BitTorrent client with a client/server model"
HOMEPAGE="http://deluge-torrent.org/"
-SRC_URI=""
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://deluge-torrent.org/${PN}.git
+ http://git.deluge-torrent.org/${PN}"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.deluge-torrent.org/source/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+fi
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
-IUSE="geoip gtk libnotify setproctitle webinterface"
+IUSE="geoip gtk libnotify setproctitle sound webinterface"
DEPEND=">=net-libs/rb_libtorrent-0.14.9[python]
- dev-python/setuptools"
-RDEPEND="${DEPEND}
+ dev-util/intltool"
+RDEPEND=">=net-libs/rb_libtorrent-0.14.9[python]
dev-python/chardet
dev-python/pyopenssl
dev-python/pyxdg
- || ( dev-lang/python:2.7 dev-lang/python:2.6 dev-python/simplejson )
>=dev-python/twisted-core-8.1
>=dev-python/twisted-web-8.1
geoip? ( dev-libs/geoip )
gtk? (
- dev-python/pygame
+ sound? ( dev-python/pygame )
dev-python/pygobject:2
>=dev-python/pygtk-2.12
gnome-base/librsvg
@@ -39,25 +45,23 @@ RDEPEND="${DEPEND}
setproctitle? ( dev-python/setproctitle )
webinterface? ( dev-python/mako )"
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.5-disable_libtorrent_internal_copy.patch
+ )
-src_prepare() {
- distutils_src_prepare
- python_convert_shebangs -r 2 .
- epatch "${FILESDIR}/${PN}-1.3.5-disable_libtorrent_internal_copy.patch"
+ distutils-r1_python_prepare_all
}
-src_install() {
- distutils_src_install
+python_install_all() {
+ distutils-r1_python_install_all
newinitd "${FILESDIR}"/deluged.init deluged
newconfd "${FILESDIR}"/deluged.conf deluged
+ systemd_dounit "${FILESDIR}"/deluged.service
+ systemd_dounit "${FILESDIR}"/deluge-web.service
}
pkg_postinst() {
- distutils_pkg_postinst
elog
elog "If after upgrading it doesn't work, please remove the"
elog "'~/.config/deluge' directory and try again, but make a backup"