summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-10-18 08:40:33 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-10-18 08:40:33 +0000
commit609f5d605f8c3baec06ef06d4071848916d46ade (patch)
treecd6ec9fea94f73f29e4a0483f51e83791e66027a
parentadded prefix support (bug #435438) (diff)
downloadgentoo-2-609f5d605f8c3baec06ef06d4071848916d46ade.tar.gz
gentoo-2-609f5d605f8c3baec06ef06d4071848916d46ade.tar.bz2
gentoo-2-609f5d605f8c3baec06ef06d4071848916d46ade.zip
added prefix support (bug #435376)
(Portage version: 2.2.0_alpha140/cvs/Linux i686, signed Manifest commit with key C2000586)
-rw-r--r--dev-java/fop/ChangeLog8
-rw-r--r--dev-java/fop/fop-0.95.ebuild14
2 files changed, 12 insertions, 10 deletions
diff --git a/dev-java/fop/ChangeLog b/dev-java/fop/ChangeLog
index 4bddf2d09905..553945488a48 100644
--- a/dev-java/fop/ChangeLog
+++ b/dev-java/fop/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-java/fop
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/fop/ChangeLog,v 1.68 2011/12/31 15:33:32 sera Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fop/ChangeLog,v 1.69 2012/10/18 08:40:33 ottxor Exp $
+
+ 18 Oct 2012; Christoph Junghans <ottxor@gentoo.org> fop-0.95.ebuild:
+ added prefix support (bug #435376)
31 Dec 2011; Ralph Sennhauser <sera@gentoo.org> fop-0.95.ebuild:
Drop ia64 support #345433
@@ -244,4 +247,3 @@
25 Feb 2004; Dylan Carlson <absinthe@gentoo.org> fop-0.20.5.ebuild,
metadata.xml:
New package. Closes #21475.
-
diff --git a/dev-java/fop/fop-0.95.ebuild b/dev-java/fop/fop-0.95.ebuild
index 52032dc5c05e..a49985f556d8 100644
--- a/dev-java/fop/fop-0.95.ebuild
+++ b/dev-java/fop/fop-0.95.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/fop/fop-0.95.ebuild,v 1.6 2011/12/31 15:33:32 sera Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fop/fop-0.95.ebuild,v 1.7 2012/10/18 08:40:33 ottxor Exp $
# TODO: if 'doc' use flag is used then should build also extra docs ('docs' ant target), currently it cannot
# be built as it needs forrest which we do not have
# TODO: package and use optional dependency jeuclid
-EAPI=2
+EAPI=4
JAVA_PKG_IUSE="doc examples source"
WANT_ANT_TASKS="ant-trax"
@@ -19,7 +19,7 @@ LICENSE="Apache-2.0"
SLOT="0"
# doesn't work with java.awt.headless
RESTRICT="test"
-KEYWORDS="amd64 ppc ppc64 x86"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="hyphenation jai jimi"
COMMON_DEPEND="
@@ -75,7 +75,7 @@ EANT_BUILD_TARGET="package"
src_compile() {
# because I killed the automagic tests; all our JDK's have JCE
local af="-Djdk14.present=true -Djce.present=true"
- use hyphenation && af="${af} -Duser.hyph.dir=/usr/share/offo-hyphenation/hyph/"
+ use hyphenation && af="${af} -Duser.hyph.dir=${EPREFIX}/usr/share/offo-hyphenation/hyph/"
use jai && af="${af} -Djai.present=true"
use jimi && af="${af} -Djimi.present=true"
@@ -95,13 +95,13 @@ src_install() {
if use hyphenation; then
java-pkg_dojar build/fop-hyph.jar
insinto /usr/share/${PN}/
- doins -r hyph || die
+ doins -r hyph
fi
# doesn't support everything upstream launcher does...
java-pkg_dolauncher ${PN} --main org.apache.fop.cli.Main
- dodoc NOTICE README || die
+ dodoc NOTICE README
use doc && java-pkg_dojavadoc build/javadocs
use examples && java-pkg_doexamples examples/* conf