summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-16 05:42:57 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-16 05:42:57 +0000
commit5f6c72c88c109aa941425bcc4c2a678356174bbe (patch)
tree60d483426abad10c71085f914f20e39463280322
parentversion bump (diff)
downloadgentoo-2-5f6c72c88c109aa941425bcc4c2a678356174bbe.tar.gz
gentoo-2-5f6c72c88c109aa941425bcc4c2a678356174bbe.tar.bz2
gentoo-2-5f6c72c88c109aa941425bcc4c2a678356174bbe.zip
version bump
(Portage version: 2.1.1_pre2-r8)
-rw-r--r--x11-misc/entrance/ChangeLog4
-rw-r--r--x11-misc/entrance/entrance-0.9.0.007.ebuild65
-rw-r--r--x11-misc/entrance/entrance-9999.ebuild4
-rw-r--r--x11-misc/entrance/files/digest-entrance-0.9.0.0076
-rw-r--r--x11-misc/entrance/files/digest-entrance-99992
5 files changed, 77 insertions, 4 deletions
diff --git a/x11-misc/entrance/ChangeLog b/x11-misc/entrance/ChangeLog
index f26c583bbaee..c0f6cedb8362 100644
--- a/x11-misc/entrance/ChangeLog
+++ b/x11-misc/entrance/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for x11-misc/entrance
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/entrance/ChangeLog,v 1.13 2005/12/14 04:24:02 joshuabaergen Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/entrance/ChangeLog,v 1.14 2006/07/16 05:42:57 vapier Exp $
14 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
entrance-9999.ebuild:
diff --git a/x11-misc/entrance/entrance-0.9.0.007.ebuild b/x11-misc/entrance/entrance-0.9.0.007.ebuild
new file mode 100644
index 000000000000..4e8c125c9573
--- /dev/null
+++ b/x11-misc/entrance/entrance-0.9.0.007.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/entrance/entrance-0.9.0.007.ebuild,v 1.1 2006/07/16 05:42:57 vapier Exp $
+
+inherit enlightenment eutils
+
+DESCRIPTION="next generation of Elogin, a login/display manager for X"
+HOMEPAGE="http://xcomputerman.com/pages/entrance.html"
+SRC_URI="${SRC_URI}
+ mirror://gentoo/extraicons-1.tar.bz2
+ http://wh0rd.de/gentoo/distfiles/extraicons-1.tar.bz2"
+
+IUSE="pam"
+
+RDEPEND="|| ( x11-libs/libXau virtual/x11 )
+ pam? ( sys-libs/pam )
+ >=dev-db/edb-1.0.5
+ >=x11-libs/evas-0.9.9
+ >=x11-libs/ecore-0.9.9
+ >=media-libs/edje-0.5.0
+ >=x11-libs/esmart-0.9.0"
+
+src_compile() {
+ if use pam ; then
+ export MY_ECONF="--with-auth-mode=pam"
+ else
+ export MY_ECONF="--with-auth-mode=shadow"
+ fi
+ enlightenment_src_compile
+}
+
+src_install() {
+ enlightenment_src_install
+ rm -rf ${D}/etc/init.d
+ insinto /usr/share/entrance/images/sessions
+ doins ${WORKDIR}/extraicons/*
+ exeinto /usr/share/entrance
+ doexe data/config/build_config.sh
+
+ cd /etc/X11/Sessions
+ local edb="${D}/etc/entrance_config.db"
+ local count="`edb_ed ${edb} get /entrance/session/count int`"
+ local datadir="${D}/usr/share/entrance/images/sessions"
+ local icon=""
+ while [ ${count} -ge 0 ] ; do
+ edb_ed ${edb} del /entrance/session/${count}/icon
+ edb_ed ${edb} del /entrance/session/${count}/session
+ edb_ed ${edb} del /entrance/session/${count}/title
+ count=$((${count} - 1))
+ done
+ count=0
+ for s in default * failsafe ; do
+ [ "${s}" == "Xsession" ] && continue
+ icon="`find ${datadir} -iname ${s}.png -printf %f`"
+ if [ -z "${icon}" ] ; then
+ edb_ed ${edb} add /entrance/session/${count}/icon str default.png
+ else
+ edb_ed ${edb} add /entrance/session/${count}/icon str ${icon}
+ fi
+ edb_ed ${edb} add /entrance/session/${count}/session str ${s}
+ edb_ed ${edb} add /entrance/session/${count}/title str ${s}
+ count=$((${count} + 1))
+ done
+ edb_ed ${edb} add /entrance/session/count int ${count}
+}
diff --git a/x11-misc/entrance/entrance-9999.ebuild b/x11-misc/entrance/entrance-9999.ebuild
index ae4079b72a56..dd2ad08558fe 100644
--- a/x11-misc/entrance/entrance-9999.ebuild
+++ b/x11-misc/entrance/entrance-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/entrance/entrance-9999.ebuild,v 1.6 2005/12/14 04:24:02 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/entrance/entrance-9999.ebuild,v 1.7 2006/07/16 05:42:57 vapier Exp $
inherit enlightenment eutils
diff --git a/x11-misc/entrance/files/digest-entrance-0.9.0.007 b/x11-misc/entrance/files/digest-entrance-0.9.0.007
new file mode 100644
index 000000000000..e704c49ca20c
--- /dev/null
+++ b/x11-misc/entrance/files/digest-entrance-0.9.0.007
@@ -0,0 +1,6 @@
+MD5 b789d09fa76e76a6466a786f0628d0ff entrance-0.9.0.007.tar.gz 15942913
+RMD160 0978a9cb5792eaf4cb5f89c98b5c7b463654a356 entrance-0.9.0.007.tar.gz 15942913
+SHA256 789846f0a3df54b03a07cd117ee59b53f63a8677662cb2ff754a9be94032ec44 entrance-0.9.0.007.tar.gz 15942913
+MD5 b1d2a452028c3a09443d84968e24144c extraicons-1.tar.bz2 16770
+RMD160 6c608c53d4fb9475d88a5c475e4a57d7e1a9e71f extraicons-1.tar.bz2 16770
+SHA256 eae4ea74efa3e4a1ca43395fb15826a6f41a066cf9b0095f269000b62d393b38 extraicons-1.tar.bz2 16770
diff --git a/x11-misc/entrance/files/digest-entrance-9999 b/x11-misc/entrance/files/digest-entrance-9999
index 8cf3b1b334a4..c4594cb3adb8 100644
--- a/x11-misc/entrance/files/digest-entrance-9999
+++ b/x11-misc/entrance/files/digest-entrance-9999
@@ -1 +1,3 @@
MD5 b1d2a452028c3a09443d84968e24144c extraicons-1.tar.bz2 16770
+RMD160 6c608c53d4fb9475d88a5c475e4a57d7e1a9e71f extraicons-1.tar.bz2 16770
+SHA256 eae4ea74efa3e4a1ca43395fb15826a6f41a066cf9b0095f269000b62d393b38 extraicons-1.tar.bz2 16770