summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-09-19 16:32:51 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-09-19 16:32:51 +0000
commit5df10574d491fa5e202c1a47f593baccae098b79 (patch)
treeaa984378aaa7f4fc8e97ddc807bd39be9c0c4f8f
parentAdd support for zeroconf. (diff)
downloadgentoo-2-5df10574d491fa5e202c1a47f593baccae098b79.tar.gz
gentoo-2-5df10574d491fa5e202c1a47f593baccae098b79.tar.bz2
gentoo-2-5df10574d491fa5e202c1a47f593baccae098b79.zip
Add support for the Sametime protocol.
(Portage version: 2.0.51.22-r2)
-rw-r--r--kde-base/kopete/ChangeLog5
-rw-r--r--kde-base/kopete/kopete-3.5_alpha1.ebuild19
2 files changed, 15 insertions, 9 deletions
diff --git a/kde-base/kopete/ChangeLog b/kde-base/kopete/ChangeLog
index 90e4ff369c9c..a738c25ae800 100644
--- a/kde-base/kopete/ChangeLog
+++ b/kde-base/kopete/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/kopete
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.23 2005/09/07 12:29:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.24 2005/09/19 16:32:51 greg_g Exp $
+
+ 19 Sep 2005; Gregorio Guidi <greg_g@gentoo.org> kopete-3.5_alpha1.ebuild:
+ Add support for the Sametime protocol.
*kopete-3.5_alpha1 (07 Sep 2005)
diff --git a/kde-base/kopete/kopete-3.5_alpha1.ebuild b/kde-base/kopete/kopete-3.5_alpha1.ebuild
index 1965047ec839..5b046ca62f21 100644
--- a/kde-base/kopete/kopete-3.5_alpha1.ebuild
+++ b/kde-base/kopete/kopete-3.5_alpha1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-3.5_alpha1.ebuild,v 1.1 2005/09/07 12:29:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-3.5_alpha1.ebuild,v 1.2 2005/09/19 16:32:51 greg_g Exp $
KMNAME=kdenetwork
MAXKDEVER=$PV
@@ -9,18 +9,21 @@ inherit kde-meta eutils
DESCRIPTION="KDE multi-protocol IM client"
KEYWORDS="~amd64"
-IUSE="ssl xmms"
+IUSE="sametime ssl xmms"
DEPEND="dev-libs/libxslt
dev-libs/libxml2
+ sametime? ( >=net-libs/meanwhile-0.4.2 )
xmms? ( media-sound/xmms )"
RDEPEND="$DEPEND
ssl? ( app-crypt/qca-tls )"
-# External libgadu support - doesn't work, kopete requires a specific development snapshot of libgadu.
-# Maybe we can enable it in the future.
-#PATCHES="$PATCHES $FILESDIR/configure-fix-kdenetwork-gadu.patch"
-#myconf="$myconf --with-external-libgadu"
+src_compile() {
+ # External libgadu support - doesn't work, kopete requires a specific development snapshot of libgadu.
+ # Maybe we can enable it in the future.
+ # The nowlistening plugin has xmms support.
+ local myconf="$(use_enable sametime sametime-plugin)
+ $(use_with xmms) --without-external-libgadu"
-# The nowlistening plugin has xmms support
-myconf="$myconf $(use_with xmms)"
+ kde-meta_src_compile
+}