summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-20 06:25:57 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-20 06:25:57 +0000
commit5597c69523492d5a77787910d4e8e2d13685ec62 (patch)
tree1e2ba670a677e4def0a0c8006980633f821593b0
parentInitial commit (ebuild written by me), needed for xsd and the required librar... (diff)
downloadgentoo-2-5597c69523492d5a77787910d4e8e2d13685ec62.tar.gz
gentoo-2-5597c69523492d5a77787910d4e8e2d13685ec62.tar.bz2
gentoo-2-5597c69523492d5a77787910d4e8e2d13685ec62.zip
Initital addition
(Portage version: 2.2_rc98/cvs/Linux x86_64)
-rw-r--r--sci-chemistry/prodecomp/ChangeLog10
-rw-r--r--sci-chemistry/prodecomp/metadata.xml18
-rw-r--r--sci-chemistry/prodecomp/prodecomp-3.0.ebuild52
3 files changed, 80 insertions, 0 deletions
diff --git a/sci-chemistry/prodecomp/ChangeLog b/sci-chemistry/prodecomp/ChangeLog
new file mode 100644
index 000000000000..9add7c62a48c
--- /dev/null
+++ b/sci-chemistry/prodecomp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/prodecomp
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/prodecomp/ChangeLog,v 1.1 2010/10/20 06:25:57 jlec Exp $
+
+*prodecomp-3.0 (20 Oct 2010)
+
+ 20 Oct 2010; Justin Lecher <jlec@gentoo.org> +prodecomp-3.0.ebuild,
+ +metadata.xml:
+ Initital addition
+
diff --git a/sci-chemistry/prodecomp/metadata.xml b/sci-chemistry/prodecomp/metadata.xml
new file mode 100644
index 000000000000..f42aa732a3b8
--- /dev/null
+++ b/sci-chemistry/prodecomp/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+<longdescription>
+ PRODECOMP (PROjection DECOMPosition) is a software tool for
+ decomposition of 2D projections of high-dimensional NMR spectra to a set
+ of components (defined in turn by one-dimensional "shapes").
+ Simultaneous analysis of projections from one or several
+ high-dimensional experiments provide unambigous chemical shifts for
+ large spin systems. The latter can be used for backbone and side-chain
+ assignments as well as structural studies of proteins
+ (Malmodin and Billeter 2005; 2006; Staykova et al. 2008a,b).
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/prodecomp/prodecomp-3.0.ebuild b/sci-chemistry/prodecomp/prodecomp-3.0.ebuild
new file mode 100644
index 000000000000..3212131e8bf9
--- /dev/null
+++ b/sci-chemistry/prodecomp/prodecomp-3.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/prodecomp/prodecomp-3.0.ebuild,v 1.1 2010/10/20 06:25:57 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="tk"
+
+inherit python
+
+DESCRIPTION="Decomposition-based analysis of NMR projections"
+HOMEPAGE="http://www.lundberg.gu.se/nmr/software.php?program=PRODECOMP"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE="examples"
+
+RDEPEND="sci-libs/scipy"
+DEPEND=""
+
+S="${WORKDIR}"/NMRProjAnalys
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r ExampleData Results || die
+ fi
+
+ insinto /usr/share/doc/${PF}
+ doins ProjTools/Manual.pdf || die
+ rm -rf ProjTools/Manual.pdf ProdecompOutput || die
+
+ insinto $(python_get_sitedir)
+ doins -r ProjTools || die
+ mv "${ED}"/$(python_get_sitedir)/{ProjTools,${PN}} || die
+
+ cat >> "${T}"/${PN} <<- EOF
+ #!/bin/bash
+ $(PYTHON) -O "${EPREFIX}"/$(python_get_sitedir)/${PN}/ProjAnalys.py $@
+ EOF
+ dobin "${T}"/${PN} || die
+
+ dosym ../../../../share/doc/${PF}/Manual.pdf $(python_get_sitedir)/${PN}/Manual.pdf
+}