summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-26 02:40:14 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-26 02:40:14 +0000
commit542909efcf7a31579011bbfdce0e830eea82f8b6 (patch)
treea54bf4d5ffa32e980b57f3f60170fe27acc06b5c
parentVersion bump (diff)
downloadgentoo-2-542909efcf7a31579011bbfdce0e830eea82f8b6.tar.gz
gentoo-2-542909efcf7a31579011bbfdce0e830eea82f8b6.tar.bz2
gentoo-2-542909efcf7a31579011bbfdce0e830eea82f8b6.zip
version bump
-rw-r--r--games-emulation/fakenes/ChangeLog7
-rw-r--r--games-emulation/fakenes/fakenes-0.3.0.ebuild41
-rw-r--r--games-emulation/fakenes/files/0.3.0-allegro.patch55
-rw-r--r--games-emulation/fakenes/files/digest-fakenes-0.3.01
4 files changed, 103 insertions, 1 deletions
diff --git a/games-emulation/fakenes/ChangeLog b/games-emulation/fakenes/ChangeLog
index 50661612ce83..cc23d20efc06 100644
--- a/games-emulation/fakenes/ChangeLog
+++ b/games-emulation/fakenes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/fakenes
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fakenes/ChangeLog,v 1.2 2003/09/10 15:59:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fakenes/ChangeLog,v 1.3 2003/09/26 02:40:14 vapier Exp $
+
+*fakenes-0.3.0 (25 Sep 2003)
+
+ 25 Sep 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bumpage. ~x86 since it needs latest allegro.
*fakenes-0.1.5 (13 Jul 2003)
diff --git a/games-emulation/fakenes/fakenes-0.3.0.ebuild b/games-emulation/fakenes/fakenes-0.3.0.ebuild
new file mode 100644
index 000000000000..fb29af1a0c44
--- /dev/null
+++ b/games-emulation/fakenes/fakenes-0.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fakenes/fakenes-0.3.0.ebuild,v 1.1 2003/09/26 02:40:14 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="portable, Open Source NES emulator which is written mostly in C"
+HOMEPAGE="http://fakenes.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fakenes/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="zlib fbcon svgalib"
+
+DEPEND=">=media-libs/allegro-4.1
+ zlib? ( sys-libs/zlib )
+ dev-games/hawknl
+ x86? ( dev-lang/nasm )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ chmod a+x configure
+ epatch ${FILESDIR}/${PV}-allegro.patch
+ [ ! `use fbcon` ] && sed -i '/sedfbme/s:.*::' src/gui.c src/include/gui/menus.h
+ [ ! `use svgalib` ] && sed -i '/sedsvgalibme/s:.*::' src/gui.c src/include/gui/menus.h
+}
+
+src_compile() {
+ egamesconf `use_with zlib` || die
+ emake || die
+}
+
+src_install() {
+ dogamesbin src/fakenes
+ insinto ${GAMES_DATADIR}/${PN}
+ doins src/support/fakenes.{dat,ico,rc}
+ dodoc CHANGES README SOURCE SUPPORT
+ prepgamesdirs
+}
diff --git a/games-emulation/fakenes/files/0.3.0-allegro.patch b/games-emulation/fakenes/files/0.3.0-allegro.patch
new file mode 100644
index 000000000000..646fe5a6f43c
--- /dev/null
+++ b/games-emulation/fakenes/files/0.3.0-allegro.patch
@@ -0,0 +1,55 @@
+--- src/gui.c.orig 2003-09-25 22:29:25.830731224 -0400
++++ src/gui.c 2003-09-25 22:30:29.575040616 -0400
+@@ -716,9 +716,9 @@
+
+ TOGGLE_MENU (options_video_driver_linux_menu, 4, (gfx_driver -> id == GFX_VBEAF));
+
+- TOGGLE_MENU (options_video_driver_linux_menu, 6, (gfx_driver -> id == GFX_FBCON));
++ TOGGLE_MENU (options_video_driver_linux_menu, 6, (gfx_driver -> id == GFX_FBCON)); //sedfbme
+
+- TOGGLE_MENU (options_video_driver_linux_menu, 8, (gfx_driver -> id == GFX_SVGALIB));
++ TOGGLE_MENU (options_video_driver_linux_menu, 8, (gfx_driver -> id == GFX_SVGALIB)); //sedsvgalibme
+
+ #endif
+
+@@ -3238,9 +3238,9 @@
+
+ DRIVER_MENU_HANDLER (linux, vesa_vbe_af, GFX_VBEAF)
+
+-DRIVER_MENU_HANDLER (linux, framebuffer, GFX_FBCON)
++DRIVER_MENU_HANDLER (linux, framebuffer, GFX_FBCON) //sedfbme
+
+-DRIVER_MENU_HANDLER (linux, svgalib, GFX_SVGALIB)
++DRIVER_MENU_HANDLER (linux, svgalib, GFX_SVGALIB) //sedsvgalibme
+
+ #endif
+
+--- src/include/gui/menus.h.orig 2003-09-25 22:29:33.099626184 -0400
++++ src/include/gui/menus.h 2003-09-25 22:31:12.231555840 -0400
+@@ -593,9 +593,9 @@
+
+ static int options_video_driver_linux_menu_vesa_vbe_af (void);
+
+-static int options_video_driver_linux_menu_framebuffer (void);
++static int options_video_driver_linux_menu_framebuffer (void); //sedfbme
+
+-static int options_video_driver_linux_menu_svgalib (void);
++static int options_video_driver_linux_menu_svgalib (void); //sedsvgalibme
+
+
+ static MENU options_video_driver_linux_menu [] =
+@@ -606,10 +606,10 @@
+ { "", NIL, NIL, 0, NIL },
+ { "VESA VBE/&AF", options_video_driver_linux_menu_vesa_vbe_af, NIL, 0, NIL },
+ { "", NIL, NIL, 0, NIL },
+- { "&Framebuffer", options_video_driver_linux_menu_framebuffer, NIL, 0, NIL },
+- { "", NIL, NIL, 0, NIL },
+- { "&SVGAlib", options_video_driver_linux_menu_svgalib, NIL, 0, NIL },
+- { NIL, NIL, NIL, 0, NIL }
++ { "&Framebuffer", options_video_driver_linux_menu_framebuffer, NIL, 0, NIL }, //sedfbme
++ { "", NIL, NIL, 0, NIL }, //sedfbme
++ { "&SVGAlib", options_video_driver_linux_menu_svgalib, NIL, 0, NIL }, //sedsvgalibme
++ { NIL, NIL, NIL, 0, NIL } //sedsvgalibme
+ };
+
+ #else
diff --git a/games-emulation/fakenes/files/digest-fakenes-0.3.0 b/games-emulation/fakenes/files/digest-fakenes-0.3.0
new file mode 100644
index 000000000000..d95cdb61fdf8
--- /dev/null
+++ b/games-emulation/fakenes/files/digest-fakenes-0.3.0
@@ -0,0 +1 @@
+MD5 91f8e09649cb2c4e3b911e5a349acb26 fakenes-0.3.0.tar.bz2 157807