summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-10 02:13:15 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-10 02:13:15 +0000
commit4c2c7ddc4befffd6fe85351fef50663a19d4ac9c (patch)
tree51487643c72ddda7b29d2de116a6ae47b6b1cfb5
parentRestore src_unpack(); unpacker.eclass does not automatically detect .sh exten... (diff)
downloadgentoo-2-4c2c7ddc4befffd6fe85351fef50663a19d4ac9c.tar.gz
gentoo-2-4c2c7ddc4befffd6fe85351fef50663a19d4ac9c.tar.bz2
gentoo-2-4c2c7ddc4befffd6fe85351fef50663a19d4ac9c.zip
Restore src_unpack(); unpacker.eclass does not automatically detect .sh extension as a makeself archive (bug #415013, thanks to Alan Smithee).
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
-rw-r--r--app-emulation/crossover-office-bin/ChangeLog8
-rw-r--r--app-emulation/crossover-office-bin/crossover-office-bin-6.0.0.ebuild6
-rw-r--r--app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild6
-rw-r--r--app-emulation/crossover-office-bin/crossover-office-bin-6.1.0.ebuild6
-rw-r--r--app-emulation/crossover-office-bin/crossover-office-bin-6.2.0.ebuild6
5 files changed, 27 insertions, 5 deletions
diff --git a/app-emulation/crossover-office-bin/ChangeLog b/app-emulation/crossover-office-bin/ChangeLog
index 11a67363f3a8..45ae4aa764f0 100644
--- a/app-emulation/crossover-office-bin/ChangeLog
+++ b/app-emulation/crossover-office-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/crossover-office-bin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/ChangeLog,v 1.18 2012/02/05 05:27:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/ChangeLog,v 1.19 2012/05/10 02:13:15 tetromino Exp $
+
+ 10 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ crossover-office-bin-6.0.0.ebuild, crossover-office-bin-6.0.1.ebuild,
+ crossover-office-bin-6.1.0.ebuild, crossover-office-bin-6.2.0.ebuild:
+ Restore src_unpack(); unpacker.eclass does not automatically detect .sh
+ extension as a makeself archive (bug #415013, thanks to Alan Smithee).
05 Feb 2012; Mike Frysinger <vapier@gentoo.org>
crossover-office-bin-6.0.0.ebuild, crossover-office-bin-6.0.1.ebuild,
diff --git a/app-emulation/crossover-office-bin/crossover-office-bin-6.0.0.ebuild b/app-emulation/crossover-office-bin/crossover-office-bin-6.0.0.ebuild
index f3bbd8d45661..1a390bc75716 100644
--- a/app-emulation/crossover-office-bin/crossover-office-bin-6.0.0.ebuild
+++ b/app-emulation/crossover-office-bin/crossover-office-bin-6.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/crossover-office-bin-6.0.0.ebuild,v 1.5 2012/02/05 05:27:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/crossover-office-bin-6.0.0.ebuild,v 1.6 2012/05/10 02:13:15 tetromino Exp $
inherit unpacker
@@ -31,6 +31,10 @@ pkg_nofetch() {
einfo "and place ${A} in ${DISTDIR}"
}
+src_unpack() {
+ unpack_makeself # needed due to .sh extension; #415013
+}
+
src_install() {
dodir /opt/cxoffice
cp -r * "${D}"/opt/cxoffice || die "cp failed"
diff --git a/app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild b/app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild
index d456314c6a1d..4a192b992700 100644
--- a/app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild
+++ b/app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild,v 1.5 2012/02/05 05:27:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild,v 1.6 2012/05/10 02:13:15 tetromino Exp $
inherit unpacker
@@ -31,6 +31,10 @@ pkg_nofetch() {
einfo "and place ${A} in ${DISTDIR}"
}
+src_unpack() {
+ unpack_makeself # needed due to .sh extension; #415013
+}
+
src_install() {
dodir /opt/cxoffice
cp -r * "${D}"/opt/cxoffice || die "cp failed"
diff --git a/app-emulation/crossover-office-bin/crossover-office-bin-6.1.0.ebuild b/app-emulation/crossover-office-bin/crossover-office-bin-6.1.0.ebuild
index 7724b63650c9..ac6511b0d287 100644
--- a/app-emulation/crossover-office-bin/crossover-office-bin-6.1.0.ebuild
+++ b/app-emulation/crossover-office-bin/crossover-office-bin-6.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/crossover-office-bin-6.1.0.ebuild,v 1.4 2012/02/05 05:27:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/crossover-office-bin-6.1.0.ebuild,v 1.5 2012/05/10 02:13:15 tetromino Exp $
inherit unpacker
@@ -31,6 +31,10 @@ pkg_nofetch() {
einfo "and place ${A} in ${DISTDIR}"
}
+src_unpack() {
+ unpack_makeself # needed due to .sh extension; #415013
+}
+
src_install() {
dodir /opt/cxoffice
cp -r * "${D}"/opt/cxoffice || die "cp failed"
diff --git a/app-emulation/crossover-office-bin/crossover-office-bin-6.2.0.ebuild b/app-emulation/crossover-office-bin/crossover-office-bin-6.2.0.ebuild
index a006ccfde4ca..7eebd2ce12f1 100644
--- a/app-emulation/crossover-office-bin/crossover-office-bin-6.2.0.ebuild
+++ b/app-emulation/crossover-office-bin/crossover-office-bin-6.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/crossover-office-bin-6.2.0.ebuild,v 1.5 2012/02/05 05:27:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/crossover-office-bin-6.2.0.ebuild,v 1.6 2012/05/10 02:13:15 tetromino Exp $
inherit unpacker
@@ -31,6 +31,10 @@ pkg_nofetch() {
elog "and place ${A} in ${DISTDIR}"
}
+src_unpack() {
+ unpack_makeself # needed due to .sh extension; #415013
+}
+
src_install() {
dodir /opt/cxoffice
cp -r * "${D}"/opt/cxoffice || die "cp failed"