summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-11-11 21:13:55 +0000
committerJustin Lecher <jlec@gentoo.org>2014-11-11 21:13:55 +0000
commit4c24dbbb0613c17eb0a87f66658129cd73253228 (patch)
treed1b05d8427bff69147be02d156ba1178f1ea0015
parentversion bump in lockstep with fox (diff)
downloadgentoo-2-4c24dbbb0613c17eb0a87f66658129cd73253228.tar.gz
gentoo-2-4c24dbbb0613c17eb0a87f66658129cd73253228.tar.bz2
gentoo-2-4c24dbbb0613c17eb0a87f66658129cd73253228.zip
net-libs/libupnp: Use Suse patch to fo compilation problem with latest gcc/glibc, #526562
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
-rw-r--r--net-libs/libupnp/ChangeLog8
-rw-r--r--net-libs/libupnp/files/libupnp-1.6.18-suse.patch132
-rw-r--r--net-libs/libupnp/libupnp-1.6.18-r1.ebuild52
-rw-r--r--net-libs/libupnp/metadata.xml18
4 files changed, 200 insertions, 10 deletions
diff --git a/net-libs/libupnp/ChangeLog b/net-libs/libupnp/ChangeLog
index 86e2a07facf5..d640b249d444 100644
--- a/net-libs/libupnp/ChangeLog
+++ b/net-libs/libupnp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libupnp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libupnp/ChangeLog,v 1.51 2014/03/23 12:18:17 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libupnp/ChangeLog,v 1.52 2014/11/11 21:13:55 jlec Exp $
+
+*libupnp-1.6.18-r1 (11 Nov 2014)
+
+ 11 Nov 2014; Justin Lecher <jlec@gentoo.org> +libupnp-1.6.18-r1.ebuild,
+ +files/libupnp-1.6.18-suse.patch, metadata.xml:
+ Use Suse patch to fo compilation problem with latest gcc/glibc, #526562
23 Mar 2014; Mikle Kolyada <zlogene@gentoo.org> -libupnp-1.6.17.ebuild:
Drop insecure version
diff --git a/net-libs/libupnp/files/libupnp-1.6.18-suse.patch b/net-libs/libupnp/files/libupnp-1.6.18-suse.patch
new file mode 100644
index 000000000000..2e91990c0243
--- /dev/null
+++ b/net-libs/libupnp/files/libupnp-1.6.18-suse.patch
@@ -0,0 +1,132 @@
+--- configure.ac 2013-01-29 16:39:56.000000000 +0100
++++ configure.ac 2013-02-17 10:40:53.680021913 +0100
+@@ -7,9 +7,9 @@
+ # (C) Copyright 2005-2007 Rémi Turboult <r3mi@users.sourceforge.net>
+ #
+
+-AC_PREREQ(2.60)
++AC_PREREQ([2.60])
+
+-AC_INIT([libupnp], [1.6.18], [mroberto@users.sourceforge.net])
++AC_INIT([libupnp],[1.6.18],[mroberto@users.sourceforge.net])
+ dnl ############################################################################
+ dnl # *Independently* of the above libupnp package version, the libtool version
+ dnl # of the 3 libraries need to be updated whenever there is a change released:
+@@ -366,7 +366,6 @@
+ # installed libraries.
+ #
+ AC_CONFIG_HEADERS([autoconfig.h upnp/inc/upnpconfig.h])
+-#AC_SYS_LARGEFILE_SENSITIVE
+
+ AC_REVISION([$Revision: 1.1 $])
+
+@@ -506,9 +505,12 @@
+ #
+ # Checks for programs
+ #
+-AC_PROG_CC
++AC_PROG_CC_STDC
++AC_USE_SYSTEM_EXTENSIONS
++AC_SYS_LARGEFILE
+ AM_PROG_CC_C_O
+-AC_PROG_LIBTOOL
++m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
++LT_INIT
+ AC_PROG_INSTALL
+ AC_PROG_MAKE_SET
+ AC_PROG_EGREP
+@@ -532,9 +534,7 @@
+ #:
+ # Use -O0 in debug so that variables do not get optimized out
+ AX_CFLAGS_GCC_OPTION([-O0, -g])
+- else
+- # add optimise for size
+- AX_CFLAGS_GCC_OPTION([-Os])
++
+ fi
+ ;;
+ esac
+@@ -548,8 +548,7 @@
+ #
+ AC_TYPE_SIZE_T
+ AC_TYPE_OFF_T
+-AC_DEFINE([_LARGE_FILE_SOURCE], [], [Large files support])
+-AC_DEFINE([_FILE_OFFSET_BITS], [64], [File Offset size])
++
+
+
+ #
+--- ixml/Makefile.am.orig
++++ ixml/Makefile.am
+@@ -7,7 +7,7 @@
+
+ SUBDIRS = doc
+
+-AM_CPPFLAGS = -I$(srcdir)/inc -I$(srcdir)/src/inc
++AM_CPPFLAGS = -include $(top_builddir)/autoconfig.h -I$(srcdir)/inc -I$(srcdir)/src/inc
+ AM_CFLAGS =
+
+ LDADD = libixml.la
+--- threadutil/Makefile.am.orig
++++ threadutil/Makefile.am
+@@ -4,7 +4,7 @@
+ # (C) Copyright 2005 Remi Turboult <r3mi@users.sourceforge.net>
+ #
+
+-AM_CPPFLAGS = -I$(srcdir)/inc -I$(srcdir)/src/inc
++AM_CPPFLAGS = -include $(top_builddir)/autoconfig.h -I$(srcdir)/inc -I$(srcdir)/src/inc
+
+ if ENABLE_DEBUG
+ AM_CPPFLAGS += -DDEBUG -DSTATS
+--- upnp/src/api/UpnpString.c.orig
++++ upnp/src/api/UpnpString.c
+@@ -28,38 +28,6 @@
+ /* Other systems have strncasecmp */
+ #endif
+
+-#ifndef UPNP_USE_MSVCPP
+- /* VC has strnlen which is already included but with (potentially) different linkage */
+- /* strnlen() is a GNU extension. */
+- #if HAVE_STRNLEN
+- extern size_t strnlen(const char *s, size_t maxlen);
+- #else /* HAVE_STRNLEN */
+- static size_t strnlen(const char *s, size_t n)
+- {
+- const char *p = (const char *)memchr(s, 0, n);
+- return p ? p - s : n;
+- }
+- #endif /* HAVE_STRNLEN */
+-#endif /* WIN32 */
+-
+-/* strndup() is a GNU extension. */
+-#if HAVE_STRNDUP && !defined(WIN32)
+- extern char *strndup(__const char *__string, size_t __n);
+-#else /* HAVE_STRNDUP && !defined(WIN32) */
+- static char *strndup(const char *__string, size_t __n)
+- {
+- size_t strsize = strnlen(__string, __n);
+- char *newstr = (char *)malloc(strsize + 1);
+- if (newstr == NULL)
+- return NULL;
+-
+- strncpy(newstr, __string, strsize);
+- newstr[strsize] = 0;
+-
+- return newstr;
+- }
+-#endif /* HAVE_STRNDUP && !defined(WIN32) */
+-
+ /*!
+ * \brief Internal implementation of the class UpnpString.
+ *
+--- upnp/Makefile.am.orig
++++ upnp/Makefile.am
+@@ -6,7 +6,7 @@
+
+ SUBDIRS = doc . sample
+
+-AM_CPPFLAGS = \
++AM_CPPFLAGS = -include $(top_builddir)/autoconfig.h \
+ -I$(srcdir)/inc \
+ -I$(top_srcdir)/threadutil/inc \
+ -I$(top_srcdir)/ixml/inc
diff --git a/net-libs/libupnp/libupnp-1.6.18-r1.ebuild b/net-libs/libupnp/libupnp-1.6.18-r1.ebuild
new file mode 100644
index 000000000000..8361cbad1c08
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.6.18-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libupnp/libupnp-1.6.18-r1.ebuild,v 1.1 2014/11/11 21:13:55 jlec Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pupnp/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux"
+IUSE="debug doc ipv6 static-libs"
+
+DOCS="NEWS README ChangeLog"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-suse.patch
+
+ # fix tests
+ chmod +x ixml/test/test_document.sh || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use x86-fbsd && append-flags -O1
+ # w/o docdir to avoid sandbox violations
+ econf \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable static-libs static) \
+ $(use_with doc documentation "${EPREFIX}/usr/share/doc/${PF}")
+}
+
+src_install () {
+ default
+ dobin upnp/sample/.libs/tv_{combo,ctrlpt,device}
+ use static-libs || prune_libtool_files
+}
+
+pkg_postinst() {
+ ewarn "Please remember to run revdep-rebuild when upgrading"
+ ewarn "from libupnp 1.4.x to libupnp 1.6.x , so packages"
+ ewarn "gets linked with the new library."
+ echo ""
+ ewarn "The revdep-rebuild script is part of the"
+ ewarn "app-portage/gentoolkit package."
+}
diff --git a/net-libs/libupnp/metadata.xml b/net-libs/libupnp/metadata.xml
index 9551b35d4bd9..39f3775ddfe6 100644
--- a/net-libs/libupnp/metadata.xml
+++ b/net-libs/libupnp/metadata.xml
@@ -1,13 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>proxy-maintainers</herd>
-<maintainer>
- <email>maq@maqibooy.com</email>
- <name>Marcus Stjärnås</name>
-</maintainer>
-<maintainer>
- <email>gurligebis@gentoo.org</email>
- <name>Bjarke Istrup Pedersen</name>
-</maintainer>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>maq@maqibooy.com</email>
+ <name>Marcus Stjärnås</name>
+ </maintainer>
+ <maintainer>
+ <email>gurligebis@gentoo.org</email>
+ <name>Bjarke Istrup Pedersen</name>
+ </maintainer>
</pkgmetadata>