summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-11-07 17:49:55 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-11-07 17:49:55 +0000
commit4ba98a83071c399a799308024676ea07acbae4fe (patch)
tree8fd10251fa6f26c7936710a1927c1839a9a91fe8
parentppc/ppc64 stable wrt #384593 (diff)
downloadgentoo-2-4ba98a83071c399a799308024676ea07acbae4fe.tar.gz
gentoo-2-4ba98a83071c399a799308024676ea07acbae4fe.tar.bz2
gentoo-2-4ba98a83071c399a799308024676ea07acbae4fe.zip
Drop old one. And fix minor syntax issues
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
-rw-r--r--app-emulation/xen/ChangeLog6
-rw-r--r--app-emulation/xen/xen-3.4.2-r3.ebuild109
-rw-r--r--app-emulation/xen/xen-4.1.1-r2.ebuild6
3 files changed, 8 insertions, 113 deletions
diff --git a/app-emulation/xen/ChangeLog b/app-emulation/xen/ChangeLog
index 4977f2f6319b..990e8f7f921d 100644
--- a/app-emulation/xen/ChangeLog
+++ b/app-emulation/xen/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/xen
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.92 2011/11/07 17:34:55 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.93 2011/11/07 17:49:55 alexxy Exp $
+
+ 07 Nov 2011; Alexey Shvetsov <alexxy@gentoo.org> -xen-3.4.2-r3.ebuild,
+ xen-4.1.1-r2.ebuild:
+ Drop old one. And fix minor syntax issues
07 Nov 2011; Alexey Shvetsov <alexxy@gentoo.org> xen-4.1.1-r2.ebuild,
xen-4.1.2.ebuild:
diff --git a/app-emulation/xen/xen-3.4.2-r3.ebuild b/app-emulation/xen/xen-3.4.2-r3.ebuild
deleted file mode 100644
index 8b80a9eb5733..000000000000
--- a/app-emulation/xen/xen-3.4.2-r3.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.4.2-r3.ebuild,v 1.3 2011/09/29 14:21:09 tomka Exp $
-
-EAPI=2
-
-inherit mount-boot flag-o-matic toolchain-funcs base
-
-DESCRIPTION="The Xen virtual machine monitor"
-HOMEPAGE="http://xen.org/"
-SRC_URI="http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug custom-cflags pae acm flask xsm"
-
-RDEPEND="|| ( sys-boot/grub
- sys-boot/grub-static )
- >=sys-kernel/xen-sources-2.6.18"
-PDEPEND="~app-emulation/xen-tools-${PV}"
-PATCHES=(
- "${FILESDIR}/"${PN}-3.3.0-unexported-target-fix.patch
- "${FILESDIR}/"${P}-dump_registers-watchdog-fix.patch
- "${FILESDIR}/"${P}-no-DMA.patch
- "${FILESDIR}/"${P}-werror-idiocy.patch
-)
-
-RESTRICT="test"
-
-# Approved by QA team in bug #144032
-QA_WX_LOAD="boot/xen-syms-${PV}"
-
-pkg_setup() {
- if [[ -z ${XEN_TARGET_ARCH} ]]; then
- if use x86 && use amd64; then
- die "Confusion! Both x86 and amd64 are set in your use flags!"
- elif use x86; then
- export XEN_TARGET_ARCH="x86_32"
- elif use amd64; then
- export XEN_TARGET_ARCH="x86_64"
- else
- die "Unsupported architecture!"
- fi
- fi
-
- if use xsm ; then
- export "XSM_ENABLE=y"
- use acm && export "ACM_SECURITY=y"
- if use flask ; then
- ! use acm && export "FLASK_ENABLE=y"
- use acm && ewarn "Both acm and flask XSM specified, defaulting to acm."
- fi
- elif use acm || use flask ; then
- ewarn "acm and flask require USE=xsm to be set, dropping use flags"
- fi
-}
-
-src_prepare() {
- base_src_prepare
-
- # if the user *really* wants to use their own custom-cflags, let them
- if use custom-cflags; then
- einfo "User wants their own CFLAGS - removing defaults"
- # try and remove all the default custom-cflags
- find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk -exec sed \
- -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
- -e 's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
- -e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
- -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
- -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
- -i {} \;
- fi
-}
-
-src_compile() {
- local myopt
- use debug && myopt="${myopt} debug=y"
- use pae && myopt="${myopt} pae=y"
-
- if use custom-cflags; then
- filter-flags -fPIE -fstack-protector
- replace-flags -O3 -O2
- else
- unset CFLAGS
- fi
-
- # Send raw LDFLAGS so that --as-needed works
- emake CC="$(tc-getCC)" LDFLAGS="$(raw-ldflags)" -C xen ${myopt} || die "compile failed"
-}
-
-src_install() {
- local myopt
- use debug && myopt="${myopt} debug=y"
- use pae && myopt="${myopt} pae=y"
-
- emake LDFLAGS="$(raw-ldflags)" DESTDIR="${D}" -C xen ${myopt} install || die "install failed"
-}
-
-pkg_postinst() {
- elog "Official Xen Guide and the unoffical wiki page:"
- elog " http://www.gentoo.org/doc/en/xen-guide.xml"
- elog " http://en.gentoo-wiki.com/wiki/Xen/"
-
- if use pae; then
- echo
- ewarn "This is a PAE build of Xen. It will *only* boot PAE kernels!"
- fi
-}
diff --git a/app-emulation/xen/xen-4.1.1-r2.ebuild b/app-emulation/xen/xen-4.1.1-r2.ebuild
index 448764292071..30f19805481c 100644
--- a/app-emulation/xen/xen-4.1.1-r2.ebuild
+++ b/app-emulation/xen/xen-4.1.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-4.1.1-r2.ebuild,v 1.5 2011/11/07 17:34:55 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-4.1.1-r2.ebuild,v 1.6 2011/11/07 17:49:55 alexxy Exp $
EAPI="4"
@@ -75,10 +75,10 @@ src_prepare() {
fi
# remove -Werror for gcc-4.6's sake
- find ${S} -name 'Makefile*' -o -name '*.mk' -o -name 'common.make' | \
+ find "${S}" -name 'Makefile*' -o -name '*.mk' -o -name 'common.make' | \
xargs sed -i 's/ *-Werror */ /' || die "failed to remove -Werror"
# not strictly necessary to fix this
- sed -i 's/, "-Werror"//' ${S}/tools/python/setup.py || die "failed to remove -Werror on setup.py"
+ sed -i 's/, "-Werror"//' "${S}/tools/python/setup.py" || die "failed to remove -Werror on setup.py"
# Add sccurity fix bug #379241
epatch "${FILESDIR}/${P}-iommu_sec_fix.patch"