summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-18 21:57:14 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-18 21:57:14 +0000
commit4a607873c78de0b14608650c1ae7e9b1685a4c9d (patch)
tree20a827de1acc439957445f122061968d6a24e35a
parentStable on amd64 per bug #126321 (diff)
downloadgentoo-2-4a607873c78de0b14608650c1ae7e9b1685a4c9d.tar.gz
gentoo-2-4a607873c78de0b14608650c1ae7e9b1685a4c9d.tar.bz2
gentoo-2-4a607873c78de0b14608650c1ae7e9b1685a4c9d.zip
Add patch to respect LDFLAGS.
(Portage version: 2.1_pre6-r3)
-rw-r--r--net-misc/upnp/ChangeLog8
-rw-r--r--net-misc/upnp/files/libupnp-1.2.1a-respectflags.patch39
-rw-r--r--net-misc/upnp/upnp-1.2.1a.ebuild9
3 files changed, 51 insertions, 5 deletions
diff --git a/net-misc/upnp/ChangeLog b/net-misc/upnp/ChangeLog
index ed3e9e137abb..b88c037a428c 100644
--- a/net-misc/upnp/ChangeLog
+++ b/net-misc/upnp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/upnp
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/upnp/ChangeLog,v 1.14 2005/12/14 09:07:15 flameeyes Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/upnp/ChangeLog,v 1.15 2006/03/18 21:57:14 flameeyes Exp $
+
+ 18 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/libupnp-1.2.1a-respectflags.patch, upnp-1.2.1a.ebuild:
+ Add patch to respect LDFLAGS.
14 Dec 2005; Diego Pettenò <flameeyes@gentoo.org>
+files/libupnp-1.2.1a-fbsd.patch, +files/libupnp-1.2.1a-gcc4.patch,
diff --git a/net-misc/upnp/files/libupnp-1.2.1a-respectflags.patch b/net-misc/upnp/files/libupnp-1.2.1a-respectflags.patch
new file mode 100644
index 000000000000..91d74c372335
--- /dev/null
+++ b/net-misc/upnp/files/libupnp-1.2.1a-respectflags.patch
@@ -0,0 +1,39 @@
+Index: libupnp-1.2.1a/ixml/src/Makefile
+===================================================================
+--- libupnp-1.2.1a.orig/ixml/src/Makefile
++++ libupnp-1.2.1a/ixml/src/Makefile
+@@ -95,7 +95,7 @@ endif
+ VERSION=1.2.1
+
+ CFLAGS += -fPIC -c -Wall
+-C2FLAGS = -Wall $(DEFS) -shared -Wl,-soname,$(TARGET_OUTPUT)
++C2FLAGS = -Wall $(DEFS) $(LDFLAGS) -shared -Wl,-soname,$(TARGET_OUTPUT)
+ INCLUDES = -I. -I../inc -Iinc
+
+ ifeq ($(EFENCE),1)
+Index: libupnp-1.2.1a/upnp/src/makefile
+===================================================================
+--- libupnp-1.2.1a.orig/upnp/src/makefile
++++ libupnp-1.2.1a/upnp/src/makefile
+@@ -73,7 +73,7 @@ LIBS+= -lefence
+ endif
+
+ INCLUDES = -I inc -I ../inc -I inc/tools
+-C2FLAGS = -Wall $(DEFS) -shared -Wl,-soname,libupnp.so
++C2FLAGS = -Wall $(DEFS) $(LDFLAGS) -shared -Wl,-soname,libupnp.so
+
+ ifeq ($(DEBUG),1)
+ DBG=DEBUG=1
+Index: libupnp-1.2.1a/threadutil/src/Makefile
+===================================================================
+--- libupnp-1.2.1a.orig/threadutil/src/Makefile
++++ libupnp-1.2.1a/threadutil/src/Makefile
+@@ -84,7 +84,7 @@ endif
+ CXX =$(CROSS_COMPILER)g++
+ CFLAGS += -fPIC -Wall -D_REENTRANT -I../inc
+ INCLUDE =
+-SHAREDFLAGS = -rdynamic -shared -Wl,-soname,
++SHAREDFLAGS = $(LDFLAGS) -rdynamic -shared -Wl,-soname,
+
+ libthreadutil.so_objects = $(OBJ_DIR)FreeList.o \
+ $(OBJ_DIR)LinkedList.o \
diff --git a/net-misc/upnp/upnp-1.2.1a.ebuild b/net-misc/upnp/upnp-1.2.1a.ebuild
index b80b148d5ce4..86f1840b4fd2 100644
--- a/net-misc/upnp/upnp-1.2.1a.ebuild
+++ b/net-misc/upnp/upnp-1.2.1a.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/upnp/upnp-1.2.1a.ebuild,v 1.5 2005/12/14 09:07:15 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/upnp/upnp-1.2.1a.ebuild,v 1.6 2006/03/18 21:57:14 flameeyes Exp $
inherit eutils toolchain-funcs
@@ -15,7 +15,9 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="doc debug"
-DEPEND="sys-fs/e2fsprogs
+RDEPEND="sys-fs/e2fsprogs"
+
+DEPEND="${RDEPEND}
doc? ( app-doc/doc++
app-text/tetex
virtual/ghostscript )"
@@ -28,6 +30,7 @@ src_unpack() {
epatch "${FILESDIR}/${MY_P}-gcc4.patch"
epatch "${FILESDIR}/${MY_P}-fbsd.patch"
+ epatch "${FILESDIR}/${MY_P}-respectflags.patch"
}
src_compile() {