summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-02-14 00:11:00 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-02-14 00:11:00 +0000
commit42ed725f6ba3ebe29fb2419108c5c700c9985e7f (patch)
tree476bd13d87adba7926d620ed60ca5ab444c15d91
parentBump (diff)
downloadgentoo-2-42ed725f6ba3ebe29fb2419108c5c700c9985e7f.tar.gz
gentoo-2-42ed725f6ba3ebe29fb2419108c5c700c9985e7f.tar.bz2
gentoo-2-42ed725f6ba3ebe29fb2419108c5c700c9985e7f.zip
Version bump per bug #294934.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
-rw-r--r--sys-fs/cryptsetup/ChangeLog10
-rw-r--r--sys-fs/cryptsetup/cryptsetup-1.1.0.ebuild90
-rw-r--r--sys-fs/cryptsetup/files/1.1.0_rc3-static-no-selinux.patch18
3 files changed, 116 insertions, 2 deletions
diff --git a/sys-fs/cryptsetup/ChangeLog b/sys-fs/cryptsetup/ChangeLog
index 15115d08a2a5..ce05b3918d72 100644
--- a/sys-fs/cryptsetup/ChangeLog
+++ b/sys-fs/cryptsetup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/cryptsetup
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/ChangeLog,v 1.78 2009/11/30 00:53:54 robbat2 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/ChangeLog,v 1.79 2010/02/14 00:10:59 robbat2 Exp $
+
+*cryptsetup-1.1.0 (14 Feb 2010)
+
+ 14 Feb 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +files/1.1.0_rc3-static-no-selinux.patch, +cryptsetup-1.1.0.ebuild:
+ Version bump per bug #294934.
*cryptsetup-1.0.7-r1 (30 Nov 2009)
diff --git a/sys-fs/cryptsetup/cryptsetup-1.1.0.ebuild b/sys-fs/cryptsetup/cryptsetup-1.1.0.ebuild
new file mode 100644
index 000000000000..04d0c52672b2
--- /dev/null
+++ b/sys-fs/cryptsetup/cryptsetup-1.1.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.1.0.ebuild,v 1.1 2010/02/14 00:10:59 robbat2 Exp $
+
+EAPI=2
+
+inherit linux-info eutils flag-o-matic multilib autotools
+
+MY_P=${P/_rc/-rc}
+DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
+HOMEPAGE="http://code.google.com/p/cryptsetup/"
+SRC_URI="http://cryptsetup.googlecode.com/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="dynamic nls selinux"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND=">=sys-fs/lvm2-2.02.56-r1
+ >=dev-libs/libgcrypt-1.1.42
+ >=dev-libs/libgpg-error-1.0-r1
+ >=dev-libs/popt-1.7
+ >=sys-fs/udev-124
+ || ( >=sys-libs/e2fsprogs-libs-1.41 <sys-fs/e2fsprogs-1.41 )
+ selinux? ( sys-libs/libselinux )
+ !sys-fs/cryptsetup-luks"
+
+pkg_setup() {
+ local CONFIG_CHECK="~DM_CRYPT ~CRYPTO ~CRYPTO_CBC"
+ local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup)\n"
+ local WARNING_CRYPTO_CBC="CONFIG_CRYPTO_CBC:\tis not set (required for kernel 2.6.19)\n"
+ local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup)\n"
+ check_extra_config
+
+ if use dynamic ; then
+ ewarn "If you need cryptsetup for an initrd or initramfs then you"
+ ewarn "should NOT use the dynamic USE flag"
+ epause 5
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.1.0_rc3-static-no-selinux.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sbindir=/sbin \
+ --enable-shared \
+ $(use_enable !dynamic static) \
+ --libdir=/usr/$(get_libdir) \
+ $(use_enable nls) \
+ $(use_enable selinux) \
+ || die
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ rmdir "${D}"/usr/$(get_libdir)/cryptsetup
+ insinto /$(get_libdir)/rcscripts/addons
+ newins "${FILESDIR}"/1.0.6-r2-dm-crypt-start.sh dm-crypt-start.sh || die
+ newins "${FILESDIR}"/1.0.5-dm-crypt-stop.sh dm-crypt-stop.sh || die
+ newconfd "${FILESDIR}"/1.0.6-dmcrypt.confd dmcrypt || die
+ newinitd "${FILESDIR}"/1.0.5-dmcrypt.rc dmcrypt || die
+}
+
+pkg_postinst() {
+ ewarn "This ebuild introduces a new set of scripts and configuration"
+ ewarn "than the last version. If you are currently using /etc/conf.d/cryptfs"
+ ewarn "then you *MUST* copy your old file to:"
+ ewarn "/etc/conf.d/dmcrypt"
+ ewarn "Or your encrypted partitions will *NOT* work."
+ elog "Please see the example for configuring a LUKS mountpoint"
+ elog "in /etc/conf.d/dmcrypt"
+ elog
+ elog "If you are using baselayout-2 then please do:"
+ elog "rc-update add dmcrypt boot"
+ elog "This version introduces a command line arguement 'key_timeout'."
+ elog "If you want the search for the removable key device to timeout"
+ elog "after 10 seconds add the following to your bootloader config:"
+ elog "key_timeout=10"
+ elog "A timeout of 0 will mean it will wait indefinitely."
+}
diff --git a/sys-fs/cryptsetup/files/1.1.0_rc3-static-no-selinux.patch b/sys-fs/cryptsetup/files/1.1.0_rc3-static-no-selinux.patch
new file mode 100644
index 000000000000..d64867d42352
--- /dev/null
+++ b/sys-fs/cryptsetup/files/1.1.0_rc3-static-no-selinux.patch
@@ -0,0 +1,18 @@
+diff -Naur cryptsetup-1.1.0-rc3/configure.in cryptsetup-1.1.0-rc3-areyoufuckingserious/configure.in
+--- cryptsetup-1.1.0-rc3/configure.in 2009-11-16 17:39:37.000000000 -0500
++++ cryptsetup-1.1.0-rc3-areyoufuckingserious/configure.in 2009-11-17 19:49:08.000000000 -0500
+@@ -93,9 +93,11 @@
+ saved_LIBS2=$LIBS
+ LIBS="$LIBS -static"
+ # Check if it there is still not some missing dependency like static selinux libs
+- AC_SEARCH_LIBS([dm_set_selinux_context], [devmapper],,
+- [AC_MSG_ERROR([Your system requires SElinux libraries for static compilation.])])
+- LIBS=$saved_LIBS2
++ if test "x$enable_selinux" != xno; then
++ AC_SEARCH_LIBS([dm_set_selinux_context], [devmapper],,
++ [AC_MSG_ERROR([Your system requires SElinux libraries for static compilation.])])
++ LIBS=$saved_LIBS2
++ fi
+ fi
+
+ LIBS=$saved_LIBS