summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-12 22:46:21 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-12 22:46:21 +0000
commit3e767918ccee09fc40b38b9fbd50a631c9b512a2 (patch)
tree2fa9d3a0c80dcd70a5c376b093c3313498c8ee2a
parentVersion bump. (diff)
downloadgentoo-2-3e767918ccee09fc40b38b9fbd50a631c9b512a2.tar.gz
gentoo-2-3e767918ccee09fc40b38b9fbd50a631c9b512a2.tar.bz2
gentoo-2-3e767918ccee09fc40b38b9fbd50a631c9b512a2.zip
Version bump.
(Portage version: 2.2.0_alpha23_p3/cvs/Linux x86_64)
-rw-r--r--www-servers/tornado/ChangeLog10
-rw-r--r--www-servers/tornado/tornado-1.1.1.ebuild38
2 files changed, 46 insertions, 2 deletions
diff --git a/www-servers/tornado/ChangeLog b/www-servers/tornado/ChangeLog
index 4443318d4bb1..363fbd5f54e8 100644
--- a/www-servers/tornado/ChangeLog
+++ b/www-servers/tornado/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/tornado
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tornado/ChangeLog,v 1.8 2010/10/29 19:35:01 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tornado/ChangeLog,v 1.9 2011/02/12 22:46:21 arfrever Exp $
+
+*tornado-1.1.1 (12 Feb 2011)
+
+ 12 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +tornado-1.1.1.ebuild:
+ Version bump.
29 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-tornado-0.2.ebuild, -tornado-1.0.ebuild:
diff --git a/www-servers/tornado/tornado-1.1.1.ebuild b/www-servers/tornado/tornado-1.1.1.ebuild
new file mode 100644
index 000000000000..91d315be524e
--- /dev/null
+++ b/www-servers/tornado/tornado-1.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tornado/tornado-1.1.1.ebuild,v 1.1 2011/02/12 22:46:21 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+DESCRIPTION="Scalable, non-blocking web server and tools"
+HOMEPAGE="http://www.tornadoweb.org/ http://pypi.python.org/pypi/tornado"
+SRC_URI="http://github.com/downloads/facebook/tornado/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pycurl
+ || ( dev-lang/python:2.7 dev-lang/python:2.6 dev-python/simplejson )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable failing test.
+ sed -e "s/test_ssl/_&/" -i tornado/test/httpserver_test.py
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="." "$(PYTHON)" tornado/test/runtests.py
+ }
+ python_execute_function testing
+}