summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-11-05 07:07:26 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-11-05 07:07:26 +0000
commit31d5f79dd63672e67ed70b1e0b1620634dd7bf8b (patch)
tree06b1059ec14ae57ccecc027374147e7d41aa9596
parentAdd proper autoconf dependency (via WANT_AUTOCONF), bug #149504 (diff)
downloadgentoo-2-31d5f79dd63672e67ed70b1e0b1620634dd7bf8b.tar.gz
gentoo-2-31d5f79dd63672e67ed70b1e0b1620634dd7bf8b.tar.bz2
gentoo-2-31d5f79dd63672e67ed70b1e0b1620634dd7bf8b.zip
rev bump. Changed init script to generate machine id as per new upstream recommendation. Cleaned up initscript.
(Portage version: 2.1.2_rc1-r3)
-rw-r--r--sys-apps/dbus/ChangeLog9
-rw-r--r--sys-apps/dbus/dbus-0.95.ebuild103
-rw-r--r--sys-apps/dbus/files/dbus.init-0.9550
-rw-r--r--sys-apps/dbus/files/digest-dbus-0.953
4 files changed, 164 insertions, 1 deletions
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index 2ed329aeea55..38349384e6e6 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/dbus
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.141 2006/11/03 02:14:41 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.142 2006/11/05 07:07:26 cardoe Exp $
+
+*dbus-0.95 (05 Nov 2006)
+
+ 05 Nov 2006; Doug Goldstein <cardoe@gentoo.org> +files/dbus.init-0.95,
+ +dbus-0.95.ebuild:
+ rev bump. Changed init script to generate machine id as per new upstream
+ recommendation. Cleaned up initscript.
03 Nov 2006; Sven Wegener <swegener@gentoo.org> dbus-0.62-r1.ebuild,
dbus-0.94.ebuild:
diff --git a/sys-apps/dbus/dbus-0.95.ebuild b/sys-apps/dbus/dbus-0.95.ebuild
new file mode 100644
index 000000000000..4974a9cee9ca
--- /dev/null
+++ b/sys-apps/dbus/dbus-0.95.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-0.95.ebuild,v 1.1 2006/11/05 07:07:26 cardoe Exp $
+
+WANT_AUTOCONF=2.5
+inherit eutils multilib debug autotools
+
+DESCRIPTION="A message bus system, a simple way for applications to talk to each other"
+HOMEPAGE="http://dbus.freedesktop.org/"
+SRC_URI="http://dbus.freedesktop.org/releases/dbus/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc selinux X"
+
+RDEPEND="X? ( x11-libs/libXt x11-libs/libX11 )
+ selinux? ( sys-libs/libselinux )
+ >=dev-libs/expat-1.95.8
+ !<sys-apps/dbus-0.91"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen
+ app-text/xmlto )"
+
+src_compile() {
+ local myconf=""
+
+ hasq test ${FEATURES} && myconf="${myconf} --enable-tests=yes"
+
+ econf \
+ $(use_with X x) \
+ $(use_enable kernel_linux dnotify) \
+ $(use_enable kernel_FreeBSD kqueue) \
+ $(use_enable selinux) \
+ $(use_enable debug verbose-mode) \
+ $(use_enable debug asserts) \
+ --with-xml=expat \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --with-system-socket=/var/run/dbus/system_bus_socket \
+ --with-session-socket-dir=/tmp \
+ --with-dbus-user=messagebus \
+ --localstatedir=/var \
+ $(use_enable doc doxygen-docs) \
+ --disable-xml-docs \
+ ${myconf} \
+ || die "econf failed"
+
+ # after the compile, it uses a selinuxfs interface to
+ # check if the SELinux policy has the right support
+ use selinux && addwrite /selinux/access
+
+ emake || die "make failed"
+}
+
+src_test() {
+ DBUS_VERBOSE=1 make check || die "make check failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # initscript
+ newinitd "${FILESDIR}"/dbus.init-0.95 dbus
+
+ # dbus X session script (#77504)
+ # turns out to only work for GDM. has been merged into other desktop
+ # (kdm and such scripts)
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}"/30-dbus
+
+ # needs to exist for the system socket
+ keepdir /var/run/dbus
+ # needs to exist for machine id
+ keepdir /var/lib/dbus
+
+ keepdir /usr/lib/dbus-1.0/services
+ keepdir /usr/share/dbus-1/services
+
+ dodoc AUTHORS ChangeLog HACKING NEWS README doc/TODO
+ if use doc; then
+ dohtml doc/*html
+ fi
+}
+
+pkg_preinst() {
+ enewgroup messagebus || die "Problem adding messagebus group"
+ enewuser messagebus -1 "-1" -1 messagebus || die "Problem adding messagebus user"
+}
+
+pkg_postinst() {
+ elog "To start the D-Bus system-wide messagebus by default"
+ elog "you should add it to the default runlevel :"
+ elog "\`rc-update add dbus default\`"
+ elog "Currently have it installed and running?"
+ elog "Run etc-update and then run the following:"
+ elog "\`/etc/init.d/dbus reload\`"
+ elog "This will cause it to reload it's configs but"
+ elog "not run the newest version you just installed."
+ elog "You must tell it to restart for that to happen,"
+ elog "however not all apps can handle a D-Bus restart."
+}
diff --git a/sys-apps/dbus/files/dbus.init-0.95 b/sys-apps/dbus/files/dbus.init-0.95
new file mode 100644
index 000000000000..c8ca38164e16
--- /dev/null
+++ b/sys-apps/dbus/files/dbus.init-0.95
@@ -0,0 +1,50 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/files/dbus.init-0.95,v 1.1 2006/11/05 07:07:26 cardoe Exp $
+
+opts="reload"
+
+depend() {
+ after nscd dns
+}
+
+start() {
+ ebegin "Starting D-BUS system messagebus"
+
+ /usr/bin/dbus-uuidgen --ensure
+
+ # We need to test if /var/run/dbus exists, since script will fail if it does not
+ [[ ! -e /var/run/dbus ]] && mkdir /var/run/dbus
+
+ start-stop-daemon --start --pidfile /var/run/dbus.pid --exec /usr/bin/dbus-daemon -- --system
+ eend $?
+}
+
+stop() {
+ local retval
+
+ ebegin "Stopping D-BUS system messagebus"
+
+ start-stop-daemon --stop --pidfile /var/run/dbus.pid
+ retval=$?
+
+ eend ${retval}
+
+ [[ -S /var/run/dbus/system_bus_socket ]] && rm -f /var/run/dbus/system_bus_socket
+
+ return ${retval}
+}
+
+reload() {
+ local retval
+
+ ebegin "Reloading D-BUS messagebus config"
+
+ /usr/bin/dbus-send --print-reply --system --type=method_call \
+ --dest=org.freedesktop.DBus \
+ / org.freedesktop.DBus.ReloadConfig > /dev/null
+ retval=$?
+ eend ${retval}
+ return ${retval}
+}
diff --git a/sys-apps/dbus/files/digest-dbus-0.95 b/sys-apps/dbus/files/digest-dbus-0.95
new file mode 100644
index 000000000000..94b316919d3d
--- /dev/null
+++ b/sys-apps/dbus/files/digest-dbus-0.95
@@ -0,0 +1,3 @@
+MD5 c660e2c6345cbe5edc5e2486570148af dbus-0.95.tar.gz 1400507
+RMD160 bbe7a1b573c40229c65c4e85174bfdd3dcabf64c dbus-0.95.tar.gz 1400507
+SHA256 9bd989a5116320aa56531745904881f1a03a612d201f718374fbe223dfae7592 dbus-0.95.tar.gz 1400507