summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-05-04 08:53:40 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-05-04 08:53:40 +0000
commit31a4ef9348df7c6506745b50d90478fb42ee066e (patch)
tree98c76b1ddc45f5f2d347f7a92f9c5f9ced7ff572
parentAdd prediction use flag for pidgin wrt bug #176923. (diff)
downloadgentoo-2-31a4ef9348df7c6506745b50d90478fb42ee066e.tar.gz
gentoo-2-31a4ef9348df7c6506745b50d90478fb42ee066e.tar.bz2
gentoo-2-31a4ef9348df7c6506745b50d90478fb42ee066e.zip
Add prediction use flag for pidgin wrt bug #176923.
Thanks to Tristan Heaven for reporting. (Portage version: 2.1.2.4)
-rw-r--r--net-im/pidgin/ChangeLog7
-rw-r--r--net-im/pidgin/pidgin-2.0.0_beta7.ebuild8
2 files changed, 11 insertions, 4 deletions
diff --git a/net-im/pidgin/ChangeLog b/net-im/pidgin/ChangeLog
index a6bb951b1ae0..7346ea5c55d2 100644
--- a/net-im/pidgin/ChangeLog
+++ b/net-im/pidgin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/pidgin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.3 2007/05/01 14:17:18 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.4 2007/05/04 08:53:40 drizzt Exp $
+
+ 04 May 2007; Timothy Redaelli <drizzt@gentoo.org>
+ pidgin-2.0.0_beta7.ebuild:
+ Add prediction use flag for pidgin wrt bug #176923.
+ Thanks to Tristan Heaven for reporting.
01 May 2007; Olivier Crête <tester@gentoo.org> pidgin-2.0.0_beta7.ebuild:
Disabled mono support because it causes to many problems
diff --git a/net-im/pidgin/pidgin-2.0.0_beta7.ebuild b/net-im/pidgin/pidgin-2.0.0_beta7.ebuild
index aea16bc4d917..0877399ee51b 100644
--- a/net-im/pidgin/pidgin-2.0.0_beta7.ebuild
+++ b/net-im/pidgin/pidgin-2.0.0_beta7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.0.0_beta7.ebuild,v 1.3 2007/05/01 14:17:18 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.0.0_beta7.ebuild,v 1.4 2007/05/04 08:53:40 drizzt Exp $
inherit flag-o-matic eutils toolchain-funcs multilib autotools perl-app gnome2
@@ -14,7 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="avahi bonjour cjk crypt dbus debug doc eds gadu gnutls gstreamer meanwhile nls perl silc startup-notification tcl tk xscreensaver custom-cflags spell ssl qq msn gadu"
-IUSE="${IUSE} gtk sasl console groupwise" # mono"
+IUSE="${IUSE} gtk sasl console groupwise prediction" # mono"
RDEPEND="
bonjour? ( !avahi? ( net-misc/howl )
@@ -49,7 +49,8 @@ RDEPEND="
gstreamer? ( >=media-libs/gstreamer-0.10 )
sasl? ( >=dev-libs/cyrus-sasl-2 )
doc? ( app-doc/doxygen )
- dev-libs/libxml2"
+ dev-libs/libxml2
+ prediction? ( =dev-db/sqlite-3.3* )"
#mono? ( dev-lang/mono )"
DEPEND="$RDEPEND
@@ -245,6 +246,7 @@ src_compile() {
$(use_enable gstreamer) \
$(use_enable sasl cyrus-sasl ) \
$(use_enable doc doxygen) \
+ $(use_enable prediction cap) \
"--with-dynamic-prpls=${DYNAMIC_PRPLS}" \
${myconf} || die "Configuration failed"
#$(use_enable mono) \