summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-26 13:56:35 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-26 13:56:35 +0000
commit2ec95d26e515f04d66c08ce407299bfb8e7b2a86 (patch)
tree96672144f4c03834e3fc973e2205670170c8af0d
parentuse $(tc-getCC) (Manifest recommit) (diff)
downloadgentoo-2-2ec95d26e515f04d66c08ce407299bfb8e7b2a86.tar.gz
gentoo-2-2ec95d26e515f04d66c08ce407299bfb8e7b2a86.tar.bz2
gentoo-2-2ec95d26e515f04d66c08ce407299bfb8e7b2a86.zip
use $(tc-getCC)
-rw-r--r--dev-util/pscan/pscan-20000721.ebuild21
-rw-r--r--games-arcade/excido/excido-0.1.5c.ebuild8
2 files changed, 17 insertions, 12 deletions
diff --git a/dev-util/pscan/pscan-20000721.ebuild b/dev-util/pscan/pscan-20000721.ebuild
index 1b2c553328f0..95a208c0ca9b 100644
--- a/dev-util/pscan/pscan-20000721.ebuild
+++ b/dev-util/pscan/pscan-20000721.ebuild
@@ -1,25 +1,30 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pscan/pscan-20000721.ebuild,v 1.2 2004/10/17 10:00:21 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pscan/pscan-20000721.ebuild,v 1.3 2004/10/26 13:53:46 vapier Exp $
-DESCRIPTION="PScan: A limited problem scanner for C source files"
+inherit toolchain-funcs
+
+DESCRIPTION="A limited problem scanner for C source files"
HOMEPAGE="http://www.striker.ottawa.on.ca/~aland/pscan/"
# I wish upstream would version their files, even if it's only with a date
SRC_URI="http://www.striker.ottawa.on.ca/~aland/pscan/pscan.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~ppc ~x86"
IUSE=""
+
RDEPEND="virtual/libc"
-DEPEND="${RDEPEND} sys-devel/gcc sys-devel/flex"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
S="${WORKDIR}/${PN}"
src_compile() {
- emake CC="gcc ${CFLAGS}"
+ emake CC="$(tc-getCC) ${CFLAGS}" || die
}
src_install() {
- into /usr
- dobin pscan
- dodoc COPYING README find_formats.sh test.c wu-ftpd.pscan
+ dobin pscan || die
+ dodoc README find_formats.sh test.c wu-ftpd.pscan
}
diff --git a/games-arcade/excido/excido-0.1.5c.ebuild b/games-arcade/excido/excido-0.1.5c.ebuild
index cf9d091df8c2..1c432e679f95 100644
--- a/games-arcade/excido/excido-0.1.5c.ebuild
+++ b/games-arcade/excido/excido-0.1.5c.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/excido/excido-0.1.5c.ebuild,v 1.2 2004/08/28 23:02:13 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/excido/excido-0.1.5c.ebuild,v 1.3 2004/10/26 13:56:35 vapier Exp $
-inherit gcc games
+inherit games toolchain-funcs
DESCRIPTION="A fast paced action game"
HOMEPAGE="http://icculus.org/excido/"
@@ -10,7 +10,7 @@ SRC_URI="http://icculus.org/excido/${P}-src.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~amd64 ~ppc"
+KEYWORDS="~amd64 ~ppc x86"
IUSE=""
DEPEND="dev-games/physfs
@@ -22,7 +22,7 @@ DEPEND="dev-games/physfs
src_compile() {
emake \
- CC="$(gcc-getCXX)" \
+ CC="$(tc-getCXX)" \
PREFIX="/usr" \
BINDIR="${GAMES_BINDIR}/" \
DATADIR="${GAMES_DATADIR}/${PN}/" \