summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2012-08-11 09:14:47 +0000
committerBenedikt Boehm <hollow@gentoo.org>2012-08-11 09:14:47 +0000
commit299233f6fddc5fdaf7e883cc21eec9c954ec57cc (patch)
tree6068149cf64284bfdef348bbacf25b4166c1dd24
parentInstall udev rules file to documentation directory and notify user of its pur... (diff)
downloadgentoo-2-299233f6fddc5fdaf7e883cc21eec9c954ec57cc.tar.gz
gentoo-2-299233f6fddc5fdaf7e883cc21eec9c954ec57cc.tar.bz2
gentoo-2-299233f6fddc5fdaf7e883cc21eec9c954ec57cc.zip
version bump + ruby19 support
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
-rw-r--r--dev-ruby/ohai/ChangeLog9
-rw-r--r--dev-ruby/ohai/files/ohai-6.14.0-multiple-ruby.patch17
-rw-r--r--dev-ruby/ohai/files/ohai-lsb-release.patch20
-rw-r--r--dev-ruby/ohai/ohai-6.14.0.ebuild (renamed from dev-ruby/ohai/ohai-0.6.10.ebuild)16
4 files changed, 33 insertions, 29 deletions
diff --git a/dev-ruby/ohai/ChangeLog b/dev-ruby/ohai/ChangeLog
index 32aad91331e3..4b65b453a96e 100644
--- a/dev-ruby/ohai/ChangeLog
+++ b/dev-ruby/ohai/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/ohai
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ChangeLog,v 1.10 2012/04/29 15:26:43 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ChangeLog,v 1.11 2012/08/11 09:14:47 hollow Exp $
+
+*ohai-6.14.0 (11 Aug 2012)
+
+ 11 Aug 2012; Benedikt Böhm <hollow@gentoo.org> -ohai-0.6.10.ebuild,
+ +ohai-6.14.0.ebuild, +files/ohai-6.14.0-multiple-ruby.patch,
+ -files/ohai-lsb-release.patch:
+ version bump + ruby19 support
*ohai-0.6.12 (29 Apr 2012)
diff --git a/dev-ruby/ohai/files/ohai-6.14.0-multiple-ruby.patch b/dev-ruby/ohai/files/ohai-6.14.0-multiple-ruby.patch
new file mode 100644
index 000000000000..1206fb33c674
--- /dev/null
+++ b/dev-ruby/ohai/files/ohai-6.14.0-multiple-ruby.patch
@@ -0,0 +1,17 @@
+diff --git a/lib/ohai/plugins/ruby.rb b/lib/ohai/plugins/ruby.rb
+index a54de8e..67591d0 100644
+--- a/lib/ohai/plugins/ruby.rb
++++ b/lib/ohai/plugins/ruby.rb
+@@ -20,9 +20,11 @@ provides "languages/ruby"
+
+ require_plugin "languages"
+
++require 'rbconfig'
+
+ def run_ruby(command)
+- cmd = "ruby -e \"require 'rbconfig'; #{command}\""
++ ruby = ::File.join(::Config::CONFIG['bindir'], ::Config::CONFIG['ruby_install_name'])
++ cmd = %{#{ruby} -e "require 'rbconfig'; #{command}"}
+ status, stdout, stderr = run_command(:no_status_check => true, :command => cmd)
+ stdout.strip
+ end
diff --git a/dev-ruby/ohai/files/ohai-lsb-release.patch b/dev-ruby/ohai/files/ohai-lsb-release.patch
deleted file mode 100644
index e67e4f61dd12..000000000000
--- a/dev-ruby/ohai/files/ohai-lsb-release.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/lib/ohai/plugins/linux/lsb.rb
-+++ b/lib/ohai/plugins/linux/lsb.rb
-@@ -23,13 +23,13 @@ lsb Mash.new
- begin
- File.open("/etc/lsb-release").each do |line|
- case line
-- when /^DISTRIB_ID=(.+)$/
-+ when /^DISTRIB_ID=["']?(.+?)["']?$/
- lsb[:id] = $1
-- when /^DISTRIB_RELEASE=(.+)$/
-+ when /^DISTRIB_RELEASE=["']?(.+?)["']?$/
- lsb[:release] = $1
-- when /^DISTRIB_CODENAME=(.+)$/
-+ when /^DISTRIB_CODENAME=["']?(.+?)["']?$/
- lsb[:codename] = $1
-- when /^DISTRIB_DESCRIPTION=(.+)$/
-+ when /^DISTRIB_DESCRIPTION=["']?(.+?)["']?$/
- lsb[:description] = $1
- end
- end
diff --git a/dev-ruby/ohai/ohai-0.6.10.ebuild b/dev-ruby/ohai/ohai-6.14.0.ebuild
index 224d538b31ff..c387271735fe 100644
--- a/dev-ruby/ohai/ohai-0.6.10.ebuild
+++ b/dev-ruby/ohai/ohai-6.14.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ohai-0.6.10.ebuild,v 1.2 2012/03/05 10:29:56 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ohai-6.14.0.ebuild,v 1.1 2012/08/11 09:14:47 hollow Exp $
EAPI=4
-USE_RUBY="ruby18"
+USE_RUBY="ruby18 ruby19"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
@@ -22,20 +22,20 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/sigar )"
+RUBY_PATCHES=( "${FILESDIR}/ohai-6.14.0-multiple-ruby.patch" )
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
ruby_add_rdepend "
- dev-ruby/yajl-ruby
+ dev-ruby/ipaddress
dev-ruby/mixlib-cli
dev-ruby/mixlib-config
dev-ruby/mixlib-log
- >=dev-ruby/systemu-2.2.0"
+ dev-ruby/systemu
+ dev-ruby/yajl-ruby"
all_ruby_prepare() {
rm Gemfile || die
- # Be more lenient to work with versions of systemu that we have in
- # the tree.
- sed -i -e 's/~> 2.2.0/>= 2.2.0/' ohai.gemspec || die
}
all_ruby_install() {