summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-07-03 12:04:07 +0000
committerMark Wright <gienah@gentoo.org>2014-07-03 12:04:07 +0000
commit21343b58ef35b82e492b2dea466dd324ec950af0 (patch)
tree6572d478d2ce87bb3336f26bcb4cf6891468e821
parentBump hdbc to 2.4.0.0 (diff)
downloadgentoo-2-21343b58ef35b82e492b2dea466dd324ec950af0.tar.gz
gentoo-2-21343b58ef35b82e492b2dea466dd324ec950af0.tar.bz2
gentoo-2-21343b58ef35b82e492b2dea466dd324ec950af0.zip
Bump hdbc-postgresql to 2.3.2.2-r2
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
-rw-r--r--dev-haskell/hdbc-postgresql/ChangeLog8
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.2-r2.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-haskell/hdbc-postgresql/ChangeLog b/dev-haskell/hdbc-postgresql/ChangeLog
index 4515721cb5fc..7064bfdba6c8 100644
--- a/dev-haskell/hdbc-postgresql/ChangeLog
+++ b/dev-haskell/hdbc-postgresql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/hdbc-postgresql
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/ChangeLog,v 1.24 2014/01/14 08:34:09 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/ChangeLog,v 1.25 2014/07/03 12:04:07 gienah Exp $
+
+*hdbc-postgresql-2.3.2.2-r2 (03 Jul 2014)
+
+ 03 Jul 2014; Mark Wright <gienah@gentoo.org>
+ +hdbc-postgresql-2.3.2.2-r2.ebuild:
+ Bump hdbc-postgresql to 2.3.2.2-r2
*hdbc-postgresql-2.3.2.2-r1 (14 Jan 2014)
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.2-r2.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.2-r2.ebuild
new file mode 100644
index 000000000000..59eeff65eb3a
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.2-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.2-r2.ebuild,v 1.1 2014/07/03 12:04:07 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+CABAL_FEATURES+=" nocabaldep" # workaround depend on old cabal-1.16
+inherit haskell-cabal
+
+MY_PN="HDBC-postgresql"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL driver for HDBC"
+HOMEPAGE="http://github.com/hdbc/hdbc-postgresql"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # requires configured postgresql
+
+RDEPEND=">=dev-db/postgresql-base-7
+ dev-haskell/convertible:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ >=dev-haskell/hdbc-2.2.0:2=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+ test? ( >=dev-haskell/hdbc-2.2.6:=[profile?]
+ dev-haskell/hunit:=[profile?]
+ dev-haskell/quickcheck:2=[profile?]
+ dev-haskell/testpack:=[profile?] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}