summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-09-29 06:50:43 +0000
committerPeter Volkov <pva@gentoo.org>2007-09-29 06:50:43 +0000
commit210bc23467aefb5830fdfb39a2162d7bc95ae5c5 (patch)
treea0b62b5e46887992cd44d4fdfb65f8c4b2e395da
parentHandle fpe in ri contrib package. Closes #193683 (diff)
downloadgentoo-2-210bc23467aefb5830fdfb39a2162d7bc95ae5c5.tar.gz
gentoo-2-210bc23467aefb5830fdfb39a2162d7bc95ae5c5.tar.bz2
gentoo-2-210bc23467aefb5830fdfb39a2162d7bc95ae5c5.zip
Use tc-getCC compiler, fixes bug #193793, reported by Chris Slycord <cslycord AT gmail.com>
(Portage version: 2.1.3.10)
-rw-r--r--net-analyzer/netselect/ChangeLog8
-rw-r--r--net-analyzer/netselect/files/digest-netselect-0.3-r23
-rw-r--r--net-analyzer/netselect/netselect-0.3-r2.ebuild45
3 files changed, 55 insertions, 1 deletions
diff --git a/net-analyzer/netselect/ChangeLog b/net-analyzer/netselect/ChangeLog
index f6561df7a5ab..c829e1c63dc1 100644
--- a/net-analyzer/netselect/ChangeLog
+++ b/net-analyzer/netselect/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/netselect
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/ChangeLog,v 1.29 2007/04/30 13:32:25 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/ChangeLog,v 1.30 2007/09/29 06:50:43 pva Exp $
+
+*netselect-0.3-r2 (29 Sep 2007)
+
+ 29 Sep 2007; <pva@gentoo.org> +netselect-0.3-r2.ebuild:
+ Use tc-getCC compiler, fixes bug #193793, reported by Chris Slycord
+ <cslycord AT gmail.com>
30 Apr 2007; Cedric Krier <cedk@gentoo.org> netselect-0.3-r1.ebuild:
Fix HOMEPAGE and SRC_URI for bug #176200
diff --git a/net-analyzer/netselect/files/digest-netselect-0.3-r2 b/net-analyzer/netselect/files/digest-netselect-0.3-r2
new file mode 100644
index 000000000000..b8cf6541048d
--- /dev/null
+++ b/net-analyzer/netselect/files/digest-netselect-0.3-r2
@@ -0,0 +1,3 @@
+MD5 3a3714946db2458e5db3d55373057ef2 netselect-0.3.tar.gz 22047
+RMD160 f57b7348549a033c008d3b67b85ef12a3f91c9aa netselect-0.3.tar.gz 22047
+SHA256 fe81942589d5219d030e5cecfb12787fb6d3613416cb326dea4952bf53f9c978 netselect-0.3.tar.gz 22047
diff --git a/net-analyzer/netselect/netselect-0.3-r2.ebuild b/net-analyzer/netselect/netselect-0.3-r2.ebuild
new file mode 100644
index 000000000000..fded24afdc36
--- /dev/null
+++ b/net-analyzer/netselect/netselect-0.3-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/netselect-0.3-r2.ebuild,v 1.1 2007/09/29 06:50:43 pva Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Ultrafast implementation of ping."
+HOMEPAGE="http://alumnit.ca/~apenwarr/netselect/index.html"
+SRC_URI="http://alumnit.ca/~apenwarr/netselect/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-bsd.patch"
+}
+
+src_compile() {
+ append-ldflags $(bindnow-flags)
+
+ sed -i \
+ -e "s:PREFIX =.*:PREFIX = ${D}usr:" \
+ -e "s:CFLAGS =.*:CFLAGS = -Wall -I. -g ${CFLAGS}:" \
+ -e "s:LDFLAGS =.*:LDFLAGS = -g ${LDFLAGS}:" \
+ -e '23,27d' \
+ -e '34d' \
+ Makefile \
+ || die "sed Makefile failed"
+
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install () {
+ dobin netselect || die "dobin failed"
+ fowners root:wheel /usr/bin/netselect
+ fperms 4711 /usr/bin/netselect
+ dodoc ChangeLog HISTORY README*
+}